6 Replies Latest reply: Apr 14, 2012 12:52 PM by marsofhouston
shura.sena Level 1 (0 points)

It's been about a month that I cannot login to apple support communities using my regular apple ID. The system returns - @Account could not be created".

I fill out the support form at the same page, and post it, countless times ... with zero feedback from Apple. I had to register another apple id to write this question.

  • Carolyn Samit Level 10 (103,365 points)

    If you are using Safari, from the menu bar click Safari / Preferences then select the Security tab. Click: Show Cookies.

     

    Type in apple top right corner in the search field, click Remove All.

     

    Now click Safari from the menu bar, scroll down and click: Empty Cache.

     

    Quit then relaunch Safari. Try logging into ASC.

     

    If you still have problems, check out Apple ID FAQ's...

     

    http://support.apple.com/kb/he37

  • shura.sena Level 1 (0 points)

    Sorry Carolyn, it won't work. Tried that already, and tried to login from different computers, just now from a freshly installed iMac - still

    account could not be created due to system issues. Please contact support communities using form below....

    I used that form below for 10 times already, over the whole of the past month, it seems there is nobody at the other end of the form to contact.

    Very unsatisfactory work for Apple support

  • Matt K. Level 4 (2,380 points)

    Hi shura.sena,

     

    I sent you an email to the address associated with shura.sena username.

     

    Thanks

  • shura.sena Level 1 (0 points)

    Hi Matt,

    thanks for support. Maybe you have to check if the automatic feedback form that appears along with the error is really working and sending info to somebody alive.

  • BarryMcKelvey Level 1 (0 points)

    Hi Matt

     

    I cant sign into Apple discussions with my Apple ID. My username connected with that account is barrymckelvey. I can log in with another Apple ID but its got all my posts listed that I'd made with my current Apple ID for some reason. If u can sort this out for me, Id be very grateful.

     

    Many Thanks

     

    Barry McKelvey

  • marsofhouston Level 1 (0 points)

    I am having a very similar problem.

     

    I am unable to sign into the Support Community with marsofearth@gmail.com very strange.

     

    Is there any remedy for this issue. Tried all of the above suggestions.

     

    Mars