Skip navigation

iPhone 4 cannot connect to home Wi-Fi

797093 Views 678 Replies Latest reply: Apr 10, 2014 10:01 PM by WilliamDA RSS Branched to a new discussion.
  • Debelina Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 12:27 PM (in response to Bobbygiorgiii)

    Thank you!  I had to reset my wireless modem.  All fixed now.

  • J251 Calculating status...
    Currently Being Moderated
    Jan 31, 2013 1:43 PM (in response to iRageU95)

    INTERFERENCE FROM WIRELESS PRINTER!

     

    I had the same problem with my iPhone 4 and then 4S, when I upgraded to that model: It connected to every WiFi network except to ours at home (consisting of 9 other devices, 4 of them iOS devices, that have had no connectivity problems whatsoever).

     

    I tried everything listed in this thread. I also telephoned Apple technical support which determined that it is one of three things: (1) the router is too old to support the iPhone (the router was manufactured 3 years ago and has the latest firmware update, but I went and purchased an Airport Express, and the problem persisted); (2) the 2.4GHz went bad on the router (but the gaming consoles are 2.4GHz and they connect fine!); or (3) there is a channel conflict (ours is set to a different channel than any of the other networks in range).

     

    What it turned out to be was interference from our Canon wireless printer. (It wasn't a device conflict, as the printer and iPhone are assigned two different IP addresses.) If I use the printer's USB connection instead, the WiFi on my iPhone works like a charm!!

     

    Perhaps this might help to resolve the issue for others.

  • mimitaryn Calculating status...
    Currently Being Moderated
    Feb 4, 2013 12:36 AM (in response to jaymphd)

    Hi

     

    This has worked for me too!!! Thank  you

  • vidder911 Calculating status...
    Currently Being Moderated
    Feb 4, 2013 2:17 AM (in response to mimitaryn)

    FOUND A FIX!

     

    Hey. Updated my iOS this morning on my 5 and iPad 3 and had the same stupid problem of not being able to connect to ANY wi-fi router. After trying most of the basic fixes (reset, backup/restore, router reset, etc.) nothing worked.

     

    Got an idea and instead of the phone/ipad connecting to the router, I went into the router and added both devices' MAC addresses to the router's whitelist. This helped the router pre-identify my device and let me through as soon as I typed my WPA2/TKIP password in. On both my idevices, I tapped the > icon next to my wi-fi connection and switched the HTTP proxy to auto. WORKED!

     

    So here's a simple step by step process:

    Open router menu (usually 192.168.1.1 or 0.1) in your pc/laptop browser

    Go into your configuration menu and look for "MAC Address Filtering"

    When you find it, go in and add your idevices' MAC address(es) to the "whitelist"

    (to find your MAC address, goto settings->general->about and scroll all the way down.)

    Confirm, reboot your router and try reconnecting to your wi-fi on your devices.

    Also, you might be able to connect (wifi symbol will turn on, but your won't have internet access), then goto settings->wi-fi-> your connection-> and turn HTTP PROXY to AUTO. This should solve the connectivity problem.

  • goapsy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2013 5:16 AM (in response to iRageU95)

    I sold my 4S and got SE Xperia, rooted it, installed custom firmware and kernel. Best in the world, AND NO PROBLEMS HERE

  • Woogy Calculating status...
    Currently Being Moderated
    Feb 4, 2013 7:58 AM (in response to iRageU95)

    Ok so after struggling to connect my iPhone 4S to my Airport Express for ages, and after reading all the posts and fixes I have found a solution which seems to work for me (so far).

     

    First I tried resetting the AE and the iPhone network settings at the same time, which worked initially but only lasted a day.

     

    From everything I've read it seems the main problem is that the 4S is having trouble connecting on the 802.11a/n on the AE.

     

    This is what I did that has worked for me so far:

     

    First reset the network settings on your iphone.

     

    In Airport Utility go to the Wireless tab.

    Change the radio mode to 802.11a/n-802.11b/g.

    Change the radio Channel Selection to "manual".

    Set the 5GHz to automatic and the 2.4GHz to 11.

     

    Before you click on Update, make sure your iphone is in front of you in the WiFi section (and that wifi is turned on).

     

    Click update in Airport Utility. This will reset your Airport.

    Now watch your phone.

    AS SOON AS YOUR WIFI NETWORK APPEARS on your iPhone, tap it and connect.

     

    I really hope this helps some people as this has been a very frustrating problem!

  • J251 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2013 2:48 PM (in response to mimitaryn)

    Great! You're welcome.

  • Susan5s Calculating status...
    Currently Being Moderated
    Feb 11, 2013 10:45 AM (in response to Bobbygiorgiii)

    Thanks for this info. Worked for me.

  • strabucco Calculating status...
    Currently Being Moderated
    Feb 18, 2013 7:21 AM (in response to brendan5689)

    The problem I'm having is pretty similar issue. My wi-fi was working fine until my power went out last night. Even almost 12 hours after it came back on, I'm still not able to connect. I tried the "forget this network" option and after typing in the correct password over 20 times I still cannot connect. But the computers in my home are working fine with the wi-fi connection. I know almost nothing about computers, so all of these responses are doing nothing for me. So if someone could explain step-by-step what to do, that would be wonderful.

  • Herok Calculating status...
    Currently Being Moderated
    Feb 18, 2013 8:51 AM (in response to iRageU95)

    Hi William,

     

    I had a similiar problem to you after an upgrade, but now I'm able to connect to W-Fi.

     

    Settings>Wi-Fi>select blue circle on the right from network that you want to connect>IP Adress>BootP

     

    This worked for me.

     

    Best regards,

    Herok

  • Andy Skowronski Calculating status...
    Currently Being Moderated
    Feb 20, 2013 3:00 PM (in response to iRageU95)

    My iPhone 4s running iOS 6.1.1 was working fine until this afternoon. Then it couldn't get wifi. Not at home, not anywhere. I see that iOS6.2.1 is released and I install it. Still no wifi.

    Makes a smart phone pretty **** useless.

     

    And I have tried all the restarts and such. Nothing works.

     

    FIX THIS NOW.

  • JoanieNeu Calculating status...
    Currently Being Moderated
    Feb 21, 2013 7:20 AM (in response to vidder911)

    Fantastic idea....but my router will not allow me to update that page. Ugh! I just updated to iOS 6.1.2 to help with battery drain issues and now my 4s will not accept my wifi password. All other PCs, iPAD, phones working fine. Just mine. Have tried every idea in this forum multiple times and still no luck. So frustrated!!

  • Allan517 Calculating status...
    Currently Being Moderated
    Feb 25, 2013 2:01 AM (in response to iRageU95)

    I have had many problems like this but the main thing I have learnt is that it is the interference we get from all the other devies - laptops, cordless phones, comuters, Foxtel, iPads, etc., etc., etc., plus we live in a double brick house, so the signal from the router is very poor. When I stand next to the router the iphone picks up the wifi, but if I walk 10 metres away, it loses it. Solution is to get a booster for the router. I found that this works for me.

  • janis25 Calculating status...
    Currently Being Moderated
    Mar 8, 2013 3:06 PM (in response to ACable)

    Thank you. I tried every suggestion offered at all the sites.  Yours is what worked for me (and I also have Wrt54G).

    I looked for a "new" network, even though I was typing in the same network name the iphone was trying to connect to.  Under settings, I picked "WPA" (not the WPA-2 you suggested) and WHEW! after weeks of typing in my network password every time I entered the house, I was finally okay.  I have so much gratitude to these boards for helping everyday people like me figure out our tech problems.

  • Jaxbeachgirl Calculating status...
    Currently Being Moderated
    Mar 14, 2013 6:18 PM (in response to iRageU95)

    Just had this happen to me... Reset my router and all is good now...

1 ... 40 41 42 43 44 ... 46 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (22)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.