Previous 1 41 42 43 44 45 46 Next 688 Replies Latest reply: Jun 22, 2015 12:59 PM by TheHeadmare Go to original post Branched to a new discussion.
  • johnmacward Level 1 Level 1 (0 points)

    In this case it was not up to your phone to investigate why another device was not allowing it to connect, in all fairness it was up to the wireless router to tell you this but of course this isn't really possible. All the phone knows is that the wireless router probably ignore the iPhone connection, hence the phone returns with something useless.


    Also, In a lot of cases ISP provided routers are typically very cheap and very restrictive units, possibly maxing out at about 5 or 10 connections without telling you. You find intermittent behaviour when somebody suddenly dosconnects and you can connect again.


    I've always bought decent routers and simply NEVER have had a problem with WiFi on my Apple devices.

  • johnmacward Level 1 Level 1 (0 points)

    What you are seeing here is called an APIPA address, it's an emergency / backup addressing system if your device can't get an IP from the device it's connecting to. I'd bet it's something like 169.254.X.X...


    You might try to disable all wifi devices in your house, reboot your router (to clear it's connection cache) and then connect your phone purely on its own.


    See if that makes a difference,

  • WilliamDA Level 1 Level 1 (0 points)

    My daughter's iPhne 4S failed to connect to her University Wi Fi recently and on return home both Wi Fi and bluetooth were greyed out. All solutions have been tried and all other home devices are connected to Wi Fi. The fault is with the iPhone.

  • aljaxon Level 1 Level 1 (0 points)

    i know what the problem is with my iphone but have yet to find a solution.

    it would be inconsistent with my home wifi netgear router at connecting and staying connected.

    i found the solution was to change from mixed wpa (default for netgear routers?)  to just wpa2.

    works fine- connects instantly every time and stays connected.


    my problem is when i stay at hotels or visit places with free wifi and netgear routers set to default encryption or at least mixed wpa..

    i cant connect reliably and usually not at all.

    now i cant go round asking them to change their encryption can i?

    so the problem is with the phone.

    is there a solution to this anywhere?

    i have tried resetting network settings on the phone.



  • johnmacward Level 1 Level 1 (0 points)

    I doubt this is the phones fault. This more than likely has something to do with NetGear not sticking to Wireless security standards protocol, the way they are writing the mixed mode negotiation code is possibly poor. Also, mixed mode security is not all that common in routers anymore - it was for a time that some devices were old enough to know only about WPA 1 and others could negotiate up to WPA 2 which was more secure. Nowadays everythgin can run WPA 2.


    I have never used Netgear, I happen to have a Cisco cable router, and previously a Buffallo AP and also I have extensively used an Asus RT-56U - there is no mixed mode on these routers. So I either had it set to WPA or WPA2 and I have NEVER had any significant problems with these devices.


    The fact that this formum is so full of complaints from people with Netgear routers says a lot.

  • aljaxon Level 1 Level 1 (0 points)

    it is the phones fault. my son in law and others around me can connect to mixed wpa with their iphones but mine can not.

    it should have been returned when new but my son failed to do this.

    i am guessing there are an awful lot of netgear routers being used for free wifi. and for apple to sell a device that cant connect to them is not netgears fault.

    some iphones can connect and some cant.

    my wifes android phone and nexus funnily enough have NEVER EVER had a problem connecting to any free wifi.


    i have tried using the nexus as a hotspot but apple in their wisdom have chosen to make that not possible with my iphone.


    my sons iphone 5 connects to mixed wpa no problem. and has no problem with any free wifi anywhere. my son in laws is the same. my iphone 4 has had problems from day one. some people have returned their phones to apple and solved the problem.

  • sark2 Level 1 Level 1 (0 points)

    This solved my question. THANK YOU.

  • trotz98 Level 1 Level 1 (0 points)

    Wow I've been struggling with that since the first upgrade to iOS6 !!!!

    This (& this only) worked in a snap. Thank you SO MUCH !!!

    NO this was NOT the phone's fault -> iMac & Macbook were still connecting to Wifi without issue all the way - iPhone 4 & iPhone 3GS did not since the 1st upgrade to IOS6

    NO it was NOT the router that was not compliant or Apple compatible -> my router is an Apple Time Capsule !!!!

    NO the network reset, phone reset, router reset in whatever order did NOT help

    Somehow since the upgradeS to iOS 6 + the iphones ( 3GS & 4 for me / apparently valid for 4S as well) could no longer connect with WIFI in AUTOMATIC settings. Switching to manual did the trick !!!

    T H A N K Y O U !

  • DavidGwd Level 1 Level 1 (0 points)

    Just got an iPhone 4 & it could not even see my network (well, most of the time, sometimes briefly saw it & forget). After reading lots of these posts & trying things, I tried something off the wall that no one had mentioned... I took the special characters out of both the SSID and the WPA password!   My password had previously started with a $ or a £.     (My work HTC still doesn't like it but theiPhone is happy now).

  • mom4life1226 Level 1 Level 1 (0 points)

    I am still having trouble figuring out this. I have reset network settings. I have reset my router. I have changed my password. Everytime I enter my password for my iphone 4s to connect to my home wifi. It says incorrect password. My phone has no problems connecting to my parents home wifi or my aunts. I see that some people say to reset the channel but not seeing where to change it on my rounter settings? If anyone could help me it would be greatly appreciated!

  • Sk8Dreams Level 3 Level 3 (855 points)

    mom4life1226 - If the message is "incorrect password", then that is the problem.  Do you mean you reset your password in the router?  Just FYI, if you are using WPA security, then the password is case sensitive.  This is not true for WEP.

  • thea2 Level 1 Level 1 (0 points)

    After syncing my iphone with itunes on my home computer last night I lost my wifi connection & the search found no networks. Same thing from office today. Arrived home and plugged the phone in to my computer. Immediately the search found our home network & I was able to enter the password & connect. After  removing my phone from the computer the network remained available for a short time & then same problem again. Each time I plug back in to the computer I can log on to the wifi but need to re-enter the password. Each time I remove the phone from the computer the wifi drops out after about a minute? Does anyone know why this is happening? Note I tried resetting the network settings but this didn't work.

  • JimHdk Level 7 Level 7 (28,240 points)

    It sounds like you have a failing battery. Get it checked out and replaced.

  • thea2 Level 1 Level 1 (0 points)

    Thanks for your reply but I think my battery is good. I have battery doctor installed & no problems detected. I notice I am able to join the wireless only when I am right next to the computer at home. When I go in to another room the search cannot find the network. Could it be the antenna? I have a 4S which is less than a year old so I may have to make a warrenty claim? I have also tried the suggestion of adding the iphone addresss to the mac filter on the router but no fix for me.

  • ProtoQuandus Level 1 Level 1 (0 points)

    My iPhone 4 stopped connecting to any WiFi. Your solution worked. Thanks much!