2 Replies Latest reply: May 9, 2011 11:53 AM by charliefrommanchester
charliefrommanchester Level 1 Level 1 (0 points)

Over the weekend I upgraded to one of the new 2011 quad-core Sandy Bride iMacs, replacing my aging 2008 iMac which I gave to my brother-in-law, and I've been trying to use Facetime so we can video call eather other.

 

When either of initates a call it rings correctly on the other's Mac, we are able to answer the call, he can see/hear me, but I just get a static picture of him with no sound, then after 4-5 seconds the call disconnects.

 

Both Macs are running the latest version of Snow Leopard.  Facetime came pre-installed on my iMac, was installed from the Mac App Store on his.

 

When I initially tried both Macs were in my house, connected to my wireless, but we are having the same problem now that they are in separate locations.

I've also tried calling from my 2009 13" Macbook Pro, which is running Lion pre-release, with the same outcome.

 

I've tried disabling the built in Snow Leopard firewall, but there don't seem to be any real options in Facetime itself and I cannot find an diagnostics/logs/etc to help troubleshoot.

 

I would suspect the problem lies somewhere with the 2008 iMac, as I have used Facetime successfully on the Macbook Pro at work to an iPhone 4.

 

Has anybody had similar problems?  Any ideas would be appreciated.


Facetime for Mac, Mac OS X (10.6.7)
  • Dah•veed Level 7 Level 7 (32,820 points)

    Some folks have solved their FaceTime issues by switching their DNS service to either OpenDNS or Google Public DNS. It is best to configure it directly in your modem or router if you have that level of access. But often just configuring it on the Mac will override the modem/router settings.

     

    OpenDNS

    208.67.222.222, 208.67.220.220

     

    Google Public DNS

    8.8.8.8, 8.8.4.4

  • charliefrommanchester Level 1 Level 1 (0 points)

    Thanks, Dah•veed.

     

    I did see mention of using Google Public DNS while I was searching the forums prior to posting, but to be honest didn't think it was a DNS-related problem.

     

    However, to rule it out I've set the prefered DNS servers on my router to Google's, but FaceTime still disconnects after 4-5 seconds when calling between me and my brother-in-law.  It doesn't matter who initiates the call.

     

    As a test, before I made the changes to my router, I logged into FaceTime as him on my MBP and tried calling myself on my iMac, and that was successful.

     

    The same test between the two iMacs when they were here was unsuccessful, so now I'm definitely thinking it's something on the '08 iMac.

     

    Now I just need to figure out what...