4 Replies Latest reply: Oct 2, 2012 10:17 AM by DK-sls
Vijay-Kumar Level 1 Level 1 (75 points)

Hi All,

 

I'm setting up our new-ish Mac mini Server with Snow Leopard.  I've started the VPN Server and Macs seem to connect correctly;  however it appears that after connected, Macs can't use the internet resources on this machine.  What I'd really like to do is to share the Airport connection, so it's as if they're in the office connected to the the WiFi.  I can't seem to find any internet sharing pref anywhere, and am wondering if I;m doing something wrong.

 

Server Preferences > VPN Service

Service os On

Shared Secret is filled in

IP Address Range is filled in

 

Server Admin > VPN > Settings

 

L2TP:

Enable L2TP over IPsec

Directory Service - MS-CHAPv2

Shared Secret - filled in

 

Client Information:

DNS Server - filled in

 

 

Any help appreciated

 

TIA - Vijay

  • sulie4real Level 1 Level 1 (10 points)

    u aint doing nothing wrong, its just that snow leopard did not have the ability to share internet without writing ur own script or doing some extra modifications. but the new OSX LION, now forward VPN packet to any network interface, so u can share ur vpn connection via wifi or ethernet, and all ur connected devices will have acess to ur vpn services..............hope this helps

  • John Lockwood Level 5 Level 5 (6,275 points)

    Something else to consider.

     

    If you don't do anything the default configuration of the VPN Server in Mac OS X 10.6 Server is to route all the users traffic including traffic for sites on the Internet via the Mac OS X Server. If your happy enough for only the traffic that needs to reach your internal LAN to go via the VPN Server and to let the (remote) users Internet traffic go via their own Internet link instead of the office VPN, then you need to add at least one rule in the VPN Server.

     

    1. Launch Server Admin
    2. Click on the VPN service
    3. Click on Settings at the top
    4. Click on the Client Information tab
    5. In the big box at the bottom add a rule to route to your office LAN and mark it as type Private.

     

    See page 151 of the Mac OS X 10.6 Server "Network Services Admin v10.6" PDF manual.

  • Vijay-Kumar Level 1 Level 1 (75 points)

    Hi...

     

    I tried setting up a rule but that didn't help.  Using the Server Admin I enabled the VPN and set it up by using the NAT category and Starting NAT, which went through the rest of the set up.  I'm using ethernet as the main connection, and using the Airport WiFi for my VPN traffic.  This seemed to work well for a few days until one day when people at the office connected to the wireless and were unable to because the Airport was giving them 192.168 numbers.

     

    Did I miss a setting or set somethign up wrong?

     

    TIA - Vijay

  • DK-sls Level 1 Level 1 (0 points)

    I have a realated problem. I am trying to share ethernet internet connection via wifi, when I hava TunnelBear running. I can create the wifi network and log on to it, but there is not internet connection shared when connected to TUnnelBear VPN