Previous 1 2 Next 18 Replies Latest reply: Jun 17, 2013 6:36 AM by Jason_1848
hiwhitey Level 1 (0 points)

I am having a problem with my Hosted Exchange account and iCal. Prior to the widespread issues with Hosted Exchange and Mac Mail in late March/early April, I was able to add shared Exchange calendars in iCal by going to Preferences-Accounts-Delegation, clicking the + and typing in the first few characters of a colleague's email address (a colleague who has shared their calendar with me). I have four shared calendars right now that are working perfectly, I can see their appointments and the shared calendars update when changes are made.



The problem is that I can't add a new shared calendar using this method. I have three new employees whose calendars I need to add to iCal and the process to add a shared calendar is not working. I type the first few characters of their email address like I did before and nothing happens. I have tried (on another Mac) to delete the account and re-add it, I can't add any shared calendars there so I've lost the four that I had before and can't get them back. 



I have verified that this is working fine in Outlook 2010 on a virtual PC, it appears to be another problem with Hosted Exchange that is crippling Mac productivity.


Anyone else seeing this problem?

MacBook Pro, Mac OS X (10.6.4)
  • Nigel314 Level 1 (0 points)

    I'm running iCal 4.04 on Mac OS X 10.6.7 on a 2011 MacBook Pro.  By coincidence, 30 mins prior to reading your post I had just added delegates to my iCal using the method you describe.  They are windows users who have shared their calendars via MS Outlook and exchange.  My account is hosted on the same MS exchange server.  I know it's not the most helpful of answers, but at least you know that it should still be possible.

  • rbrandy Level 1 (0 points)

    I am having the exact same issue. Works in Outlook 2010 on the MAC, but not in iCal.  Have not found a solution as of yet. Maybe with OS Lion??

  • klms Level 1 (0 points)

    I'm having the same issue.... I've been able to add delegates to my mac pro today but not to my macbook.  I tried it on my colleague's macbook air and it didn't work there either.  As far as I can tell all the operating systems and versions of ical are the same. Not sure what's different....

  • Mike Matthews Level 1 (10 points)

    According to this thread...


    Turns out that with iCal - if the person who's calendar you want to view is set to be the OWNER - Not Editor of their own Calendar - it prevents iCal from being able to give others permission to see their calendar.


    The solution is to set the person as Editor to their own calendar - voila I can now access that person's calendar.


    So how do I do this in Outlook for Mac 2011? I believe that a user is by default the Owner of the folder that contains the calendar to share. Do I just simply add myself as a new user and change the privileges from Free/Busy (which is offered as the default) to Editor?


    Also, like hiwhitney, still having trouble getting iCal to search the Exchange server to add acounts I can access. I can access the server to manage my account access by others; iCal does correctly access and search the server as far as I can tell.




  • g_pirtle Level 1 (45 points)

    I am experiencing the same issue. I go to Delegation tab, type in the name, and it will not add them. It works in everything except iCal on Lion.

  • Nigel314 Level 1 (0 points)

    I have just reset my Lion iCal with delegates, I pressed the plus sign and typed in the surname I was looking for and it offered me all the people with that surname


    Screen Shot 2011-07-27 at 18.35.13.png

    And it produced the names in the drop down menu

    Screen Shot 2011-07-27 at 18.39.28.png

  • Mike Matthews Level 1 (10 points)

    Hi Nigel:


    How did you "reset my Lion iCal with delegates"?


    Fpr me, clicking the + button and typing a user name does not initiate a search of the Exchnage server for matches. This happens to me using two different Macs (both running Snow Leopard on the internal drives, and one running Lion via an external drive).




  • Nigel314 Level 1 (0 points)

    Hi Mike


    When I upgraded to Lion the delegates were not there, so I reloaded them.  iCal was pretty tempremental, telling me that it could not contact the exchange server, but I persisted by clicking on the plus again and retyping the surname and it found them.  The only evidence that a search is underway is the rotating cirlce of lines i.e. not the spinning beach-ball of death.


    I have no idea how the servers etc are set up, far too technical for me, but I log-in via outlook anywhere.





  • Mike Matthews Level 1 (10 points)

    Hi NIgel:


    Yeah, I cannot even get the rotating circle fo lines to appear. Nor do I get messages that iCal cannot contact the exchange server. I get no response at all.



  • Nigel314 Level 1 (0 points)

    Sorry if it's teaching you to suck eggs, but I assume you have set exchange to be your provider of mail and calendar in Systems Preferences as per picture below


    Screen Shot 2011-07-27 at 22.14.07.png

  • Mike Matthews Level 1 (10 points)



    Yep, it's set up properly in Lion, as the graphic above indicates.


    I can see the five people I've given read-only access to my calendar, but can't add anyone else. Also can't add any users who have given me access to their calendars.


    I think there's a setting on the server somewhere that's screwed up for me. Same outcome using both Lion and Snow Leopard on two different Macs.


    Any other suggestions?



  • Nigel314 Level 1 (0 points)

    Sorry Mike, we have now hit the limits of my technical knowledge.  Reading elsewhere on the subject I think it's an issue for whoever runs your exchange servers.  At least you can show them this thread and prove that it can be done and it's not an issue with your Mac.

  • anothersmurf Level 1 (20 points)

    I was having this problem on Lion. The solution was to go to System Preferences, choose the Mail, Contacts & Calendars pane, click the Exchange account, and check the box beside Contacts (which was unchecked). See Nigel's picture above.


    Once Contacts was checked, I was able to add delegates just like I could in Snow Leopard. I can also search for people with accounts on the Exchange Server from within the abysmal Address Book GUI.

  • Mike Matthews Level 1 (10 points)

    Huzzah for anothersmurf!


    This worked for me on Snow Leopard, so I assume it will work for me on Lion tonight when I give it a try at home.


    After reading this tip, I realized that when I first set up my account on the Exchange server, I must have had Contacts syncing to the Exchange server turned on, then I added a couple of delegate calendars without a problem, then I turned Contacts syncing off. And then the problems began.


    Because I don't want my contacts on the server (some are personal, and it only complicates Address Book, which I'm already syncing via MobileMe), I plan to do this:


    --Turn on contacts syncing.

    --Add the delgates for calendars that are shared with me by others.

    --Add users with whom I wish to share my calendar.

    --Turn off contacts syncing.


    I've confirmed delegates whose calendars I can see can add and delete events and their calendars will update in my iCal window with contacts syncing to the Exchange server turned off.


    I'm hoping this behavior lasts across restarts, so we'll give it a try over time.


    If thsi works and I want to change the delegates list, I'll simply turn contacts syncing back on and make the changes I need, then turn contacts syncing off.



Previous 1 2 Next