5 Replies Latest reply: Jul 13, 2011 5:01 AM by scottw03
scottw03 Level 1 (15 points)

So I just received my iPad 2 today and so far love it.  The only problem I am having at the moment is that I can not get the iPad to connect to the iTunes store on the iPad or the app store.  I keep getting the message "cannot connect to iTunes store" when I open each app.  I have it synced to my computer already and can get apps on there through my computer but I would like to get this fixed.  Any ideas what the problem is?  When I go to settings and the store section my iTunes account shows up so I don't know what the problem is.  I never had these problems with my iPhone 3G or 4.  Thank you for any suggestions.

  • scottw03 Level 1 (15 points)

    No one has an idea what the problem could be?

     

    I updated the firmware to 4.3.3 today and still have the same problem.

     

    Not sure what the problem could be.

     

    It is not a hardware problem since I am online and can access the Internet.  The only thing i have a problem with is just these two apps.

  • elizabethfromalameda Level 1 (0 points)

    I am having the same problem...am considering taking it to the genius bar today.

  • Fire Ninja Level 1 (0 points)

    Same here. No genius bar near here. If you find a solution let me know.

  • rossvoll Level 1 (0 points)

    Had exactly the same problem, my iPhone had no issues, but my brand new iPad would not connect to AppStore or iTunes, and sometimes it would not connect to YouTube, iBooks or GameCenter... I tried all tips and suggestions that I could find on the web, but none seemd to work.

     

    But when I tried my iPad on a different network, all was fine! So I got a new Cisco WiFi router and hey presto! No problems with AppStore or anything! Weird (wired) but true... I can't see a reasonable explanation why my 2 yr old Belkin (B-G-N) router would cause these problems, but theydisappeared totally with the new router installed.

  • scottw03 Level 1 (15 points)

    I fixed my problem awhile back by doing a few restores on the iPad 2 with firmware 4.3.3 and it finally worked.  Was able to get the iPad to connect to iTunes and App store.