4 Replies Latest reply: Oct 20, 2011 1:12 PM by blackadder1999
Yddi Level 1 Level 1 (0 points)



I have an iPhone 4. I recently switched to using exchange as my contact list so I can have all my contacts (business and private) at the same place.


My problem is that the contact names do not always show up on text messages. A few contacts work but there is no visible difference in the ones that work and those that don't. Also I have added the country code to the phone number and that does not solve the problem either. I have tried deleting the contacts and recreating them. I have tried to delete all the history of a given number and start the sms conversation again picking the name from the adress book - right after the message was sent it switched the name to the number.


Also I have tried restarting the phone and resynced it to iTunes.


Can anyone help me? This is really not possible to live with.

iPhone 4, iOS 4.3.2
  • vipuldalal Level 1 Level 1 (0 points)

    Go to Settings > General > International > Region Format


    and select hte country. mine is an international unlocked phone and it worked for me. I have added country code to my contacts and even when sms comes without country code the iphone shows person name.

  • Yddi Level 1 Level 1 (0 points)

    Thank you for the reply. I checked up on it and the region was correctly setup to Denmark. I guess I will have to try and reinstall the phone as a new phone from iTunes. I cannot find any solution at this point eventough I have spent hours looking for an answer.

  • graniel Level 1 Level 1 (0 points)

    Have you found a solution to your problem?


    I am also having a problem since upgrading to iOS 5. I am in Oman right now (on assignment) and all my contacts are prefixed with +968 (Oman country code). When I receive a local call, iPhone does not match any of my contacts and just displays the number as it does not contain the country code. Removing the country code in my contact list though creates problem on my Messages as SMS is received with country codes and will not match my contacts if they are saved without the country code.


    I hate that I have to add the same number twice. One without country code and one with country code. Has anyone able to fix this? Any help would be appreciated.

  • blackadder1999 Level 1 Level 1 (10 points)

    1) Open the Phone and dial *228. This is a Verizon over-the-air programming number.

    2) When the system answer press 1 for "Program or activate your phone"

    3) Wait for the call to disconnect. You should get a prompt stating something like, "Settings updated."

    4) Open the Task Manager and kill the Phone, Message, and Contacts Applications

    5) Wait a few minutes (I waited 3 just to be extra safe)

    6) Open the Message App to verify the fix