5 Replies Latest reply: May 28, 2011 5:47 PM by okeeusa
okeeusa Level 1 Level 1 (0 points)

I used Handbrake to convert family video I received as Video_TS to m4v file. When I try to use the m4v file, iMovie insists on "optimizing" it - but then I see NO video, just green screen clips! What am I doing wrong? Please help!


iMovie '11, Mac OS X (10.6.7)
  • Lloyd Is The Name. Level 1 Level 1 (0 points)

    Possibly try to convert the movie into another file format using another program. I am not sure if it would work, but it is worth a try.

  • okeeusa Level 1 Level 1 (0 points)

    Thank you.  But to what file format should I convert the .VOB video file, and with which program?

     

    I always believed Apple was the way to go to work with video, but it is becoming more and more complicated to accomplish anything.  Thank you again for your help.

  • Lloyd Is The Name. Level 1 Level 1 (0 points)

    Well I am pretty sure imovie runs best with .mov files, so try and convert the file to that. Personally, off the top of my head, I cannot name a program that does that.

     

    I have used a program called iSquint before to convert my videos for iMovie. To my knowledge that program is freeware. Give that a go, and see if it will work.

  • John Cogdell Level 5 Level 5 (4,605 points)

    Try MPEG Streamclip from Squared 5, available as a free download from the developer's website here:

    http://www.squared5.com/svideo/mpeg-streamclip-mac.html

     

    Preferably, convert to Apple Intermediate Codec (AIC) - otherwise H.264, both of which work fine with iMovie '11.

     

    John

  • okeeusa Level 1 Level 1 (0 points)

    OMG, thank you folks for the helpful advice!  It is VERY much appreciated!  I haven't been at home yet to try your recommendations, but I will post as soon as I can with the results!