Previous 1 2 3 Next 32 Replies Latest reply: Oct 28, 2012 5:52 AM by Green eyed monster Go to original post
  • scottiepunk Level 1 Level 1 (0 points)

    I'm having exactly the same issues. Yesterday I decided to get over the issue I'd wire my apple TV(s) to get over the, what I thought, WiFi problem! Success, it appears, on my Apple TV upstairs, but not so lucky on my Apple TV downstairs!! Why does one work and the other keep dropping it's connection! Before I wired them both I was having the same issues on both over WiFi, now I'm only having the problem on one, which is directly plugged into the router!?

     

    To say this is extremly frustrating is an understatement!!!!

  • malec Level 1 Level 1 (0 points)

    I had the same problem and it turned out to be DNS related.

    As soon as I fixed DNS it went away.

     

    If your ATV2 cannot set network time during reboot, try changing your DNS settings.

  • Robertito Level 1 Level 1 (10 points)

    Sorry, but how we can do that.

     

    I used the DNS from my provider (3 numbers)

  • Keith Murlless Level 1 Level 1 (20 points)

    My "interruptions" were in the home sharing side of things... airplay of music, itunes movies form my own collection, etc

     

    AppleTV was saying that I had current software...

     

    I just (9/21/11) ran a full "Restore System" on the Apple TV... which by default also fetches current software update.

     

    Today no issues with dropout.

     

    Another suggestion for some users: AIrFoil by Rogue Amoeba Software. Great little app for streaming music around the house to almost any device

     

    KM

  • scottiepunk Level 1 Level 1 (0 points)

    Sorted! I've just bought myself a £20 network switch! Now my ATV2 connects straight away and so far no dropouts! The problem is obviously with the routher but by putting a switch between the ATV2 and the router seems to have solved the problem. An extra £20 but I've now got an ATV2 that I can watch and enjoy!

  • Hellking Level 1 Level 1 (0 points)

    Just want to chime in to keep this thread alive. Ever since the iOS 'upgrade', I've been having a similar issue with my ATV2 (my ATV1 is still trucking along fantastically well).

    Like the original poster, I have my machine(s) wired into my network. I haven't had any media cut off mid-stream, but after the ATV2 goes to sleep and subsequently wakes, the network connection is fouled and I'm forced to reboot. The initial menu screen will come up and everything looks normal, but as soon as I try to reach anything on the network it gives me a pinwheel for a while before telling me that nothing can be reched (local or internet). Then it returns me to the menu screen and most of the options are removed in terms of what I can select. By this time, it doesn't even let me try to connect to local computers and I'm just stuck with the reboot.

    This has become something I have to do every single time I power up now. And things like this should definitely NOT be an issue, nor should they be left hanging in the ether without being addressed by Apple.

  • Musashi007 Level 1 Level 1 (0 points)

    I've been suffering the exact same problem for the last week.

     

    I've been using my Apple TV2 without a hitch for over  year.

    Now, the Apple TV2 has ceased to discover my router by DHCP.

    When I switched to Static IP, it still refuses to connect to the router.

     

    All other devices - Xbox, PS3, Laptops (wired), iPhone, iPod, iPad (wifi) - connect without any problems. Apple TV2 is also a wired connection.

     

    I've restarted/reset the router and the Apple TV, without joy.

    Can someone from Apple please look into this and provide a solution.

     

    ... I will be heading down to the Apple Store to see if they can shed any light on this.

  • eramir Level 1 Level 1 (0 points)

    Same issue as you derailed described. One difference. This all only happens when wired. It works well on wifi.

    Not acceptable, Apple do something.

    All at home is apple.

  • MacMunfordGB Level 1 Level 1 (0 points)

    I had the same problem with my ATV2, tried it wired, on a different router and what fixed it for me (I have Apple Airport Extreme products) was to force the network to use the 5ghz only setting.  Ever since I did that, I've only had one drop compared to several during a NexFlix episode.  The only thing that this did was muck up my iPhone connection, so I had to buy the latest rendition of the Airport Extreme and add it to the network. Now all my phones, ATV2, iPads and Mac's are happy campers.  While it's probably not fixed, It's 98% better.  I watched a season of a TV series, during the 22 episodes, I was reconnecting 3 times. That's 66 disconnects. Since I've made the change, I've only had one.

     

    Hope that helps some.

     

    G

  • Rathbone Hall Level 1 Level 1 (0 points)

    I  purchased an Apple TV3, exchanged it, and returned it for a refund because both kept losing wifi connection even after trying every tip and workaround I read in these Apple support forums. The Apple Company's failute to admit there is a problem is disappointing.

  • Whippersnap Level 1 Level 1 (0 points)

    I had a very similar (if not identical) problem.  Is your TV plugged into a strip, splitter, or other receptacle extension?  If so, try plugging it directly into the wall.  Subtle electrical interference can cause it to drop the network even if nothing else on the power strip is running or even on.  Keep in mind this can happen even for a wired connection because the problem is the network, not the wifi/Internet connection.

  • Rathbone Hall Level 1 Level 1 (0 points)

    Scan the Support Community sites and you will find: Apple TV losing connection is prevalent. The many postings point out the problem occurs with:-

    1 Apple TV1,2and 3;

    2 with different brands of router including Airport Extreme;

    3 with current and past versions of iTunes;

    4 after varying periods of working well.....minutes, hours, days;

    5 losing connection with Home Sharing and losing Airplay;

    6 whether the router and Apple TV are in same room or separated by distance;

    7 after trying innumerable posted 'fixes';

    8 after exchanging for a new Apple TV;

    9 with all the recent operating systems -Mountain Lion, Lion, Snow Leopard, Leopard and Lion.

    10 when it loses wifi, the ATV will work immediately if you plug in the ethernet cable.....

       This is not a network issue or a hardware issue; it is an APPLE issue. Steve Jobs called the ATV a hobby, but Apple products are supposed to be better than this. If he was still at Apple this Apple TV issue would have been fixed.

        I suspect frustrated  readers just give up trying, rather than find a fix, which is why I invite readers to please don't post a fix until you check it works for at least a week.

  • Whippersnap Level 1 Level 1 (0 points)

    Rathbone,

    Unfortunately, we cant bring Jobs back.  Fortunately, this fix worked immediately for me and has now for >6mos.  Also, its free and simple to try.   Your list up there does not address finding and eliminating network interference.  Have you tried what I suggested?

  • Rathbone Hall Level 1 Level 1 (0 points)

    Whippersnap,

    Thanks. You wrote "...similar (if not identical) problem.  Is your TV plugged into a strip, splitter, or other receptacle ..."

    Are you referring to the TV or to the  ATV(AppleTV)?

  • BenFinklea Level 1 Level 1 (15 points)

    Use Google’s Public DNS Server To Fix Apple TV Streaming Problems

     

    1. Navigate to Settings >> General >> Network and select Configure TCP/IP.

     

    2. Select “Manually” next to Configure IP.

     

    3. Dont change the IP address or the Subnet Mask and Router Address. Just click "Done".

     

    4. Set the DNS Address screen with the following: 008.008.008.008 and click “Done.”

     

    You should now be able to stream more smoothly on your Apple TV.

     

     

    If this works for you, please buy a cup of coffee for a complete stranger or some other selfless, random act of kindness.