Previous 1 2 Next 16 Replies Latest reply: Jul 21, 2013 11:24 AM by John Quillen
mr88cet Level 1 (0 points)

My Magic Trackpad ran low on batteries, and after changing out the batteries, pairing is failing.  I can't seem to find the documents describing how to Bluetooth-pair the Magic Trackpad with my Mac Pro.  Anybody know where a description of the procedure can be found? 

 

In particular,

  • Bluetooth is "on" and "discoverable" in the Mac's Bluetooth System-Preferences panel, and the trackpad shows up in that panel. 
    • Sometimes it shows up as "connected," but more often as "not connected."  Not sure what to make of that.  Connecting it often doesn't seem to be successful.
    • The trackpad also shows up as "Paired - Yes," and "Configured - Yes," even when it's "not connected."  Perhaps that just means, correctly, that it was paired at one time in the past...
  • I pop up the Trackpad System-Preferences panel.
  • It initially says, "no trackpad found" and "searching."
  • I hit the button on the side of the Magic Trackpad.
  • The LED on the trackpad goes solid-on for a second or so, then blinks.
  • It (after a few seconds delay) says "Found Apple Wireless Trackpad."
    • However, sometimes it doesn't find the Trackpad.
    • Sometimes, if I cycle power on the trackpad, it does find it.
  • When it does find it, though, I hit "continue."
  • It says "the pairing attempt was unsuccessful."

 

As far as I can tell, there are no other Bluetooth-enabled devices in the vicinity, potentially interfering.

 

Oh also, I'm wondering if the System Preferences panel, and SW for it in general, for it might have vanished somehow.  The Preferences panel shows a picture of the Magic Trackpad, so it may know that there's supposed to be one "out there," but it doesn't show any of the controls for any of its cool, multi-touch features.  Maybe it's not showing those controls just simply because it hasn't paired yet.

 

I remember I had somewhat similar difficulties setting it up the first time too, and I can't remember what the final solution was.  It worked great for a long time after that, until now.


Mac Pro 2.8GHz 8 Xeon, MacBook Pro 17", iPhone 4, iPad 3G, Mac OS X (10.6.4)
  • captfred Level 7 (26,290 points)

    Here's the link to everything bluetooth.  It's primary focus seems to be the mouse/keyboard but it applies equally to the Trackpad.

     

    http://www.apple.com/support/keyboard/

     

    Regards,

    Captfred

  • mr88cet Level 1 (0 points)

    (Sorry, got sidetracked on an unrelated project.) 

     

    Thanks for the reply.  I'll look it over to see whether it helps solve the problem.

  • mr88cet Level 1 (0 points)

    Just as a general matter, am I assuming correctly that the Magic Trackpad must first show up as "Connected" in the Bluetooth Preferences panel before messing around with anything in the Trackpad Preferences panel?

  • captfred Level 7 (26,290 points)

    That's correct, otherwise you end up with this:

     

    Screen shot 2011-05-18 at 1.49.28 PM.png

  • mr88cet Level 1 (0 points)

    And that is in fact what I'm getting.  When I poke the button on the side of the trackpad, I notice in the Trackpad Preferences panel ... well, I get what I described in my original message above.

     

    I noticed earlier today that, in the Bluetooth Preferences panel, that, that each time I poke the trackpad's button on the side:

    1. No change for ~1 second.
    2. Changes from "not connected" to "connected" for a fraction of a second, then back to "not connected."
    3. Stays "not connected" for ~1 second.
    4. For a second time, it changes from "not connected" to "connected" for a fraction of a second, then back to "not connected."

     

    Hmmm...

  • captfred Level 7 (26,290 points)

    That sounds like a battery connection problem.  Rechargables are notorious for having different shape and sizes on the + terminal end.  That has caused connection problems in the past.  Try a different set to be sure.

     

    Another issue can be interference on the 2.4Ghz range.  It usually shows up in the wireless network rather than bluetooth device, especially when using a portable in clamshell mode.  Changing wireless channels to a lower number resolves that.

     

    Many times a good PRAM reset will resolve bluetooth issues.

    http://support.apple.com/kb/ht1379

     

    Since your problems started with a change of batteries, I think the that's the best bet.

     

    Screen shot 2011-05-18 at 3.35.23 PM.png

  • mr88cet Level 1 (0 points)

    Ah, I like your PRAM-zap suggestion, but those are all good thoughts.  Thanks.

  • mr88cet Level 1 (0 points)

    For future reference, I was hoping that this might do it:

     

                 http://support.apple.com/kb/HT3081

     

    but unfortunately not.  It just does the same behavior of being connected for a fraction of a second, and then going back to being disconnected for a few seconds, looping that 4 or 5 times.  Unlike when I hit the button on the side of the trackpad, though, the green LED on the trackpad doesn't blink.

     

    Oh, just to clarify my previous post:  When I hit the button on the side of the trackpad, it does that connected for a very brief instant behavior repeatedly, not just a couple times as I implied there.

  • mr88cet Level 1 (0 points)

    Yip, looks like zapping the PRAM is what it took!

     

    Thanks.

  • captfred Level 7 (26,290 points)

    Glad that worked for you mr88cet!  

     

    Regards,

    Captfred

  • RalphieRulz Level 1 (0 points)

    If it is unable to connect, go to the Bluetooth System Preferences Panel, and make sure the trackpad isn't already shown. If it is, delete it, then go back to the Trackpad panel and pair it again. I did that and didn't have to zap the pesky PRAM.

  • mr88cet Level 1 (0 points)

    Thanks for the suggestion.  As I recall, I'm pretty darned sure did in fact do that a few times, and it still didn't pair, until I zapped the PRAM.

  • dneu Level 1 (0 points)

    I had the exact same problem and tried zapping PRAM and changing batteries, still no luck. Finally found a solution:

    System Preferences / Bluetooth. Highlighted Trackpad and hit the minus button to disconnect. Then hit the plus sign and got the "Welcome to the Bluetooth Setup Assistant" window. Hit continue and was delighted to see the Congratulations! window.

     

    Hope this helps someone else out there who had this issue.

     

    Cheers!

  • mr88cet Level 1 (0 points)

    I'm glad that worked for you.  For whatever it's worth, however, I had tried that before I zapped the PRAM.  It didn't help in my particular case.

Previous 1 2 Next