1 Reply Latest reply: Jun 9, 2011 7:15 PM by Alexander Newman
Alexander Newman Level 1 (30 points)

Since having the iPhone's backup part of a backup and update procedure interrupted when the phone rang a while ago - last year in fact: I've been trying to get it working again myself since then - the phone is no longer seen by iTunes (9.x and 10.x) when plugged in to any computer that I've tried it with.


I have also tried the trick of holding down the power and home buttons until the "connect to iTunes" screen appears, plugged the thing into powered USB 2.0 hubs and straight into various PPC Macs (G5, Pwerbooks, MacBook Pros, iMac). I've bought a brand new Apple cable in case it was a cable issue; it has even been jacked into a Windows PC, but still the same - no recognition by iTunes. It connects fine over the WiFi (fortunately!), but I'd like to be able to update the phone's firmware so that a. I can use some recent apps; and b. so that the phone can detect that it has been officially unlocked by Vodafone and I can start using it as a phone again.


Interestingly, the Mac System Profiler (OS X 10.6.7) on an i7 iMac reports the following while the phone is in the "iTunes connect" mode (or whatever it's called):


Internal Memory Card Reader:    Product ID:     0x8403

Vendor ID:     0x05ac  (Apple Inc.)

Version:     98.33

Serial Number:     000000009833

Speed:     Up to 480 Mb/sec

Manufacturer:     Apple

Location ID:     0xfa120000

Current Available (mA):     500

Current Required (mA):     500


At this stage my favourite theory is a dry joint/disconnect on the phone side of the bottom port.


Is there a likelihood of it being a software problem, and if so, is there a workaround?


Note also that I've cleaned the bottom port with special computer contact cleaner as well.