6 Replies Latest reply: May 17, 2011 10:57 AM by David Yellen
David Yellen Level 1 Level 1 (110 points)

For whatever reason, there are certain apps that when running, will not allow the screensaver to activate. I often capture several hours worth of video using iMovie HD, and if I fall asleep or forget to return to the computer for a while, the screensaver will not work, no matter what settings I use, and the screen will stay full brightness. I have started noticing minor burn-in on my screen and really want to prevent it.

 

Is there some setting or preference I am missing? Or is there a third party app that will let me make additional adjustments to my screensaver settings?

 

David Y


20" Intel Imac / 15" MacBook Pro, Mac OS X (10.5.3)
  • kennethfromtoronto Level 4 Level 4 (1,035 points)

    In System Preferences > Exposé & Spaces > Exposé

    Set the Hot Corners something as you see in the screen shot:

    Screen shot 2011-05-16 at 6.03.20 PM.jpg

    This will allow you to immediately turn off the display or start the screen saver as soon as you want to leave your workstation without the concern of the display open for hours.

  • David Yellen Level 1 Level 1 (110 points)

    thanks. I never thought of using that feature before. Good solution.

  • X423424X Level 6 Level 6 (14,205 points)

    If I am reading you correctly you want to force the screen saver on when your machine is finished doing whatever it is doing and you are not there to know when it's finished.  If so the previous answer won't help you.  But related to that I stumbled on this neat little app.  If you could find a way to execute it on some particular event it could probably satisfy what you want to do.

     

    As an alternative suggestion how about forcing your machine to sleep as a function of your Energy Saver preferences?  What you describe is that something is keeping your energy saver settings from turning on your screen saver.  I've had a similar problem, but I wanted the machine to sleep, not screen save, and I could never find out what's keeping my machine from obeying the energy saver preferences (although I suspect it's my non-apple USB keyboard based on the kernel.log -- you might want to look at that by the way to see if you see anything related to your problem). At any rate I solved my problem by using a little app called PleaseSleep.   It forces my machine to enable the sleep settings.  Maybe this would work for you if you don't mind sleep instead of screen saving.

  • David Yellen Level 1 Level 1 (110 points)

    the "hot corner" thing works, but only for about 10 seconds, then the desktop returns. Any idea what's going on?

  • kennethfromtoronto Level 4 Level 4 (1,035 points)

    That seems unusual for it to be negated so quickly like that. You didn't nudge the mouse and dislodge the pointer from the selected corner? Once you activate the Hot Corner you have to leave the pointer in that position. Perhaps you inadvertently touched a key on the keyboard? Sometimes a slight bump of the computer table can undo it. Other than those couple of things I can't come up with an answer. Perhaps another member of the forum can help provide insight.

  • David Yellen Level 1 Level 1 (110 points)

    it's odd, but if I leave iMovie in "edit mode", the standard screensaver and my "hot corner" settings work properly, but in "camera mode" they both will last about 10 seconds before the desktop returns.

     

    I still use iMovie HD 6.0.4. (I can't stand the newer version!)