5 Replies Latest reply: Jan 7, 2012 2:26 PM by rottenrottenapple
bernardfromherseaux Level 1 (0 points)



When connecting my iPhone to my Macbook Pro, I receive the message :

"iTunes was unable to load data class information from Sync Services. Reconnect or try later."

and after the backup : "iTunes could not backup the iPhone "xxx..." because the backup session failed."

This is the first problem I met since I have my phone (2 years).

Can you help me ?


iPhone 3GS
  • Ingo2711 Level 7 (22,552 points)

    Did you already try the solutions for the sync services alert mentioned in this article? http://support.apple.com/kb/TS2690


    If your existing backup can't be read anymore, follow this article: http://support.apple.com/kb/TS2529


    Message was edited by: Ingo2711

  • bernardfromherseaux Level 1 (0 points)



    Yes I read those articles but I found the correct answer elsewhere.

    In one of the discussions, someone suggested that after downloading the latest version of Xcode, we better re-download de latest version of iTunes as well.

    I effectively downloaded Xcode a few days ago.

    So I downloaded iTunes again as stated in the discussion.

    And indeed, it works now fine !

    So thank you all for your kind assistance.

    It a pleasure being part of this community.

  • Ingo2711 Level 7 (22,552 points)

    You're welcome

  • rottenrottenapple Level 1 (0 points)

    Apple is the most consumer unfriendly company ever. I have an iphone 4 running OS 4.1. Backup worked fine till upgrading itunes from 10 to 10.5.


    Other products (from 4.2 onwards) worked fine. Tried downgrading but got this ******** " cannot start library becsause created by never version"  or something BS.


    Thankfully my library is on a NAS and I had a computer still running itunes 10. AMAZING IT WORKED!! (sarcasm). So I had to copy the backup into the itunes 10.5 folder and it shows up.


    This is an obvious compatibility issue by design, and now I must try to find a way to downgrade. (any help will be greatly appreciated).


    If I wasn't grandfathered into the unlimited data plan, I would switch to droid. People criticize MS but apple is far, far more closed minded. Why people marvel at a proprietary version of Linux is beyond me.

  • rottenrottenapple Level 1 (0 points)

    Thankfully there are lots of posts on how to fix the library issue. At least apple had the sense to backup the old library. That still is no excuse for intentionally engineering incompatibilities.


    If anyone has this issue, you just need to rename the library to the .old extension, then copy the last backup found in "previous libraries" and change the name to match the original file name.


    Why is this necessary? Why can't people simply re-install an older version?