Skip navigation

MAC Mail not saving all sent items

140813 Views 575 Replies Latest reply: Apr 4, 2014 6:36 AM by __kckc__ RSS Branched to a new discussion.
  • lolafromburlington Calculating status...
    Currently Being Moderated
    Apr 27, 2013 7:02 PM (in response to lolafromburlington)

    I noticed that the solution I referred to as helping me did not appear in this thread, so I will try to explain what it was....open your "Sent" folder then click on "View" at the top, then go to "Sort by" and make sure it shows by "Date" and "Decending."  All of my other folders were set that way but "Mail" was not.  I don't remember what the settings were but they were not these.  It solved the problem for me.  Good luck.

     

    Old Granny Lola

  • Satome Calculating status...
    Currently Being Moderated
    Apr 27, 2013 7:09 PM (in response to Jules2000)

    I'm using Mail 6.3 on OS X 10.8.3, but the setting for me is in Mail->Preferences->Accounts and then click the advanced tab on the IMAP account you want to apply it to.

  • Csound1 Level 7 Level 7 (32,310 points)
    Currently Being Moderated
    Apr 27, 2013 7:23 PM (in response to Jules2000)

    Mail>Preferences >Accounts>Advanced. On 10.6.8

  • Jules2000 Level 2 Level 2 (225 points)
    Currently Being Moderated
    Apr 28, 2013 12:47 PM (in response to Csound1)

    Thank you. I found the IDLE setting and un-checked it. But unfortunately 50% of my sent e-mail is still not showing up in the Sent folder. I have also tried to sort the folder like lolafromburlington suggested with no luck.

     

    I think this problem started after I did an Apple Softaware update.

  • Carelesscreek Calculating status...
    Currently Being Moderated
    Apr 28, 2013 1:51 PM (in response to Jules2000)

    Posting what worked for me.

    Using MacMail 6.3(1503) with Yahoo mail Pro account.

     

    I just transitioned my wife over to a new MacBook Pro and when she sent her first email after I got her migrated she said she couldn't find the sent email. 

     

    When I looked at the sent section, I could see a bunch of old sent mail she had sent before using any client.  But not the new email she just sent from the MacMail client.

     

    So, I went to Mail Preferences and unchecked Save on Server for sent emails.  Now all her sent emails show up in her MacMail profile. 

     

    I should note that the Idle setting mentioned in earlier threads was greyed out in the preference.  Not sure why.  It being greyed out let me to try to find another option to fix the sent items not showing up.

  • Satome Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2013 5:21 PM (in response to Jules2000)

    I haven't lost any sent mail since disabling IDLE.

     

    The suggestion to uncheck 'save on server for sent emails' won't keep your sent mail synched up unless your email provider automatically copies it to a sent folder like Google does when you send through their SMTP server.

  • razzo Calculating status...
    Currently Being Moderated
    May 18, 2013 6:14 PM (in response to chrisaxe21)

    I had the same problem, but I have found a workaround. Its not a true fix because the messages still do not get transferred to the server, but at least it saves a copy on your Mac. Hopefully it will work to save your Sent Mail until Apple comes up with a true fix for this problem.

     

    For the mail account that is "losing" the sent messages, create a Smart Mailbox specifically for those Sent Messages. Here's how:

     

    1.  In Mac Mail, go to MAILBOX > NEW SMART MAILBOX

    2.  In the dialog box, name the Smart Mailbox (I named mine the account name + Sent Mail)

    3.  For the conditions, on the left pop-up select FROM, the middle pop-up select CONTAINS, and the right space type the email address of your account (the one that's losing the Sent Mail)

    4.  Click on the box below for "INCLUDE MESSAGES FROM SENT"

    5.  CLICK OK

     

    This should create a new Smart Mailbox that will appear on the left gray sidebar after your Inbox, Sent, and Trash folders. It will be under a heading entitled SMART MAILBOX. It should populate automatically with all of your previously sent mail plus your newly sent mail. However, just to be sure, go back to MAILBOX > SYNCHRONIZE ALL ACCOUNTS. This should synchronize everything and the new Smart Mailbox should populate.

     

    Remember, once again, this still does not seem to save the messages to the server so you will have to upload them manually. But at least you have them available to upload.

     

    Oh, in case you need to know, to upload them to the server manually, just view your SMART MAILBOX, click on the messages to highlight them, the drag them to the Sent Mail folder where they should have been in the first place (but weren't). As long as this folder is set up to sync with your sent mail from your server (as it should be), then this will upload the Sent Mail from the SMART MAILBOX to your server. Please note that they will not longer be in your SMART MAILBOX folder (because you moved them), but they will be in your designated Sent Mail folder.

     

    I hope this helps!

  • razzo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2013 9:06 PM (in response to Satome)

    When I unchecked "Enable Idle" it did save a copy of the message in the proper Sent Mail box on my computer. However, it did not upload that message to the IMAP server. That means that the message did not propagate to my iPhone or iPad, or get saved anywhere other than on the Mac. So, that doesn't solve the problem.

  • razzo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2013 9:10 PM (in response to Carelesscreek)

    Hi,

     

    Just so you know, unclicking "save sent mail on the server" does display the sent mail in the proper folder. However, it does not save the message on the IMAP server, so its only available on your Mac, not on any other device that uses the same account such as an iPhone or iPad.

  • Satome Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2013 10:19 PM (in response to razzo)

    @razzo

     

    Then you must have also had 'save sent mail on server' unchecked at the same time. The IDLE command is entirely separate from where sent messages are supposed to get saved.  You still need to separately tell Mail to save sent mail on the server. IDLE only affects the IMAP connection being kept alive.

     

    In my particular case, the vast majority of my sent messages were stored on the server in the proper folder.  A few, seemingly at random, would be sent but not saved.  For me, unchecking IDLE fixed that and also got rid of the error mentioned in the linked thread in console.

  • razzo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 19, 2013 7:06 AM (in response to Satome)

    @ Satome

     

    I actually tried with all four possibilities, with the Save Sent Mail on Server checked and unchecked and IDLE checked and unchecked. None of the four possibilities saved my messages on the server. They all only saved the messages on my computer.

     

    The only way I found to save them on the server is to do one of the tricks that works on the individual computer (for some reason they don't all work on everyone's computer consistently). On my computer (MacBook Pro Retina OS 10.8.3; Mail 6.3), the only one that works is to create a SMART MAILBOX, then drag the messages from the smart mailbox into the Sent Mail folder that syncs to the server. This is the only way I can get my messages on the server.

     

    One thing for certain, after reading 27 pages of messages, none of these solutions seems to work consistently for anyone. Like many have said, I also talked to Apple Care. They tried blaming it on my host, but I told them that my host had already had me create a Thunderbird account and it worked perfectly. So, my host had proven to me that it is Mac Mail. Apple Care claimed that if my iCloud account works, then they should all work, therefore it must be my host. I pointed them to this discussion that has almost 74,000 views and is not the only one on this subject. Only then did she say that she would elevate it to engineering. Hopefully, they'll acknowledge that there is a serious problem and address it soon.

  • Csound1 Level 7 Level 7 (32,310 points)
    Currently Being Moderated
    May 19, 2013 7:18 AM (in response to razzo)

    razzo wrote:

     

    @ Satome

     

    I actually tried with all four possibilities, with the Save Sent Mail on Server checked and unchecked and IDLE checked and unchecked. None of the four possibilities saved my messages on the server. They all only saved the messages on my computer.

    Then you have a problem with your mail setup, delete the account and start again.

     

    Note that

     

    Idle has nothing to do with sending mail, if you think it does you are imagining it. When Idle is checked mail will be pushed to your client, when unchecked it will be pulled by your client

     

    Save Sent Mail on Server is obvious, note that your mail will appear (in Mail) in a different folder from the one it would have if you chose not to Save on Server. If Save on Server is unchecked Sent items won't appear on other devices or on the website.

  • razzo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 19, 2013 7:44 AM (in response to Csound1)

    @Csound1

     

    I have deleted the mail account and started again many times. It always results in the same issue of Mac Mail not saving the Sent Mail nor transferring it to the server. I've spent at least 7 hours with tech support at my host and at least 5 hours with Apple Care, none of them can figure out what the problem is. We've tried every iteration. We've even wiped the entire computer clean twice and reinstalled the OS (with Mail) then manually copied all of the files and reinstalled all of the apps to be sure its a clean install. So far, nothing has fixed the Mail doesn't save Sent messages and transfer them to the server automatically issue.

     

    The only work around that I've found is creating a Smart Mailbox which will save the Sent Mail on my computer, then dragging them into the folder where they should have been saved so that they will sync with the server. I've tried all of the mentioned "fixes" in this forum such as the IDLE, uncheck Save Sent Mail, delete the account and start again, clean installs, Smart Mailboxes. So far, the only thing that works is the Smart Mailbox to save the messages, then manually drag them to the Sent Mailbox to sync with the server.

  • Sybil Ann Chick Level 2 Level 2 (220 points)
    Currently Being Moderated
    May 19, 2013 7:51 AM (in response to razzo)

    When I found a sent message wasn't in any sent folder in Mail or in iCloud, it was with a message sent from my .mac.com address, so if there's something wrong with the host that's Apple themselves and they need to sort it out.

  • Csound1 Level 7 Level 7 (32,310 points)
    Currently Being Moderated
    May 19, 2013 7:53 AM (in response to razzo)

    razzo wrote:

     

    @Csound1

     

    I have deleted the mail account and started again many times. It always results in the same issue of Mac Mail not saving the Sent Mail nor transferring it to the server. I've spent at least 7 hours with tech support at my host and at least 5 hours with Apple Care, none of them can figure out what the problem is. We've tried every iteration. We've even wiped the entire computer clean twice and reinstalled the OS (with Mail) then manually copied all of the files and reinstalled all of the apps to be sure its a clean install. So far, nothing has fixed the Mail doesn't save Sent messages and transfer them to the server automatically issue.

    This may be so but it is an error, and errors can always be fixed. Clearly Mail works (or millions of people would have the issue)

     

    Playing with the idle command (a server setting that affects incomimg mail only) is as useful as making coffee.

     

    Set it up with Save on Server checked. Send a test mail from Mail, go to the server and locate that Mail. Once found map the Server Sent folder to the Mail Sent folder or you will not see the sent mal on the client.

1 ... 25 26 27 28 29 ... 39 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (32)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.