13 Replies Latest reply: Jan 28, 2012 8:06 AM by TadMarshall
JoshZZ Level 1 Level 1 (0 points)

Hello everyone,

 

Today I received an iPad 2 as a gift.  It is the first Apple product I have ever owned.  I spent about 3 hours this morning trying to get it to turn on -- it kept displaying an image of a USB cord so I connected it to my computer.  Still the iPad would not display its desktop.  Finally, I learned that the iPad had to be connected to a PC running Windows (instead of the Centos 5 Linux system that I use).  Additionally iTunes had to be installed.  I find it extremely bizaare to require the device to connect to a computer before being able to turn it on.

 

Now after getting the device to boot, I am attempting to connect to my home wireless network.  Thus far it appears this is going to be Strike Two for me and the iPad 2.  My wifi network is 802.11g using WPA2-AES and 128 bit key.  The iPad 2 recognizes the presence of my network (the SSID appears in the listing when it prompts me to connect), however, when I supply the 128bit key to connect, the iPad 2 reports that it is unable to connect.

 

I went into the Network configuration in the General Settings and attempted to add the network manually (ensuring I could specify WPA2 as the encryption type).  Same failure.

 

Any hints on getting this thing to connect to my network?  I've already watered the security down to 128bit encryption (from 256bit).  All the other devices in my home are able to connect without issue.  The iPad 2 detects a strong signal from the router.


Thanks,
Josh


iPad 2, Other OS, Centos 5
  • Dadof2Girls Level 3 Level 3 (545 points)

    Do some searches here on the threads.  This has come up a lot.  There are multiple issues that can be at play... the type of router, router settings, channel, etc... 

     

    Best.

  • Roosevelt Jones Level 2 Level 2 (380 points)

    Also check the article at http://support.apple.com/kb/HT4199.

     

    If you have Wi-Fi and LAN connections on your Windows PC, setting up an ad-hoc network may be another option.

     

    Does your router see connection attempts from the iPad?

  • Mice On Rollerskates Level 1 Level 1 (10 points)

    I had the same problem. I had not problems with connection when I down graded my security to WEP, not something I was happy about. I chalk it up to another flaky Apple product. I love my iPad 2 I really do, I use it everyday. But, Apple has their heads up the @ss when it comes to choose what they want to support. Sometimes I swear the choose to support the least common denominator because they just simply can't handle supporting anything to advanced or complex. I did get a new Cisco n class router that I am going to try. I want the faster n speed for the wireless (the iPad 2 is the only thing I use wireless, everything else is wired for the best security and speed) so it will be interesting to see if it does any better.

     

    Robert

  • JoshZZ Level 1 Level 1 (0 points)

    I appreciate everyone that responded with the intent of helping me solve the issue.  This forum is weird -- there are many users that try to help with iPad2 issues and then there are many that mock me and say I should just return it for expecting this very expensive device to just work.

     

    After a late night of debugging with Wireshark, I finally tracked down the problem (Apple, feel free to send me a cheque for my services)

     

    I will post the solution here for those who desire to use an 802.11x security protocol that has not yet been compromised (WPA2-AES).

     

    When you attempt to join a wireless network, the iPad asks for the password.  If this password contains any characters other than 0-9, A-F (hexadecimal), WPA states that Password Based Key Derivation Function 2 (RSA Security, PKCS #5) must be used to calculate the pre-shared key.  If however, the password contains only hexadecimal characters, then that value *is* the key to be used (e.g. do not run the PBKDF2 function)

     

    I specify my network keys in hex both in my router and my devices.  This means the devices nor the router need to invoke PBKDF2.

     

    The key I specified in my router was entered using upper case hexadecimal letters (e.g. A, B, C, D, E, F) whereas the key I entered on the iPad 2 was entered using lower case hexadecimal letters (e.g. a, b, c, d, e, f).  Since I am specifying a key, the uppercase and lower case hexadecimal values have the same binary represention -- meaning they are identical.  The iPad, however, does not treat them as identical and therefore attemps to connect using an invalid pre-shared key (my guess is it is running PBKDF2 when it shouldn't be -- but I don't care enough to troubleshoot it any further)

     

    In summary, this issue will only affect those of us that specify our pre-shared keys explicitly (via hexadecimal) in the router.  As a workaround, make sure you enter the hexadecimal key using only lower case letters (a-f) when you set the key in the router and use lower case letters (default) when entering the key on the iPad 2.

     

    After doing so, iPad 2 can connect as can the other 20 devices I own that followed the WPA specification in the first place.

     

    Josh

  • BobTheFisherman Level 6 Level 6 (11,030 points)

    Hex values for upper and lower case characters are not the same. If they were how would your keyboard know you wanted an "A" and not an "a"? "a" (hex 61) (binary 00111101) is not equal to "A" (hex 41) (binary 00101001).

    See here http://www.asciitable.com/

  • Roosevelt Jones Level 2 Level 2 (380 points)

    For the purposes of entering in a hex string a and A are the same value, 10 decimal. What you saying is correct if the string is supposed to interpreted as ASCII. The OP message indicates that the standard accepts both forms so care needs to be taken if you want the key to be interpreted as a hex string and not ASCII.

  • Roosevelt Jones Level 2 Level 2 (380 points)

    I'm just curious if you were able to enter the string in upper case and the key still failed to verify?

  • BobTheFisherman Level 6 Level 6 (11,030 points)

    Roosevelt Jones wrote:

     

    For the purposes of entering in a hex string a and A are the same value, 10 decimal. What you saying is correct if the string is supposed to interpreted as ASCII. The OP message indicates that the standard accepts both forms so care needs to be taken if you want the key to be interpreted as a hex string and not ASCII.

    You are correct. I didn't read carefully enough. Maybe the OP was inputing ascii not hex values. Interesting.

  • Trisha0208 Level 1 Level 1 (0 points)

    How in the world do I get my keyboard to go to lowercase letters?? This is my first Ipad and I have no clue on what I am doing...LOL

  • Roosevelt Jones Level 2 Level 2 (380 points)

    The shift key goes into different modes as you tap it. If there is blue on the key, it will generate upper case characters. The keyboard tries to help so just check to make sure the arrow is black before you start typing.

  • johnsmithjr Level 1 Level 1 (0 points)

    I have the same problem... I tried as you say a passphrase consisting of only lowercase characters and numbers but still the same issue.

     

    The little flower is spinning forever meaning my ipad is not getting an ip address from the dhcp server...

  • yogix Level 1 Level 1 (0 points)

    Hi JoshZZ

     

    I too had a similar problem connecting my new iPad 2 to my home network. The little circle kept spinning next to my network name and when I tried to connect to the internet it said it had no connection. My network is WPA2.

     

    My password is numbers and upper and lower text. The way I did it was to click the blue circle with the right arrow and I clicked Static and entered in my IP, Subnet, Router and DNS settings manually.

     

    It now connects with no problems.

     

    I think I had a similar problem with iPods and manually set them up and they work perfectly. I am on Sky+ using a netgear router. I have connected to a BT network and didn't experience the same issues.

  • TadMarshall Level 1 Level 1 (0 points)

    Thanks for the uppercase trick.  My issue was with the iPhone 4S, but I think it's the same problem.  I was using a random 256-bit key from Steve Gibson's Perfect Passwords ( https://www.grc.com/passwords.htm ) so without changing the password on my router and all other devices my only option is to type it in using 64 hexadecimal digits.  It's hard enough to type something like this into the iPhone's "keyboard", being forced to use uppercase A through F just makes it harder.