5 Replies Latest reply: Dec 13, 2012 8:53 AM by mspritch
DaiVernon Level 1 Level 1 (0 points)

Colleague came in over weekend to use a specific PowerMac and large screen rather than her usual MacBook Pro.

 

She was unable to login as 'herself' as she repeatedly got the message that she was <<unable to log in at this time because an error has occured>>.

 

No 'headshaking' as if she had given the wrong password, but she couldn't log in or accesss our sharepoints.

 

She tried another desktop Mac (a  macmini) and got same result...

 

She could (and today still can)  happily log in to the server via her laptop...

 

What gives?


iMac, Mac OS X (10.5.4), 20" integrated screen iMac PPC
  • 1. Re: <unable to log in at this time because an error has occured>
    gracoat Level 3 Level 3 (660 points)

    I've seen this behaviour on my network.  99% of the time, a restart of the client computer fixes it.

    .9%, there's another network user logged into that computer already.  ....and that user has not logged out...  They've just returned to the login window.

    Lastly .1%, a restart of the AFP service on the server would fix it.

     

     

    Between these three reasons, I've been able to rectify the situation in every time.

     

    -Graham

  • 2. Re: <unable to log in at this time because an error has occured>
    DaiVernon Level 1 Level 1 (0 points)

    Thanks for your interest...

     

    this occurred over the weekend so I was unable to fully document the situation...

     

    but restart didn't seem to clear it, I asked colleague to demo this to me and the error still occurred...

     

    the 0.1% solution has yet to be tried....

  • 3. Re: <unable to log in at this time because an error has occured>
    DaiVernon Level 1 Level 1 (0 points)

    Stopped and restarted AFP service...same result, unfortunately...

     

    We are set up as mobile users

     

    2 specific macs on which my colleague could not log in.

     

    1 on which I could not log in

     

    In each instance, neither of us had used these macs before so were not listed in logon screen - had to use <Other> and enter credentials manually. Proper credentials entered, icons for each individual displayed, but still <unable ...an error has occurred>

  • 4. Re: <unable to log in at this time because an error has occured>
    John.Kitzmiller Level 3 Level 3 (870 points)

    I had this same issue recently, and the root of the problem was that our directory server was not replicating properly. If you have a master/replica configuration, I would try destroying the replica and re-binding.

  • 5. Re: <unable to log in at this time because an error has occured>
    mspritch Level 1 Level 1 (0 points)

    We just had a similar issue here.

     

    On the MacBook Pro, we needed a new user to log in. Existing MBP users were fine, new users no chance, although administrator accounts were OK. OSX 10.7.4, same issue with 10.7.5.

     

    Clues were found elsewhere on this site (https://discussions.apple.com/thread/4140320?start=0&tstart=0), but what we did to fix it was this:-

     

    Ensure the Mac will create a local folder for new user accounts (top tick-box)

    In AD, turn off the Z: drive mapping to the home folder (or whatever drive you use) for that particular user

    On the Mac, log in and let it create the local home folder

    In AD, turn the drive mapping back on and respecify the home folder path

     

    The account should now continue to work as it's already created the local home folder.

     

    Admin accounts worked because we don't map the home folder for those. Originally we were mapping using a logon script, which is why we didn't have an issue when setting up the other users initially. What probably doesn't help is that we use DFS, and the Macs don't like talking to DFS (we have to map to the \\servername\share instead of \\domainname\dfs-share for those).

     

    Hope this helps. Many thanks to user "Think Touch" for providing the clues.