6 Replies Latest reply: Feb 23, 2012 2:00 AM by Matthew Elliott1
jessywessi Level 1 Level 1

Skype wont open, saying its "not supported on this Aschitecture". How can I get it to work??

 

I have downloaded Skype from its main website for MAC, but still it says " can't open Skype. not supported on this Architecture" when i click on it.  I don't know why it wont. This isn't an old Desktop Mac computer, and Skype downloaded with no problems on my Mac Lap top. So what's wrong this time?

 

Any suggestions would be helpful! Thanks!


iMac, Mac OS X (10.5.8)
Reply by babowa on May 23, 2011 8:58 PM Helpful

Are you running 10.5.8 as showing in your profile? If so, I'm wondering if the latest version of Skype may not be backwards compatible (although it should)? You might want to contact Skype support and ask about the compatibility of their version(s); make sure to tell them which Mac OS version you're on and, if necessary, also ask for a link to download an older version.

All replies