3 Replies Latest reply: May 25, 2011 12:45 PM by tjfrazer
molan Level 1 Level 1 (0 points)

Over the last 48 hours I've noticed that my iPhone 4 with 4.3.3 keeps losing both WiFi & 3G settings all the time.

 

I can force the WiFi back if I go to my carrier settings and simply ask it to search for available carriers (no idea why this fixes WiFi as it isn't helping to restore 3G!).

 

If I do this I get WiFi back for maybe 20 seconds before it drops again.

 

If I power down and back up again I seem to get WiFi for a longer time but still get issues with 3G.

 

Any ideas anyone?


iPhone 4
  • diesel vdub Level 7 Level 7 (21,975 points)

    Basic troubleshooting steps are reset, restart, and restore.

    Have you tried any of these?

  • molan Level 1 Level 1 (0 points)

    Tried the first two and it seems to be working Ok for now - will see if it survives the next 24 hours

     

    Always a bit nervous about a full restore in case I lose loads of stuff in the process!

  • tjfrazer Level 1 Level 1 (0 points)

    I have a 3Gs and I've tried everything. I even restored as new phone and the issue continues. It has to do with the Wifi antenna and the bluetooth antenna, I believe they are both the same. I get intermittent wifi at home, work and other hotspots. I also get static on my bluetooth earpiece. I have to hold the phone within 6 inches of my ear for the static to go away. If I take the phone off of headset during that call, the phone is crystal clear. I have done the forget this device. I've done the turn off iPhone and turn off router at home, star the router up and wait, then turn iphone back on. Same issues continue. It has to do with the software. I'm not sure how they power the antenna, but maybe the software update 4.3.3 has effected it.