8 Replies Latest reply: Jun 10, 2014 12:45 AM by one000mph
Curtis Tucker Level 2 (270 points)

I'm stumped. I created a Smart playlist of Media Kind is "Podcast" + Plays equals "0". Then I synced it to my iPad. I selected the new playlist in the iPod app on the iPad and there's nothing there...the playlist is empty.

 

Smart playlists with only music content sync as expected. Smart playlists using "Media Kind is..." filters other than "Podcast" sync as expected.

 

The problem seems to be related to selecting "Media Kind is Podcast" filter. The "Media Kind is not Podcast" filter works as expected.)

 

As I final check I selected all of the podcasts and created a new, regular,  playlist with the the selection. The new playlist synced as expected.

 

Any suggestions?


Mac mini (Mid 2010), Mac OS X (10.6.7)
  • Ty Lastrapes Level 1 (35 points)

    I have the same issue with syncing smart playlists of podcasts to my iPhone.  I've found a multitude of forum posts and blog entries on the subject.  I haven't found anything that works yet.  I just sent a bug report to Apple.  I suggest you do the same:  http://www.apple.com/feedback/

  • Curtis Tucker Level 2 (270 points)

    I agree and came to the same conclusion. I submitted official feedback. I hope they address this in an update. Apparently it is not a new issue.

  • Ty Lastrapes Level 1 (35 points)

    I've found the solution to my problem without changing my podcast smart playlists.  When syncing with iTunes, click your device node (iPhone for me).  The smart playlists will appear under both the Music & Podcasts tabs.  I unchecked the plyalist from music & checked them under podcasts & now the podcasts appear on my iPhone within my playlists. 

  • ron212 Level 1 (0 points)

    I had the same problem.  My iPod shows there are 8 playlists but I cant bring them up.  I fixed it by syncing one non smart music playlist.  Now I can display all my podcast smart playlists.

  • rjp0503 Level 1 (0 points)

    I ran into this problem too but resolved it by doing the following:

     

    Select the device.

    Click on the Podcasts tab.

    At the bottom left will be a list of playlists under the heading "Include Episodes from Playlists".

    Check on the playlists that have the podcasts you want to sync.

    Sync and you should now see the podcasts on your device.

  • Curtis Tucker Level 2 (270 points)

    Just tried it. The smart playlist name syncs to my iPad but it's empty, no songs.

  • nledez Level 1 (0 points)

    It work's for me.

     

    Thanks.

  • one000mph Level 1 (0 points)

    I found that changing the Media Kind (Right Click Podcast -> Get Info -> Options tab -> Media Kind) from Podcast to Music solved the problem. Now playlists containing podcast will sync properly although nothing is showing up in the Podcast app still. Hope Apple releases an update on this soon becuase this should be an unnecessary workaround.