Previous 1 2 3 4 5 Next 65 Replies Latest reply: Jan 23, 2015 12:08 AM by varrt Go to original post
  • jan0k Level 1 (0 points)



    has anyone successfully compile rdesktop 1.7.2 (with smartcard support) with Mountain Lion?

  • HaydenRU Level 1 (0 points)

    Yes, TRON's link on previous page compiles just fine.

  • mstryd Level 1 (0 points)

    Interesting. Do you have the same frequent crashes as me (malloc problem)?

  • TRON Level 1 (20 points)


    I've been running my rdesktop build on Mountain Lion for a while without crashes.  You may want to consider updating your system with Shawn Geddis's SmartCard services installers:


    by the way, is rdesktop launching in the XQuartz application?  which version are you running?  thanks.

  • mstryd Level 1 (0 points)

    TRON, thanks for replying.


    Yes I am running rdesktop in XQuartz 2.7.4

    Did upgrade the smartcard services.


    I am using SafeNet Authentication Middleware (for example for VPN), not sure if that might be the source of the problem (but it works for openvpn/Viscosity)


    Have upgraded to Mountain Lion but didn´t change much.

    Interesting fact: if I retry to connect a couple of times, sometimes it works for 5 minutes or so and then crashes.


    What kind of smartcard/token are you using?

  • mstryd Level 1 (0 points)

    Just had an idea: for testing purposes, could you supply me your rdesktop binary, TRON?

  • TRON Level 1 (20 points)


    My compiled rdesktop is located here:


    note:  this file should be copied to /usr/local/bin/ , and will probably require the "keymaps" folder which usually gets installed to /usr/local/share/rdesktop/


    A "ZIP" version of my "keymaps" folder can be downloaded here:


    Unzip the "keymaps" folder and copy the entire folder to /usr/local/share/rdesktop/


    Good luck!

  • mstryd Level 1 (0 points)

    Thanks. Your version works much better. It is still giving the same errors on the console, but it doesn´t stop the RDP when doing so. One catch so far: as soon as the error appears the smartcard redirection into the target machine doesn´t work. So I can´t use it within the RDP. Just a minor glitch for me, though.


    Do you have the errors in the console as well? Do you use SC redirection in RDP?


    I guess I need to learn gdb and find out what is really going wrong.

  • TRON Level 1 (20 points)


    I'm not seeing any errors in the console. The only output I get is:

         Autoselected keyboard map en-us


    I do use scard redirection, and it works for "some" purposes.  I'm able to log-in to the remote server (Windows Server 2003, 64-bit) using my smart card, but when I use MS Outlook in the remote session, I'm not able to use the smart card certificates to digitally sign emails.  However, I am able to use the smart card certificates to log-in to secure sites in Internet Explorer in the remote session.

  • jan0k Level 1 (0 points)



    any time i forward my smartcard to a windows server my rdesktop crashes with this error message:

    "Segmentation fault: 11"


    Any ideas?

  • AlexHH1 Level 1 (0 points)

    Hy Tron,


    could we contact elsewhere?

    I would like to offer a Business Deal with you?

    Are you interested?


    PM is disabled here. . :-(


    Regards from Germany



  • TRON Level 1 (20 points)


    Unfortunately, I can't provide any professional (business) services; however, I'd be happy to offer any help I can.

    If you follow the original link to my rdesktop files,



    you should be able to leave a comment on any of the files so I can contact you outside the discussion.  Thanks.

  • Ian Cheong Level 1 (30 points)

    Have been playing with macports rdesktop +smartcard on Snow Leopard and Leopard. rdesktop 1.7.1 build fell over. rdesktop 1.6 rev 83402 seemd to have stabiliy problems. So have been fiddling with 1.7.1.


    Minimal fix to get rdesktop 1.7.1 + smartcard to build. Seems to still recognise smart card at least partially for SafeSign token administration utility


    1.     fudge to non-existent lib64 problem with:


         $ sudo ln -s /opt/local/lib /opt/local/lib64


    2.     comment out part with missing symbols in scard.o. See diff file content:


    --- 1.7.1-src/scard.c          2011-12-07 19:49:44.000000000 +1000

    +++ irc-1.7.1-works/scard.c          2013-05-02 20:22:05.000000000 +1000

    @@ -2152,7 +2152,9 @@


                         /* Translate to local encoding */

                         dwControlCode = (dwControlCode & 0x3ffc) >> 2;

    -                    dwControlCode = SCARD_CTL_CODE(dwControlCode);

    +/*IRC try rid of this

    +dwControlCode = SCARD_CTL_CODE(dwControlCode);





    @@ -2197,6 +2199,7 @@

                         DEBUG_SCARD(("SCARD: -> Success (out: %d bytes)\n", (int) nBytesReturned));



    +/* IRC try rid of this


               if (dwControlCode == SCARD_CTL_CODE(3400))


    @@ -2214,6 +2217,7 @@






               out_uint32_le(out, nBytesReturned);

               out_uint32_le(out, 0x00000004);


    There is a reference to removing definition of SCARD_CTL_CODE in 2005 revisions of MacOS Smart Card Services. martcardCCID-55000/ccid/ccid/ChangeLog

  • barlow36 Level 1 (0 points)

    Hi Thron, I'm new on Mac regarind this issues: I tried to install rdesktop as you postet on the following "

    Re: MS Remote Desktop and smart card reader

       13.11.2008 14:49    (in response to $ailor)"

    I tried to do this, but i got an error, see attached. Would you please be so kind to help me?


  • TRON Level 1 (20 points)


    It looks like you may not have the XCode Command Line Tools installed.  XCode is a free download from the Mac App store, but the Command Line Tools is a separate update/download after XCode has been installed (


    After XCode and its Command Line Tools have been installed, restart your Mac and try again.


    On the other hand, you can get a pre-compiled version from my online-links given above.