4 Replies Latest reply: May 31, 2011 2:33 PM by legolas-woodelf
legolas-woodelf Level 1 (0 points)

Whenever I try to export photos from iPhoto to a Flash Drive to use on my TV, digital photo frame or friend's Windows computer, iPhoto seems to export two files for each photo - one is the normal photo file and one seems to be some sort of copy of it with the prefix  ._  before each filename. Obviously these additional files can't be read by TVs or photo frames, meaning that when I view a slideshow on these other devices, every other photo comes up as an unreadable file error message.

 

Yet if I put the Flash Drive back in the Mac, these other files can't be seen and therefore can't be deleted.

 

The Flash Drive has been formatted as a FAT32 disk in order to try and make sure it's compatible.

 

Anyone know what this second file is for and how to get around this problem.

 

My Mac is a 17" iMac - PowerPC G4 - 1.25 GHz - 768 MB RAM - running 10.5.8.

iPhoto is iPhoto 4.0.3.

 

P.S. I realise it's an ancient iPhoto version I'm using, but I did upgrade to iPhoto 6 a while back, but was disappointed with the Slideshow features compared to version 4 so I Time Machined back.

(This thread has the details of those issues, though I got no replies):

https://discussions.apple.com/thread/2631510?threadID=2631510&tstart=0

 

Any thoughts or advice on my current problem most gratefully received.


Mac OS X (10.5.8), 17" iMac PPC G4 1.25 GHz 10.5.8
  • Terence Devlin Level 10 (137,945 points)

    What you're seeing is the Resource Fork of the file. The FAT on Windows doesn't understand it and it shows as this apparent second file.

     

    http://www.macupdate.com/find/mac/resource%20fork

     

    Lists many of the apps and utilities that you can use to strip these from the files.

     

    Regards

     

     

    TD

  • legolas-woodelf Level 1 (0 points)

    Thanks for the swift reply Terence.

     

    Based on your post I've done a bit more digging. I gather resource forks are also known as DS Store files and that I need to delete them to solve my problem.

     

    However I've now downloaded a number of freeware apps and tried deleting the relevant DS files, but still they show when I put my USB Flash Drive into the USB port on my TV.

     

    I've tried using Onyx, Cocktail and DSWipe and all seem to show that they've successfully deleted the files, but when I plug the flash disc into my TV they're still there. It's as if OS-X automatically rebuilds new DS Store files the moment the old ones are deleted.

     

    What am I doing wrong?

  • Terence Devlin Level 10 (137,945 points)

    No, Resource Forks and ds_store files are not the same thing.

     

    Resource forks are part of the actual file. Ds_store files are part of the folders that contain the files.

     

    I have used both Blue Harvest and the Grim Ripper (see link above) with success.

     

    Regards

     

     

    TD

  • legolas-woodelf Level 1 (0 points)

    Cracked it!

    I tried various things without success, but finally WinFSCleanser did the trick.

    Sincere thanks for your help, Terence - I'm much obliged to you.