Previous 1 2 3 Next 30 Replies Latest reply: May 21, 2015 3:05 PM by Darcy1music Go to original post
  • William Hamilton Level 1 Level 1 (90 points)

    Yodrak wrote:

     

    I don't see my AppleTV2 in iTunes either.  But then, I don't know why iTunes would want or need to see it.

     

    The AppleTV sees my iTunes library, and sends whatever I select to my TV.  That's all I need.

    Exactly.  Why Apple has decided to vary implimentation of AppleTV and AppleTV2 in iTunes is a mystery to me.  Rather than showing up in the devices list, you have to go to the Advanced menu in iTunes to select folders for Photo streaming.  Music is automatic.  Would have thought including the AppleTV2 under devices would have been much clearer.

  • vazandrew Level 6 Level 6 (17,040 points)

    ATV2 doesn't sync thus there is no need for it to appear.

  • TheDude73 Level 1 Level 1 (0 points)

    This is the correct answer - for all of you stating ATV2 won't ever show up in iTunes, you're 100% wrong.

     

    You cannot have the ATV2 plugged into power AND USB at the same time.  Open iTunes on your PC/Mac, plug in Apple TV2 to micro-USB, plug into USB on PC/Mac.  Within a few seconds Apple TV will appear in your iTunes device list.

     

    I just tried it myself after buying 2 brand new ATV2s. 

  • vazandrew Level 6 Level 6 (17,040 points)

    It will show up when tethered and for restoring the device. Not for regular use

  • Williams Level 2 Level 2 (185 points)

    Under normal circumstances, ATV2 will not show up the way the 1st Gen model did in iTunes under devices. It's my understanding that ATV2 is merely a networked device, unlike the first version, this one has no storage of any kind, it simply streams everything.

     

    However, Apple has now integrated the functionality to connect your Apple TV to your computer in order to perform a factory settings/software restore. Which can be helpful when your latest update blows things up or is interrupted. When you connect your ATV2 using a MICRO usb cable, it WILL show up in iTunes under devices prior to the restore. Spiffy! If you can get it to work...

     

    http://support.apple.com/kb/HT4367

  • MAK25 Level 1 Level 1 (0 points)

    all of these genius' on here telling us they have the answers to our problems need to take there place behind you my man. it was just as simple as unplugging the power cord. thank you so much. worked perfectly and now itunes recognizes the apple tv

  • Richard2478 Level 1 Level 1 (5 points)

    I don't know if you use VirusBarrier X6, but I found it frequently blocks AppleTV from connecting, even when you set it to allow AppleTV.

     

    When I sought support from Intego, I had to delete and reinstall the program, then set it to allow AppleTV, which is a setting at the bottom of the Antivandal tab on the main control screen.  It still didn't fix it, but it seems to work now after later updates, so maybe they addressed the problem.

     

    I hope that be of some help to you or someone in the future.

  • francbecerra Level 1 Level 1 (0 points)

    I'm having the same issue with my old model Apple TV. Apple's software has been mega buggy lately. First my iPod and now my Apple TV. Get your act together, Apple.

  • charlottefromstillwater Level 1 Level 1 (0 points)

    I just bought apple TV om Dec 2011 and was having the same problem as of right now. In reading the forums, a simple step worked for me for both my computers (PC and Mac). Go into Itunes PREFERENCES then select DEVICES. Check the box that says ALLOW AUDIO CONTROL FROM REMOTE SPEAKERS. I did that and both libraries were instantly on my ATV. No need to reboot. And trust me, I am no computer wizard.

  • markbeicke Level 1 Level 1 (0 points)

    Mine ATV2 does not either. It did for awhile. I would like it to show up so that I can view movies or tv shows purchased on my ATV on my iPad when I'm traveling.  Any thoughts?

    Thanks!

  • Atlanta Yankee Level 1 Level 1 (0 points)

    This was my exact problem. I had the ATV2 plugged in with power and micro-USB and it wasn't showing in iTunes. As soon as I unplugged the power cable, the device rather quickly appeared in iTunes. Exactly the answer I needed. Thank you!

  • Echrfl Level 1 Level 1 (0 points)

    My actual problem is that I cannot update my ATV2 to the latest software using WIFI or an ethernet cable. It is currently running 4.4.4 and I need a newer version in order to be able to use it with my MacBook (running Lion OS X). When trying via cable/wifi it simply says that update to new software is not required. I recently moved to China, all my apple gadgets as well as my apple account comes from Sweden, guess that has something to do with it?

     

    Anyway, it does not work to update to new version via cable/wifi so I tried to plug the ATV2 into my MacBook Air using an micro usb. I first unplugged everything from the ATV2 and the inserted the micro USB (first into the ATV2 and then into the MacBook). The problem is the ATV2 does not show up in iTunes. I tried to restart the computer with the ATV2 plugged in but that didn't work either. And no, I do not have the power cable plugged into the ATV2 (even though I tried that version as well). I am running iTunes 11.0.1.

     

    Does anyone know how I can get the ATV2 to show up in iTunes?

     

    Hope you guys can help me...

  • siamless Level 1 Level 1 (0 points)

    Unfortunately I have no answer to your problem;

    What I can assure is that there is deffinetely a issue with ATV 1st gen and connecting it to a IT library.

    I wonder if any of you guys who are running the latest Apfel software managed to do so?

    Factory reset, unpluging, etc. ppp did not work...

     

    Apple TV 1st gen, Apple Arport Extreme, Apple Mac Pro 5,1

  • dotwongdotcom Level 1 Level 1 (0 points)

    Thanks! This solved it for me. Removed the power cord while still keeping the micro-USB plugged in and it appeared in the Devices list

  • Scott Maiden Level 2 Level 2 (325 points)

    For me the trouble was an inferior micro USB cable. For anyone else having truble with this, I can tell you 100% that a Micro USB cable from Rocketfish ($20 at BestBuy) will do the trick. Simply turn on your computer. Don't launch iTines yet, plug ONLY the micro USB cable into the Apple TV2. ITunes will launch and prompt you to restore the AppleTV. Very easy actually, given a high quality USB cable.