Previous 1 2 Next 15 Replies Latest reply: Mar 7, 2013 12:54 PM by ScubaJonL
darden Level 1 Level 1 (0 points)

Hi, I have just recently come across this issue; iMovie '09 and '11 have both exported movies without a problem before. I'm currently using iMove '11, with external hard disks for storage and scratch space, and I need to export four projects in HD, each about an hour long.

 

When I attempt to export an HD movie (using the "export movie" tab in the "share" menu) iMovie appears to process the movie normally, giving a reasonable time estimate and everything, but when it is finished the movie file is nowhere to be found and iMovie does not show that it has been shared at all. There are no error messages, freezes, or crashes. The exported movie simply seems to have vanished, or never been made.

 

The only issue I can think of, is that maybe this is due to using external hard disks for storage. I use two of them, one with all of my iMovie projects and movies and one that I am exporting the finished product to. It cannot be a FAT32 issue, since they are all using OSX formats.

 

Has anyone ever had this problem before?


MacBook Pro, Mac OS X (10.6.7), Mid 2009, 2.53GHz, 4GBs, 256GB SSD.
  • zyfert Level 3 Level 3 (610 points)

    When you Share > Export Movie... you are asked where to export to and I presume that you are specifying your external HD which should show in the available list of export places.

    It's very strange that an export icon is not placed beside your project in iMovie after conclusion.

    How are your external disks connected - firewire is generally preferred.

    The only thing I could suggest is a short trial, export to your Desktop and then if successfull, move it to your external drive.

    Z.

  • stevefromtemecula Level 1 Level 1 (0 points)

    I recently encountered a similar problem - related to the 'not enough heap space" thread I've seen.

    Using iMovie I prepared a brief (30 sec) clip taken with my Canon PowerShot SD450 camera. I had to use iMovie to rotate the clip because of the way I was holding the camera.

    It works fine and the clip views great on my MacBook Pro.

    I want to place it on my iPad (1) and, following the help from iMovie, I tried to export it to iTunes. I click on the iPad option which selects 3 formats and it appears as if it's going to export reporting about 2 minutes to do so. However, the exercise terminates with a message indicating that the action cannot be completed because there is not enough room on the destination disk??? What?

    Well, I've got a 500gB drive and an 80gB partition for parallels and the system reports an available 360gB or so.

    So I don't think space is the problem.

    As a recently converted Windows user - I reluctantly report that I think we gotta bug here...

    Please help...

  • darden Level 1 Level 1 (0 points)

    Thanks for your replies. First, a little clarification on my setup: I use an 80GB USB external hard drive for storing all of my movie files and projects, and I was trying to export to a 1TB USB external hard drive.

     

    I do have some good news; I managed to export one movie by copying all of the data related to it (project file and clips) to the 1TB drive, then exporting to that same drive. It worked. Right now, I'm trying to export another film, which is stored on the 80GB, to the 80GB drive. I'll post another update when it's finished. Although firewire is undeniably better (faster) I can't see why this would be an issue. I was too cheap to pay $100 more for a firewire drive...

     

    Anyway, if this export fails then I'll probably try copying all of the movie files and projects to the 1TB. I would try out your advice and export directly to desktop, but so far I've tried to avoid this since my primary 'disk' is an SSD and I don't have TRIM enabled. So I'd rather not write massive files all over it and potentially slow things down before I can get my hands on OS Lion (with TRIM support).

     

    What the real issue here is, I really cannot say. The only thing I can think is that somehow iMovie gets confused when your using too many externals at once? But then Steve (above) says he's got the same issue and no external hard drives at all. Very strange ...

  • zyfert Level 3 Level 3 (610 points)

    What you are saying above is quite different to your first post i.e. sharing - exporting  as opposed to just moving project and event files.

    Anyway researching "heap zone" this following thread may be of use to you:

    https://discussions.apple.com/message/8619334#8619334

    Try using the search box above and you will find more.

     

    Firewire external drives formatted mac OS extended (journaled) allow you to use iMovie while all your event and, if necessary, project files are located on the external drive.

    It's the most efficient use of internal HD space.

     

    Z.

  • darden Level 1 Level 1 (0 points)

    sorry I wasn't very clear, but what I meant was: I moved all of the event/project files to the other drive, re-opened iMovie, and then shared/exported the project to that same external drive. Before, I had all the project files/events on the first external, then tried to share export to the second external. Anyway, it worked once the event/project was on the same drive as the export destination.

     

    The same thing happened when I exported a project, who's files were on the first external, to the first external.

     

    The error only appears to occur when I attempt to export files/project stored on one drive to the second drive.

  • Castillon Level 1 Level 1 (0 points)

    I have the same problem, except that it's happening on the same drive; i.e. iMovie 11 seems to finalize export but no file is to be found anywhere. Has anyone faced something similar?

  • zyfert Level 3 Level 3 (610 points)

    If you want to find the finalised movie files, do this:

    When the project is finished finalising, you will see in iMovie some little icons to the right of the project name to indicate the various sizes that have been rendered.

    Now to find these, go to your Movies folder:

    (Click on the Finder face in your dock then your User name then the Movies folder.)

    Next click on 'iMovie Projects' then select and right click on the name of your finalised project.

    From the right click menu select 'Show Package Contents' then finally click on the 'Movies' folder.

    You should now see all of the exported movies.

    Regards, Z.

  • Dr.D74 Level 1 Level 1 (0 points)

    I had the same issue but zyfert's response worked perfectly!!  Awesome.

  • easyg1 Level 1 Level 1 (0 points)

    I discovered your discussions earlier today when I had trouble uploading a video onto YouTube. Your suggestion was excellent, it worked. I know this response is in the wrong category but I couldn't find the original one for YouTube. So thank you for your suggestion. I know where to look when I have a problem.

  • frenzo Level 1 Level 1 (0 points)

    Darden,

     

    this isn't a disk issue. I'm saving projects straight to my laptop and experiencing exactly the same problem as you. The whole exporting process seems to work fine, except that the file is nowhere to be found where it should be saved. It's especially annoying since exporting lenghty projects takes hours. This has happened repeatedly with iMovie '11, and yet all my software is up to date, running Mountain Lion.

     

    Your original post is over a year old, and I'm surprised that Apple hasn't fixed this problem yet!!! I will try Zyfert's workaround next, but still this is frustrating. 

  • jabcyberia Level 1 Level 1 (0 points)

    I just want to say that I have looked all over for an answer to the problem of not being able to find the missing file after it has been exported and zyfert's response is the first answer I've seen that actually helped me. I don't know what is causing iMovie to do this (I've never had this trouble before) but I have tried exporting this movie 4 times (countless hours as it is a LONG movie) and all this time the file was in the Package Contents folder and named "720p.mov".

     

    Thanks to darden for posing the question well so it attracted attention in the forum and thanks to zyfert for helping me out. Now I can make my deadline!

  • zyfert Level 3 Level 3 (610 points)

    Good to have been of help.

    May I make an observation.

    I would assume that if you cannot find your file after exporting then you would have used either Share > Media Browser or Finalise Project.

    I say this because if you used Share > Export Movie or Share > QuickTime, the first thing that happens is that you are asked if you want to rename your movie and then where you want to save it.

    You can select to save it anywhere you like, such as your desktop etc.

    Something to remember in future.

    Best, Zyfert

  • frenzo Level 1 Level 1 (0 points)

    It seems that we're dealing with separate issues here. I've been using Share > Export using QuickTime option all along. Even after choosing where the movie file should be saved on my drive, the file is nowhere to be found when the exporting process is complete after several hours. And I'm not even getting an error message.

     

    However, when I try Export Movie (not using QuickTime) I do get an error message, -49. According to another forum somewhere, this error has to do with Time Machine getting in the way. I've tried turning off Time Machine, and indeed it works perfectly! A simple step to take, but one that I wouldn't have though of.

     

    So people, if you can't find the movie file you've just exported, it could just be Time Machine getting in the way! I hope Apple creates a fix for this.

  • jabcyberia Level 1 Level 1 (0 points)

    Actually, I have tried exporting via Share > Export Movie AND Share > QuickTime and had this problem with the missing (seemingly non-existent) file with both options. I have never had this problem in the past. This is the first time it has come up, even though I've always used the Share > Export Movie command. I knew it had to be creating a file, however, because it was using up hard disk space. It was just a matter of finding it. And I have you to thank for that lol

Previous 1 2 Next