11 Replies Latest reply: Jun 12, 2011 6:05 AM by chapi-GOD Branched to a new discussion.
lona25 Level 1 Level 1 (0 points)

I took my iPhone to a shop to unlock it from my mobile provider (no coverage in my new house and still 18-months left on my contract without option to cancel!). They installed Cydia, which I later found-out is a jailbreak software. Once I found the app and read about what it was, I wanted to get rid of it. Being in a hurry, I connected to iTunes and chose to upgrade to iOS 4.3.2.


It is now stuck in recovery mode with a 1015 error every time I try to restore. I have tried:

1) re-setting,

2) connecting to a different mac and to a different windows computer and trying to restore


I took it to the Apple Store Genius Bar and they say they can't touch it with the 1015 error. Does anyone have any suggestions?

iPhone 3GS, iOS 4.3.1, 1015 error
  • whatheck Level 5 Level 5 (4,080 points)

    It sounds like the software on the iPhone was modified or jailbroke.


    Try the suggestions in this Apple article -> http://support.apple.com/kb/TS3694#error1015


    If that doesn't work you'll need to find a way to undo any previous modifications to the iPhone.



  • Lawrence Finch Level 7 Level 7 (33,370 points)

    There's no easy answer, and it may not be possible. But you can try the C**** approach to downgrade it to an earlier version, then try upgrading with iTunes. The problem is the latest jailbreak gets the baseband version out of sync with the iOS version. This is detected as a version mismatch and prevents the update from completing. You may be able to update to a future version.

  • deggie Level 9 Level 9 (51,715 points)

    Most likely the shop you went to used tinyUmbrella in setting up your iPhone. Use Google and do a search for Error 1015 and you will find a solution to Restore your iPhone. Just keep in mind it will be relocked to your original cell phone provider.

  • Lawrence Finch Level 7 Level 7 (33,370 points)

    If the shop used tinyumbrella on their compute it should not have affected the OP's computer. It is the computer that tinyumbrella corrupts, not the phone.

  • deggie Level 9 Level 9 (51,715 points)

    True, but we don't know what the OP has done with their computer and whether the "shop" provided a disk or information that did include TU. We also don't know if a backup of the Cydia jailbroken iPhone did not make changes during a sync that are preventing a connection with the Apple server.

  • lona25 Level 1 Level 1 (0 points)

    I don't know what the shop used, just that I had Cydia on the phone after picking it up. After being stuck in the recovery loop with the 1015 error, I searched the internet for solutions and the recommendation was to use TinyUmbrella to fix the recovery and exit the recovery loop.


    I'm afraid that I did download and install TinyUmbrella - was this a mistake? It hasn't helped me to fix the problem - while it allows me to 'exit recovery', the phone then reverts to the recovery state as soon as it is connected by USB to the computer. I have seen that TinyUmbrella 'changes the host' but have no idea what this means or how to correct that if it has done that.


    I also tried downloading something called fixrecovery43, which says that I must be in DFU mode to fix the recovery loop. I am able to put the phone in DFU mode while disconnected, but as soon as I connect to the Mac, it just reverts to the recovery mode.


    BTW, this was the first time I connected to my Mac after this change, so there should not be any backups with the Cydia installed.

  • deggie Level 9 Level 9 (51,715 points)

    Just do the Google search and some of the results should even be YouTube videos. Pick one for whatever type of computer you have (PC or Mac) and follow along to change the host back.

  • Lawrence Finch Level 7 Level 7 (33,370 points)

    DFU mode and Recovery mde are the same thing.


    What tinyumbrella and similar programs (such as fixrecovery) do is fool the computer into thinking that Apple's validation servers are at a different IP address, either on your computer or on a Cydia server. This server then pretends to validate the installation, fooling the iPhone so it will work without real validation. They do this by inserting lines into the hosts file on your computer. This file is checked before the computer does a DNS lookup to find the IP address associated with a URL. You have to remove any such lines with a text editor. The hosts file is /etc/hosts on a Mac, or %windir%\system32\drivers\etc\hosts on Windows.

  • lona25 Level 1 Level 1 (0 points)

    From what I read on the internet and youtube etc. Recovery mode is when I see the usb calbe and the link to iTunes image on my phone, and DFU is when I hold the sleep and menu buttons at the same time for 10 secs and then just the menu button for 10 secs and the screen goes blank - or is that all nonsense?


    I found this on another thread of this site:


    ... open Tiny Umbrella go to advance and uncheck the box. Tiny umbrella changes your host file without your knowledge. Everytime you open and leave it open the host file changes, irrespective of what the host file setting in TU are set to in advance mode. When you close Tiny umbrella if that box is checked it will leave the host file change that it made when it opened. If that box under advance mode is unchecked it will put your host file back to normal.


    I used TU with the box for using Cydia unchecked - do I still need to edit the host file? If so, I'm afrid I'm a complete novice - where do I find /etc/hosts ??


    Also, will fixing this have any effect on my original problem of the recovery loop 1015 error, which was there befor installing TU?


    Sorry - found the file using Utilities - Terminal app. What do I need to edit. It has two lines that have some addresses and then gs.apple.com - do I keep those in or take them out?


    Message was edited by: lona25

  • Lawrence Finch Level 7 Level 7 (33,370 points)

    Take out the gs.apple.com lines. There should only be comment lines that begin with a "#" and a localhost and broadcasthost line, unless some other program added lines. This is what a "good" host file looks like on a Mac:



    # Host Database


    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##          localhost          broadcasthost

    ::1             localhost

    fe80::1%lo0          localhost


    However, fixing the hosts file probably will not fix your 1015 error. I'm not sure anything can fix that. But you can try restoring an older version using TU. You will have to manually download an earlier version from a site you can trust. Install that, then fix the hosts file, then try to update again. If this doesn't work there's probably no way to fix it.

  • chapi-GOD Level 1 Level 1 (0 points)

    1. Put iphone in DFU.

    2. Connect to itunes and proceed with shif+restore to iOS 4.1

    3. Wait for restore, error 1015 shows

    4. Don't touch any itunes box, goto tinyumbrella kick the phone out of recovery.

    5. Put again in DFU(do this quickly), now shift+restore to iOS 4.2



    Another Method worked for me..

      Continue steps 1,2,3

    4. Just when error 1015 pops open on itunes and the iphone is restarting,

       continue holding the power button for a long time and you can see iphone rebooting, and back to normal.



    Another method suggested by one user in one of the forum(haven't tried yet)(got successful with the first two many times)

    continue steps 1,2,3

    4. Without closing itunes or confirming the error, open task manager and kill itunes.exe process

    5. Again open itunes and shift+restore to the same version you used in step 2.