Previous 1 6 7 8 9 10 Next 179 Replies Latest reply: Nov 23, 2015 4:22 PM by kimina008 Go to original post Branched to a new discussion.
  • D.R.C. Level 1 (145 points)

    I get the Error 139 message on an ATV2 only when trying to watch House of Cards (the new Netflix-produced series).  The ATV2 handles other Netflix titles with no problem.  It displays iTunes movies and TV shows. It will display photos in Photostream.   But if I try to watch any of the episodes of House of Cards, the Error 139 message appears every time (immediately after clicking Play).


    The ATV2 has the latest firmware. I've tried restarting it. I've power-cycled it. I've tried the other suggestions in the Netflix FAQ on Error 139  (log out from Netflix account and log back, etc).


    It's incredibly ironic that the Netflix app in the ATV2 is allergic to the Netflix-produced show, and only that show.

  • Sam Katz1 Level 2 (195 points)

    Have you tried caling Netflix technical support?


    Might Netflix have a device limit you are hitting up against?


    As a last resort, have you tried restoring the apple tv?


    I find that that helps resolve many issues.

  • D.R.C. Level 1 (145 points)

    Yes, I've contacted Netflix tech support. They had no clue, but are 'looking into it'.


    I can't imagine how a device limit would apply. My ATV2 can watch other titles on Netflix (I've tried dozens - they all play just fine).  It's only the House of Cards series that generates the error.


    I have not tried restoring the ATV (thanks for that idea).  It's my understanding that requires a special cable.  Perhaps a trip to a Genius Bar is called for. 

  • Sam Katz1 Level 2 (195 points)

    You shouldn't need a micro-USB cable.


    "On Apple TV, choose Settings > General > Reset, and then click Restore.

    Your Apple TV will restore to its factory settings, and will also download and install the latest Apple TV software update. This process may take some time. Do not disconnect your Apple TV's power cable during the restore process."

    Make sure you have all login information for Netflix, Hulu Plus, and apple itunes.

    I am also curious.

    Did you purchase your Netflix subscription through iTunes or from Netflix?


  • D.R.C. Level 1 (145 points)


    Netflix subscription was purchased direct fm Netflix (long before Apple started selling it via ITMS).


    Thanks for the pointer to the restore procedure. Me bad.  I mistakenly thought one had to connect the ATV to a Mac to do a Factory Restore (as one does with an iPhone and/or iPod). 


    Before trying the restore, I think I'll give Netflix a couple of days so they can look into the problem and possibly figure out what it is about the HoC episodes that is different than other shows/movies. I find it extremely odd that only that one title (all episodes) causes the error.

  • gharleyjr Level 1 (0 points)

    FYI... since this thread helped me.  I have my ATV3 hard-wired with 12ft ethernet cable cat-6 directly to the router. I had to reserve the IP address on the router for ATV3 and then maunally configure the connection on ATV3. I'm 3 full Netflix movies down with no hiccups or stutters and its storming out. Hope it stays working!


    I'm going to have a fit with Apple if it hiccups again. My wife immediately goes to iTunes when Neflix doesn't work which pulls from my bank account -- lol.  Makes you wonder since iTunes works fine Wi-Fi or Ethernet with Dynamic IP vs. Netflix...


    Anyway hope this helps some.

  • Sam Katz1 Level 2 (195 points)

    You misunderstand some principles of networking here.


    I hope you won't take offense if I clear a few things up.


    First of all, reserving an IP address in the DHCP table, and configuring an iP address manually are two different things.


    I have never seen a case where reserving an IP address in the table did not work, except in a very old router that didn't work properly when reserving addresses. (this is not an atypical way for routers to fail or become flaky.)


    If you reserved it in the DHCP table in the router, configuring it manually was completely unnecessary but harmless.


    The device asks the router, "IP address please." and it always sends back the same one. Normally it's good to reserve the one it's already using in the table but it doesn't really matter.


    Anything outside the router's range of IP addresses it distributes can be assigned by you manually on each device but that gets really tricky.


    In fact, what may have happened here is what's called an IP address conflict, where either another router is giving out IPs, or a device is configured manually for an IP address in another router's range.


    I would recommend switching the apple tv back to dhcp. I think you'll find that it stays fixed, and is a cleaner over all setup.


    As for the ethernet cable, if that bothers you you can use either powerline networking or MoCA adaptors but I haven't tested either, but I bought a book on cord cutting by GigaOM and it recommended it.


    Also, test latency.


    edit: if you have it configured manually and reserved, that is an ip address conflict. do one or the other.

  • D.R.C. Level 1 (145 points)


    Could you clarify what's happening with your setup. You seemed to indicate that accessing content on the iTunes Store "works fine" when your ATV is configured via DHCP, but Netflix is unreliable.  However, when you configured the ATV network settings manually, Netflix then worked properly.    Is that an accurate summary of what you've observed?


    The root cause may be an issue with DNS.  When you configured the ATV manually, what did you use for the DNS server?  Some people recommend the Google DNS servers ( and when configuring the DNS fields in the ATV. Others prefer the Level3 servers ( and, or OpenDNS (  &   Note that when your ATV is configured in 'Auto' mode (i.e. to use DHCP), it obtains not only its IP address (and subnet) from your local router, but also the IP address to use for DNS. Many consumer routers will provide their own address as the DNS resolver (something like or as part of the DHCP datafill.  The router in turn then uses your ISP's DNS resolver to actually translate from URLs to IPs.   As a result, if the resolver firmware in the router is buggy, or if the ISP's resolver is having a bad day, problems with Netflix may ensue.  It's been suggested that some ISPs are deliberately mucking around with DNS resolution to the Netflix servers, since they (the cableco ISPs) may have a vested interest in selling their own hi-priced packages of TV channels.


    One troubleshooting step you could try: configure the ATV to use DHCP to get its IP address, but manually specify a DNS resolver (at Settings/General/Network/Ethernet/Configure DNS).  Actually, you should enter a pair of DNS addresses: primary and secondary.   These will override the DNS address proposed by your router.  If your problems with Netflix then vanish, you'll know that the root cause was a DNS issue.


    There are lots of DNS resolvers available on the internet, and some are better than others. If you have a Windows PC, there's a handy DNS benchmarking tool available at grc dot com that will indicate the fastest and more robust resolvers in your area.

  • Sam Katz1 Level 2 (195 points)

    This DNS suggestion is excellent. If it is a DNS issue, it is more likely either a bug in the router's DNS caching (Linksys 130N and 160N both have this), or that your DNS doesn't corrrectly give the netflix server knowledge of your location so that it can speed up streaming/some other issue involving your ISP and Netflix (such as a content delivery network error.)


    If this does happen, or if you get security certificate errors for sites you are not on when browsing the web, you should replace your router.

  • RA-ID Level 1 (0 points)

    gharleyjrI'm wondering if this will work for me.  How did you do this? 

  • torontolori Level 1 (0 points)

    I now have this same issue on every title. First it was just one movie... then House of Cards after we had already watched it once. Now it is everything. Netflix has tried to help. Next I will call Apple. I am not techie enough to start changing DNS and things... any easy solutions to this?

  • D.R.C. Level 1 (145 points)


    Same thing here. At first, I'd get the Error 139 only on House of Cards. Now it happens with every movie title. I opened a trouble ticket at Netflix, but got no response from them.


    Are you in Toronto?  I'm in Ottawa. I wonder if the issue is limited to Canadian customers only.


    It's not hard to change the DNS settings. Go to the ATV home page.

    Click Settings, then General, then Network, then Ethernet.

    That takes you to the Ethernet Configuration page. There are two sections: Configure IP, and Configure DNS.

    You want the latter - if you have a standard out-of-box setup, it will be set to Auto.

    Select Configure DNS, and change from Automatic to Manual.

    In the screen that appears, enter   (that's the IP address of a DNS server managed by Google).


    If you don't happen to like Google, try (that's the DNS server for Level 3, a major network supplier in the US).

  • torontolori Level 1 (0 points)

    @D.R.C - I am in Toronto. I stayed on the phone with Netflix and they tried everything. I am guessing the DNS thing didn't work for you? I won't bother then. I am going to call Apple tomorrow and will post what they suggest.

    Really ***** if they can't fix it. I don't want to just have to pay per show or movie on iTunes!

  • Gordito4u Level 1 (20 points)

    So I finally figured out my issue.


    It seems like Netflix on the AppleTV is like a canary in a coalmine.  Due to very small amounts of caching memory on the appletv, when it experiences issues there is typically an underlying network issue.  In my case it was a bad switch that caused the issue. 


    I think tweeking things like DNS settings and IP settings helps in very slim cases where that is just masking a bigger networking issue.


    If you have a complicated network try and rule out complexity to see if that helps alleviate the issue.

  • D.R.C. Level 1 (145 points)


    If my problem were caused by a network issue, I would expect it to manifest uniformly on all Netflix titles. But that's not what I've experienced.   I first started getting Error 139 ONLY on House of Cards (every episode), but not on any other titles.  The problem has now expanded to affect ALL Netflix movie titles, but not TV shows.  I've watched 3 hours of Netflix TV titles tonight without a single hiccup. If there were a flaky switch or other defect on my LAN, I'd expect to encounter the errors regardless of what titles I happened to be watching.


    Video content from iTunes Store streams with no problems.  Occasionally, I've seen a brief stall due to temporary network congestion, but never Error 139.


    I may borrow a Roku box and see if it exhibits the same problem.

Previous 1 6 7 8 9 10 Next