Previous 1 8 9 10 11 12 Next 177 Replies Latest reply: May 1, 2015 5:45 PM by kazinbc Go to original post Branched to a new discussion.
  • D.R.C. Level 1 Level 1 (145 points)

    @mmarkust,

    You mentioned that after getting Comcast's router (which is actually a combined gateway: a cable modem + router + WiFi Access Point), you tried to use your old router.  To do so effectively, you have to do more than just disable the wireless on the Comcast unit.  I'm in the same boat with my ISP (Rogers), who recently forced me to 'upgrade' to their Cisco gateway.  I've been able to revert back to using my own router by putting the Cisco gateway in "bridge mode". This is generally a standard feature on most consumer gateway products (although Comcast may prevent you from enabling it).

     

    Bridge mode not only disables the WiFi function in the Comcast gateway, but also turns off its routing function and DHCP.  Your own router takes over: it requests a public address from Comcast's DHCP server, it functions as the DHCP server for your LAN (just as it did when you had a plain old cable modem), it handles routing and NAT, WiFi, port forwarding, etc etc.  Essentially, when in bridge mode the Comcast gateway reverts to being a cable modem, and 'bridges' the IP traffic between the WAN and your own router.

     

    I've configured my Rogers gateway (a Cisco DPC3825) in bridge mode, and my Netgear/Tomato router works just fine behind it. Throughput is much faster, and the WiFi is more reliable.

     

    FWIW, my network uses OpenDNS for DNS resolution, and I've had no problems with the Netflix app on my ATV2. It's hardwired to the Netgear router (no WiFi), and uses DHCP to obtain its IP address from the Netgear.

     

    I don't want to hijack this thread away from the topic of buggy Netflix streaming. There are lots of discussion articles and info on setting up bridge mode here and elsewhere on the interweb. Just ask Ms. Google...

  • classiclabs Level 1 Level 1 (0 points)

    This did nothing for me.

     

    This is a Netflix issue. Everything else on ATV works great, all the time. Netflix is the only service having an issue.

  • classiclabs Level 1 Level 1 (0 points)

    Did this, and it does not work.

     

    hjno72, take your arogance and misinformation somewhere else. We are trying to solve an issue here or at least get some clear information out about what is happening.

     

    First thing to note it that ATV is not made so haphazardly that it requies the end user to perfom drastic steps such as assigning a static IP and reserving that IP on your router. Apple's own setup instructions say NOTHING about this as a default setup either.

     

    Also, for those thinking that Google's DNS or OpenDNS are going to solve this, Apple's setup instructions clearly state "You should use the default DNS entry supplied by your ISP, on both your Apple TV and router". See here... http://support.apple.com/kb/ts3623 . For the record, I have tried setting DNS to Google or OpenDNS and it did nothing to fix the netflix issue.

     

    As I stated before, this is NOT an ATV issue, it's a Netflix issue. Netflix is the ONLY service having a slow streaming issue. Here is a clear summary to describe what is going on...

     

    ATV rented/purchased movies/shows - GREAT

    Airplay - GREAT

    Hulu - GREAT

    PBS - GREAT

    Crackle - GREAT

    Everything else on ATV etc.. etc.. etc.. - GREAT

    Netflix - POOR

     

    If you watch the netflix "Example Short 23.976" (search for this on Netflix), you'll see the bitrate for the Netflix stream and resolution info. If you are having the same issue as me and others here, you'll see the bitrate drop down to 512, 300 or even 235 kbps while watching this on your ATV. If you watch "Example Short 23.976" on your iPad or iPhone, you'll see the bitrate increase dramatically (to where it should be).

     

    This is a Netflix issue specific to ATV.

  • iRonManNCSU Level 1 Level 1 (0 points)

    It is a Netflix on AppleTV issue (since netflix works on other devices in the same network).

     

    Since Apple is responsible for the Netflix client for AppleTV, this is an Apple problem.

     

    Apple's recommended settings are irrelevant if there is a bug in their software.

  • classiclabs Level 1 Level 1 (0 points)

    @D.R.C.

    Thanks for the good info. I am on Comcast with the same situation as you (they forced me to upgrade to a new modem) and I can verify that they do allow their modem to be set as a standard EMTA cable modem. You just have to call tech support and have them do this for you.

     

    So for anyone who needs to do this, just call Comcast, ask for tech support and tell them to turn off the wireless and routing functionality on your modem. You can also mention that you want it to be set as a standard EMTA cable modem.

     

    Ok, back to the Netflix issue...

  • classiclabs Level 1 Level 1 (0 points)

    @iRonManNCSU

    I had the understanding that the 3rd party services on ATV (e.g. Netflix) run like apps on ATV. So Netflix would be responsible for any bugs for their app on ATV, not Apple. I can't see why Apple would be taking on the responsibility for bugs in the 3rd party services that run on ATV. Pleas explain/correct me if I'm wrong here.

     

    I also agree that this is a "Netflix on AppleTV" issue, but I think it's a Netflix issue not ATV, but again, feel free to explain/correct me on this.

     

    Also, if you are aware of a known bug in the ATV software that is causing the Netflix issue, please post a link to the bug report. I have searched and found nothing so far.

     

    Here is another thread with a lot more good information...

     

    https://discussions.apple.com/thread/5582751?start=15&tstart=0

  • iRonManNCSU Level 1 Level 1 (0 points)

    I'm not sure who makes the app, but considering there's no open SDK for AppleTV, and the AppleTV is sold as an appliance (ie. the user doesn't choose to install netflix), regardless of who "makes" the netflix app, Apple is responsible for it.

     

    I have already submitted a bug report, and Apple has a pre-existing bug report for this issue (it's posted earlier in this thread).

     

    I assume they are working on a fix, but in the meanwhile, i'm managing the issue by the static IP + stream from iOS device workaround.

  • Sam Katz1 Level 2 Level 2 (190 points)

    Let me explain something to you.

     

    Every router treats DHCP slightly differently.

     

    I've seen some by some off-brand names and by another enterprise deployed one whose name I can't remember who don't seem to respect IP reservations the way I would expect them to.

     

    Similarly, I've seen some older Netgears with other weirdnesses with VoIP devices, which is a type of streaming (audio).

     

    Apple cannot test the apple tv with every configuration, and neither can Netflix.

     

    What I would encourage you to do if you want this fixed is to post your router make/model, your ISP, does it only happen in HD, because you know that sometimes rarely happens to me too.

     

    But most of the time, my Netflix works great.

     

    In terms of reserving IP addresses, actually the previous poster was slightly wrong in his instructions.

     

    You  reserve IP addresses in the DHCP range, so if it's 50-100, you reserve the IP that the apple tv currently has when it's functioning. you don't specify it on the device itself, unless you're specifying outside the range, which is not good practice.

     

    In general, I would say replace the router as a first step... as someone mentioned, you can test this by going over to someone else's house.

     

    I don't think this is a bug, but I could be wrong. It may also not be in the software, but in the CDNs. Keep in mind the CDNs change when you change DNS. You may want to ask your ISP if they have alternative DNSes if the primary ones don't work for you, but in general, you may experience worse performance using DNSes that aren't local to you.

     

    There's a way to find out which DNSes are best. You can use any DNS, it's an open protocol.

  • hjno72 Level 1 Level 1 (0 points)

    classiclabs, I am willing to accept that my solution will not work for all

    It was certainly not arrogance.

     

    Consider the following setup I have:

    4meg adsl line

    Netgear router

    South Africa

    2 ATVs streaming netflix

     

    Fixed ip addresses solve my buffer issue on ATV2 but on 3 it is not required.

  • bodosom Level 1 Level 1 (5 points)

    hjno72 wrote:

     

    Consider the following setup I have:

    4meg adsl line

    Netgear router

    South Africa

    Since you can't get superHD (and you're not in the US) much of the "recent" problem doesn't apply to you.

  • bodosom Level 1 Level 1 (5 points)

    Sam Katz1 wrote:

     

    Let me explain something to you.

     

    This "sounds" a bit condescending.  I'm just sayin'.

     

     

     

    Sam Katz1 wrote:

     

     

    In terms of reserving IP addresses, actually the previous poster was slightly wrong in his instructions.

     

    You  reserve IP addresses in the DHCP range, so if it's 50-100, you reserve the IP that the apple tv currently has when it's functioning. you don't specify it on the device itself, unless you're specifying outside the range, which is not good practice.

     

    In general, I would say replace the router as a first step... as someone mentioned, you can test this by going over to someone else's house.

    This is nonsense.  Really.  Even for someone with a simple consumer "router" this is nonsense and for people with more complex configurations it's wrong.

     

     

     

     

    Sam Katz1 wrote:

    Keep in mind the CDNs change when you change DNS.

    More nonsense -- unless of course you change from a broken DNS to a functioning one.  The Netflix system is much smarter than you're suggesting.  Your IP based geo information is a hint at best.

  • trademarked Level 1 Level 1 (0 points)

    Just chiming in to confirm that I'm just one more person that has the same issue with ONLY netflix.  Plays great through airplay to the apple tv, but poor quality when playing from the ATV3 itself.  Very frustrating but I take some comfort in knowing I'm not alone and that I wasn't going crazy for the past 3 months. 

  • bebaps Level 1 Level 1 (0 points)

    Same thing here. Seems a bit of people havin the issue within the last week or so. Follow these steps from the Netflix support website, I got mine running again perfectly in less than 5 minutes.

     

    https://support.netflix.com/en/node/276

     

    Remember folks, just because you use something regularly doesnt mean you have any idea how it actually works. Always start at the source!

  • Andrew Grimes Level 1 Level 1 (0 points)

    I've been having the same problem with HBO Go on Apple TV2. Also persistent on Netflix.

  • trademarked Level 1 Level 1 (0 points)

    Bebaps, your instructions just show how to update the software.  Most of us are already upgraded to the lastest software because the apple tv asks us to upgrade when new software is available.