Previous 1 2 3 4 5 6 Next 177 Replies Latest reply: May 1, 2015 5:45 PM by kazinbc Go to original post Branched to a new discussion.
  • superdiver Level 1 Level 1 (0 points)

    I have had the same issue.  I have reset and resotered and rebooted all modems and wireless routers MULTIPLE TIMES.  I have spent litterally MANY HOURS on the phone with Netflix and Apple.  I can watch netflix on all other devices on my wireless sytem in my house, but on apple tv I get the check back later error (139) everytime I try to play a netflix movie.  I can play iTunes and serch on Netflix, but for over a month now I cant watch a netflix movie on Apple tv.


    They are happy to take my money, and would shut off my service in a heartbeat if I screwed them and didnt pay, but they can keep charging me and contiue to screw me by not fixing a promised service!

  • OzziesMAC Level 2 Level 2 (150 points)

    This has been an ongoing issue since DAY 1 of my new AppleTV 2 box.  Netflix blames Apple, Apple blames Netflix, and customers suffer as usual.  I have totally stop using the Netflix feature from my AppleTV since it has not been reliable and have been using my Blu-ray Players built in Netflix which has been operating perfectly.


    I do like my AppleTV for it's other features that have so far worked, except for the occasional pull the power plug to reset, (due to no off switch in the front) it has worked fine.  I do not expect Apple to fix this issue anytime soon, and I do beleive it is an Apple issue and not a Netflix from the hours I have spent on it as well.  From what I have seen if things go this far a long without a fix it is becuase Apple has shelved the issue.  Similar to clearing old email cached addresses from the iPhone, an issue that has been shelved as well.


    If you want a reliable Netflix look else where such as Smart TV's, PS3, or those that are built into DVD & Blu-ray players.  For the most part those work with Netflix with no issues.  If you want to continue to use your AppleTV for Netflix, then expect to pull the plug on it for a reboot often, and if that does not work then file a complaint or an RTA with Apple.


    Our hands are tied with this issue that has been posted here and on previous threads that have mysteriously been closed.


    Just my 2 cents from what I have seen with this issue.

  • Satchmo Level 4 Level 4 (1,245 points)

    With rare exception, Netflix has streamed flawlessly on my ATV in the 14 months I've had it. I've watched hundreds of movies.

  • OzziesMAC Level 2 Level 2 (150 points)

    Why good for you!!!


    Glad it works for some of us.

  • Satchmo Level 4 Level 4 (1,245 points)

    Hence the problem might lie not with Apple or Netflix. Perhaps it is an issue with ATV or router placement, or with the service provider. Testing today at, I find that my Comcast download speed (from Indianapolis to Chicago) is 24.7 Mbps.


    It is important to try to rule out/rule in possible causes. For instance, does Netflix have more problems in certain parts of the country? Are there certain batches of ATV prone to problems. I don't know but I doubt both. It is certainly more likely that slower net connections will yield more streaming problems. Interference with a router is a potential problem. We have to ask how it can be Apple's or Netflix's problem if it works fine for many people, which I assume it does.


    OzziesMAC, how fast does estimate your download speed to be? Are you more prone to experience problems at certain predictable times of day? Have you checked your router to make sure it has no conflicts with other routers in range, and/or changed to a different channel? Are you in a high-congestion urban area, or somewhere else?

  • OzziesMAC Level 2 Level 2 (150 points)

    The nearest city to me from is Atlanta.

    Download Speed 48.45 Mbps.


    When Apple chokes up on Netflix my PS3 plays with no issue as well as my Blu-Ray Player with Netflix

    plays with no issue.  If it was download speed at the time of the problem the other would choke up as


  • Satchmo Level 4 Level 4 (1,245 points)

    OzziesMAC wrote:


    If it was download speed at the time of the problem the other would choke up as



    Agreed. I admit I haven't read this whole thread. You have swapped all of your cables? You use Airport Extreme? You have factory reset ATV?

  • OzziesMAC Level 2 Level 2 (150 points)

    Yes, Yes, and Yes.


    The cables used on the AppleTV are simply swapped over to the PS3 and they work just fine.

    ATV has been reset to factory several times since I got it, and it is directly connected to an Airport Extreme(NO WI FI).  The error 139 that lots of others are reporting has  happend to me 3 out of 10 time when I try to stream from netflix, no other issues with the ATV other than the netflix issue that has been reported numerous of times by others as well.


    Sometimes you don't get the error code 139 but try again later.  Unplug power and replug it in usually fixes that error which would be nice if you could do that with a button in the front since I had to do it so often. 

  • Satchmo Level 4 Level 4 (1,245 points)

    Very frustrating. Have you tried it with a different router?

  • iiisis Level 1 Level 1 (0 points)

    Hey OzziesMAC,


    Have you tried going into the network settings on your ATV (found under "Settings" > "General" > "Network") to configure the DNS address to match the DNS address(es) that are set by default on your Airport Extreme depending on your ISP?  I did this a couple of months ago, and so far (fingers crossed) my ATV has been causing me a lot less headaches when streaming from Netflix.


    First, go to the Airport Utility app on your Mac, and go to "Manual Setup" > "Internet" > "TCP/IP".  Write down the DNS Server(s) address(es) that appear as grayed out in the appropriate field(s); then, from the main menu on your ATV go to "Settings" > "General" > "Network" > "Configure TCP/IP" > "Configure TCP/IP MANUALLY" > "IP Address [select/scroll right to] DONE" > "Subnet Mask [select/scroll right to] DONE" > "Router Address [select/scroll right to] DONE" > "DNS Address;"enter the DNS address that is assigned to your Airport Extreme by default by your ISP; select "Done" and "Done" again. 


    In a separate but related thread, someone mentioned that they had luck by changing the DNS Address to one of Google's DNS servers.  I tried this with no success.  Being as desperate as I was, I thought that I might as well try changing the DNS server address to the one assigned by default by my ISP.  So far so good, but who knows... My experience with the ATV has proven it to be perhaps the flukiest device Apple has ever produced (to put it lightly). I don't expect any miracle fixes to hold.

  • OzziesMAC Level 2 Level 2 (150 points)

    Thanks iiisis


    I did try this but with a Google DNS will try it with my assigned DNS next time I get a chance.

    Thanks for your instructions, I will be refering myself to it!


    I second your opinion on your ATV expierience.

  • superdiver Level 1 Level 1 (0 points)

    Well, after tens of hours on the phone with apple and netflix, and replacing all my equipment and about of 4 weeks of no netflix My ISP finally came thru!  They had the best customer service!  They sent ppl to replace my equipment, they finally had a design engineer call from out east after hours Alaska time and he logged on and made some changes and it took all of 2 minutes and he had netflix up and running!

  • Satchmo Level 4 Level 4 (1,245 points)

    So, what did the ISP change? Your experience confirms my suspicion that most streaming problems have nothing to do with Apple or Netflix.

  • OzziesMAC Level 2 Level 2 (150 points)

    You may be half right their Satchmo but it my opinion it is clearly on the Apple side with this issue.  Despite his ISP making a change, this change is only needed for the ATV to work properly and not needed for other Netflix streaming devices to work.  So if a special adjustment is needed just for the ATV to work then something is not right.


    I wish he superdiver could elaborate on what this change was, since saying a change was made and it now works does not really help anyone.  I also think a wait and see attitude would be in order as well to make sure that this change did in fact fix the issue.  I can get mine to work for a few movies before it goes back into error mode for Netflix.


    iiisis fix to me appears to be the most promising since it is actually dealing with settings to the IP address.  I am guessing that this is in fact what is the root cause of the issue. What puzzles me is that I am able to stream Vimeo, YouTube, Apple Trailers as well as the stuff on my Home Sharing computer to the ATV with ZERO issues while the error is occuring during Netflix play.

  • Satchmo Level 4 Level 4 (1,245 points)

    It would interesting if you took your ATV to the home of someone who has one working successfully with Netflix to replace his with yours, and see if it works. Technology can be an incredible frustration.


    Since Lion arrived (or one of the various ATV, Airport Extreme, or OS upgrades since) each time I boot up my Mac I can no longer stream from iTunes to my stereo through ATV. Worked fine for almost a year before that. Now I have to switch iTunes to Computer and back to ATV to get it to stream. Not as much of an annoyance as you are experiencing, but still a pain.

Previous 1 2 3 4 5 6 Next