2 Replies Latest reply: Jun 16, 2012 5:10 AM by anep
Bucky Diamond Level 1 Level 1 (0 points)

I bought this app for my iPhone 4, why is it not compatible with iPad 1?


PC, Windows XP, 2 iPhones,iPod and iPod Nano
  • turingtest2 Level 9 Level 9 (54,365 points)

    iMovie for iOS runs on iPad2, iPhone 4 and iPod touch 4g. It is not compatible with iPad 1, possibly because iPad 1 may not be powerful enough to run it at an acceptable speed.

     

    tt2

  • anep Level 1 Level 1 (0 points)

    Its powerful enough but Apple tries to convince us to buy a new iPad. There are workarounds in the Internet but you have to do the same procedure for every update. Uninstall and reinstall.