1 2 3 4 5 6 Previous Next 199 Replies Latest reply: Mar 2, 2014 9:57 AM by rosafrombel Go to original post
  • 45. Re: iCloud and my 3G phone
    okenter Level 1 Level 1 (0 points)

    I used the settings mentioned earlier on my iPhone 3G IOS 4.2.1. The calendars were imported from iCloud but not the contacts. I also made changes both on the iPhone and the iCloud web site to check the sync. It seems like sync is not working in iCal or Address Book.

  • 46. Re: iCloud and my 3G phone
    Corradomac Level 1 Level 1 (0 points)

    Many thanks for all the information, in summary :

     

    1° Move to iCloud on a Mac

    2° Wipe your MM-acount from your iPhone

     

    Mail :

    Add Mail Account

    Name : your name

    Address : your MM addresss

    Description : whatever you want

    Incoming Mail Server

    Host Name : p99-imap.mail.me.com

    User Name : part before "@me.com" (surname.name)

    Password : your MM password

    Outgoing Mail Server

    SMTP : smtp.me.com

     

    You can find these info on your Mac in Mail - Preferences - Account.

     

    Address Book make a CardDAV account :

    Server : p01-caldav.icloud.com

    User Name : your MM address

    Password : your MM password

    Description : choose something

     

    iCal make a CalDAV account :

    Server : p01-caldav.icloud.com

    User Name : your MM address

    Password : your MM password

    Description : choose something

     

    With these settings it worked for me; many thanks to all helpers!

  • 47. Re: iCloud and my 3G phone
    rémifromgarches Level 1 Level 1 (0 points)

    Is there anyway to see pictures about the way to set icloud caldav and contacts parameters.

    I have an iphone 3G running IOS 3 and I set icloud mail without any difficulty.

     

    With Contacts and Caldav, it is an other story and I didn't succeed.

     

    I tried several time :

     

    For contacts :

    p04-contacts.icloud.com (same with p01-P02…)

    Apple Id : xxxxx (without @me.com and with)

    Password : pppppp (Apple Mobileme)

    and finally : description

    Then the iPhone answer : Impossible to connect. Do you want to go on without SSL. I change SSL by 443 by it doesn't work and put it ON.

     

    The same thing with the calendar :

    p04-caldav.icloud.com (same with p01-P02…)

     

    I probably did something wrong, but I did not find out the point. Does your iphone

     

    photo.jpgphoto1.jpg

  • 48. Re: iCloud and my 3G phone
    mac13k Level 1 Level 1 (0 points)

    I tried several times to follow the methods here but couldn't get the contacts and calendar to synch. I would manage to set up the accounts but no contacts or calendar items would sync. I managed to finally do it by discovering a new method.

     

    Here are the steps to get the iPhone 3g to sync calendar and contacts with iCloud.

     

    1. Set up the CardDav and CalDav accounts by going to settings and choosing new account/other

    like described above:

     

    Address Book make a CardDAV account :

    Server : contacts.icloud.com

    User Name : MM address

    Password : MM password

    Description : choose something

     

    iCal make a CalDAV account :

    Server : caldav.icloud.com

    User Name : MM address

    Password : MM password

    Description : choose something

     

     

    Now, if you are in the same situation as me, your iPhone 3G will not sync any contacts or calendar items. but you might notice that iPhone had changed the server address to p02-contacts.icloud.com or something like that. That's good because that means that there is something on the other side of the net.

     

    To finally make the phone sync you need to go to the CardDav settings --> click advanced --> click on the extended server address bar (starts with https:// and ends with /principal) --> select all --> copy it --> go back to the previous settings window (the one with your login info and server address bar) --> paste the extended server address to the server address box and click Done.

     

    You should be ready to go. Repeat the same for calendar settings.

     

    It worked for me after hours of fruitless fiddling with the settings.

  • 49. Re: iCloud and my 3G phone
    rémifromgarches Level 1 Level 1 (0 points)

    Could you add pictures ?

  • 50. Re: iCloud and my 3G phone
    mac13k Level 1 Level 1 (0 points)

    Posted once already but the post got deleted (strange).

     

    Here is how after hours of fiddling I managed to get my iPhone 3G sync with iCloud calendars and address book.

     

    For calendar sync.

     

    1. Go to Settings/Mail, Contacts, Calendars/Add Account.../other/CalDav

    2. Type the following settings:

    Server: caldav.icloud.com

    User Name: your @me.com address

    Password: your MM password

    Description: Contacts iCloud

     

    3. press Done and wait. The verification can take some time. After that you will have a new CalDav account. If you are lucky it will sync and you are home. If you are like me it will not sync. We need to make one adjustment.

     

    4. Go to your new CaldDav account settings. You may notice that the server name has been changed to p02-caldav.icloud.com or something like that (p01, p03 etc.). That's good. We want that.

    5. Now tap on "Advanced Settings" and copy the Account URL (all of it: from https:// ... to principal).

    6. go back to your CalDav account click on Server. Delete the current address ("p0x-caldav.icloud.com") and paste the address you copied from advanced settings. Hit Done and wait for verification. Now it should sync.

     

    Fllow the same procedure for contacts with one difference - in step 2 you type contacts.icloud.com as server address.

     

    Hope it works for you. It worked for me and I verified that the accounts sync both ways. Good luck.

     

    Message was edited by: mac13k The previous post reappeared. Sorry for double posting.

  • 51. Re: iCloud and my 3G phone
    rémifromgarches Level 1 Level 1 (0 points)

    I don't understand it doesn't work.

     

    Could you just let me know exactly what parameters you have ?

     

    My parameters are :

     

    Server : p04-caldav.icloud.com    (where 4 seams to be the rigth value, In find it in iTunes when i tried to sync calendar)

    User name : <MobileMe Account> @me.com

    password : xxxxx

    Description : any

     

    then in Advance Setup :

    SSL is ON

    Port : 443

    URL address : https://p04-caldav.icloud.com:443/principals/users/<MobileMe Account>%40me.com

     

    Can you please do the same for Contacts ?

     

    Thank you for your help

  • 52. Re: iCloud and my 3G phone
    Allan Eckert Level 8 Level 8 (41,525 points)

    Generally posts are deleted because they violate the TOU. If they are speculation, talking about something that is illegal or impolite those or the most typical reasons for deleteion.

     

    Allan

  • 53. Re: iCloud and my 3G phone
    mac13k Level 1 Level 1 (0 points)

    Allan,

     

    My post had non of these as you can see. I've noticed though that there is a delay between posting and when the entry is actually visible. I thought that it has been deleted, but it reappeared.

  • 54. Re: iCloud and my 3G phone
    mac13k Level 1 Level 1 (0 points)

    rémifromgarches

     

    Just copy the address from advanced settings and paste it to the server address box. Hit Done. It worked for me.

  • 55. Re: iCloud and my 3G phone
    okenter Level 1 Level 1 (0 points)

    mac13k, You are great! Your solution worked perfectly for me regarding the iCal and Address Book. Are you having any problems with Mail? I have tried every comination of settings that I've seen posted and none of them have worked for me. I have also tried the settings in Apple's support document #HT4864. They do not work. Do yu have any suggestions to get iCloud Mail working on the iPhone 3G?

     

    Thank You!

  • 56. Re: iCloud and my 3G phone
    mac13k Level 1 Level 1 (0 points)

    Email was pretty straightforward. I followed instructions from one of the websites (can't remember which one). It worked right away.

     

    I did somehting like this:

    go to Settings/Mail, Contacts, Calendars/Add Account.../Other/Add Mail Account

    Fill out the four boxes:

    Name: your name

    Address: xxxxxxxxxx@me.com (your MobileMe address)

    Password: your MobileMe password

    Description: iCloud Mail

     

    Now select the IMAP account

    imap.mail.me.com

    User Name: xxxxxxxxxx (your MobileMe address but without @me.com)

    Password: your MM password

     

    SMTP

    Server: smtp.me.com

     

    It worked for me right away (with push email) so I may be a lucky one.

  • 57. Re: iCloud and my 3G phone
    rémifromgarches Level 1 Level 1 (0 points)

    Which IOS do you run on your Iphone 3G ?

    I have 3.1.3 and I tried several time following your instructions but with no success.

    I may reinstall the OS.

  • 58. Re: iCloud and my 3G phone
    mac13k Level 1 Level 1 (0 points)

    I have 4.2.1

    I can only confirm that this is the version of iOS that my solution applies to.

  • 59. Re: iCloud and my 3G phone
    David J. Downs Level 1 Level 1 (50 points)

    Got my mail working fine, and calendar sync is also running like a champ.

     

    Contacts syncing with iCloud still a no-go.  I've set it up as was done above.  I've also (1) completely deleted my MobileMe account to avoid potential conflicts, (2) tried switching the CardDav account off and back on several times, (3) turned the iPhone completely off and restarted.  No luck.

     

    I may try a hard reset later today.  Worst case scenario, I suppose I could use iTunes to sync my contacts instead of cloud syncing.  iTunes still offers that option, yes?

     

    Any other suggestions are welcome.

1 2 3 4 5 6 Previous Next