Previous 1 2 3 Next 44 Replies Latest reply: Apr 18, 2015 9:40 PM by AaronSchacht Go to original post
  • sansarin Level 1 (5 points)

    Try this link. It involves checking that specific permissions are set correctly on login.keychain file.

    http://blog.davidohara.net/2007/12/19/os-x-keychain-not-saving-passwords/

  • ging9 Level 1 (0 points)

    First post, and hopefully a useful one...

    I had the same problem, and after reading this post I think ive cracked it.

     

    Before you start, check you have got the correct password for your email account(s).

     

    As the earlier link says, you need to open up Keychain Access, via Applications, then Utilities.

    Click Passwords (or All Items) on the left, and look for the email passwords (should start with mail.)

     

    Look for repeated entries for the same account. I have 5 email accounts, 2 of them had 3 passwords, and 1 had 2 passwords. The others had one password, and were working fine.

     

    Now, just delete the oldest of the repeated passwords, so you are left with just one for each different email account, which being the most recent, should be the correct one.

  • BDAqua Level 10 (122,202 points)

    Great post, thanks!

  • pete_schnapps Level 1 (0 points)

    Lifesaver. Seriously!!!

  • kegger Level 1 (5 points)

    dj... that's a dead link... sends me to Apple's main page

  • Laurie Hoffman Level 1 (0 points)

    Thanks a million for this, guys.

    Besides the keychain accounts beginning with "mail", also fix the ones beginning with "smtp" as I had about 6 old ones to delete.

     

    Cheers

  • david125 Level 1 (0 points)

    ging9 wrote:

     

    First post, and hopefully a useful one...

    I had the same problem, and after reading this post I think ive cracked it.

     

    Before you start, check you have got the correct password for your email account(s).

     

    As the earlier link says, you need to open up Keychain Access, via Applications, then Utilities.

    Click Passwords (or All Items) on the left, and look for the email passwords (should start with mail.)

     

    Look for repeated entries for the same account. I have 5 email accounts, 2 of them had 3 passwords, and 1 had 2 passwords. The others had one password, and were working fine.

     

    Now, just delete the oldest of the repeated passwords, so you are left with just one for each different email account, which being the most recent, should be the correct one.

    Seems to have worked for me so far.  Had several duplicated keychain entries.  Thank you very much.

  • deanooh Level 1 (0 points)

    thank you so much   it works

  • mmthatsme Level 1 (0 points)

    Thank you SO much!!!  It worked! 

  • Blinger Level 1 (0 points)

    Thanks, ging9... perfect solution!

  • STEFCOOK Level 1 (0 points)

    I am sorry to everyone for this but after doing what the post of ping9 suggested I still get asked for the password.

     

    It's a Yahoo mail account and I am seriously thinking of deleting it completely.

     

    I have 4 more gmail accounts in the Mac Mail app and none asks for password.

     

    Seriously can apple get on top of this?

  • david125 Level 1 (0 points)

    I don't think it is intrinsically an Apple issue, so I shouldn't think anything will change from their end.  I had a BT yahoo account and used to get this problem all the time.  I think the issue is that mail in Mac sets up an IMAP account and whilst the BT yahoo email will allow this to a degree, it is not fully compatible as it is natively POP3.  I got around this by deleting my bt yahoo mail account from mac mail and setting up an icloud email address.  This works perfectly and I\ve not had a problem since.  I have a lot of correspondence going to my bt email address though, so to get around this issue and still receive my bt mail, I simply set the bt email accoount to forward everything to my icloud account.  You could always try and set up a POP3 account through the mac mail app - I vaguely remember trying to do this but POP3 is nowhere near as good as IMAP at keeping everything synced between devices and I personally couldn't live with it.  Hope this helps.

  • STEFCOOK Level 1 (0 points)

    Thanks,

     

    I'll forward my mails to my gmail accout and move on from there.

     

    Still someone either in Apple or Yahoo needs to fix this.

  • muchaim Level 1 (0 points)

    In my case Mail asks me for the Password that is allready safed in keychains. Randomly I hafe to confirm (not to reenter) the password. This is annoying, because Mail strucks, when the Mac is unatteded.

    Any help for this problem?

  • Atom-Ant Level 1 (0 points)

    Just used this advice to solve this very frustrating problem.

    Thanks for taking the time to help us "david125", much appreciated!