7 Replies Latest reply: Aug 23, 2014 5:06 PM by Mike Lipay
Mike Lipay Level 2 (225 points)

I was looking up a contact using the search feature, search didn't find it even though I know it was there (have it on my iTouch). When I deleted the search terms (backspace until empty) all of my contacts were gone. I exited the app and went back in (figuring the search may have confused the app), still all gone.


Anyone else experience this?


If I resync with iTunes will that restore everything, or will it wipe out the contacts on my Mac?

iPad 2, iOS 4.3.2
  • DrewSmith Level 1 (15 points)

    Are you a MobileMe customer? Do you sync your contacts from a PC or Mac?


    One possible solution is to restore from a backup in iTunes where your contacts exist, then 're-add' anything which is missing. It's a chore, but contacts wouldn't just disappear like that usually.


    Hope I helped.

  • Mike Lipay Level 2 (225 points)

    Thanks, I thought I might have to do a restore.


    Any idea if I can just restore the contacts, or does the restore replace everything? Never had to do this with any of my devices.

  • niraj.shethia Level 1 (0 points)

    i have not any contacts in my pc or itunes... now what i do??? i lost my contacts due to mobileme..

  • olli.vdl Level 1 (20 points)

    Lost all of my contacts dure to iCloud (beta tester)


    I had a zipped backup of ~/Library/Application Support/Address Book


    ! "~" above stands for your home folder

    ! In Lion you can go to ~/Library by pressing alt and clicking the go menu in Finder




    Restoring that one didn't work at once, even when doing this while synch of contacts was turned off in iCloud pref pane.


    I namely had all contacts in address book after restoring the backup folder, but they disappeared an instant after due to an iCloud sync.


    The remedy was


    1. switch off contacts sync in the icloud prefpane (confirm to delete all contact on the mac, didn't change anything anyway)

    2. restored the ~/Library/Application Support/Address Book/ directory from a backup

      think of a backup from previous system, Time Machine, manual backup, offline sync that's not damaged

    3. digged into this folder in another window: - watch out -

      ~/Library/Application Support/AddressBook/Sources/4A17A948-7163-44D0-896A-E4A09C1154C0/'

      "4A17A948-7163-44D0-896A-E4A09C1154C0" is any single folder you find in there

    4. moved the following files and folders (not more)


      to replace the ones in the parents folder parent folder

      ~/Library/Application Support/Address Book/

      (anything that smells of sync or offline neglect it)

    5. deleted the folder

      ~/Library/Application Support/AddressBook/Sources/

    6. turned on the contacts syncing in the iCloud Pref Pane

    7. felt like a hero

    If at all this has helped you, I can bet you are very happy, and I'd appreciate to know about it.
    your contacts are worth tremendously much, and a manual backup, or a time MAchine backup for that matter is crucial for your happiness.

  • FEFWmsbrg Level 1 (0 points)

    If you did this when synch happens on iPhone connection to iTunes like it happend to me, it is upsetting.


    I tried to restore but it di not work.  Finally I wen to my MACBook Pro and entered finder, Searched for

    Address Book  and it appeared.   I drug it to my desktop and pend it and all my addresses and telephone numbers of my contacts were there.  It is in an app.  I think I will try to shuffle it back to my iphone by seeing if I can enter the app onto the apps showing up on iTunes.  When when I sinch again it may go back to the iPhone. 

    Wish me luck!

  • Sam Zhang !! Level 1 (0 points)

    I had a similar experience in which all my contacts were lost and I have no idea what caused it. Then I followed another thread that told me to reboot the device. Then everything went back on.

  • Mike Lipay Level 2 (225 points)

    This happened again on Wednesday, I tried the reboot, restoring from backup, etc. Nothing helped except to restore to factory and reload everything. It seems that this happens right after an iOS update. I think Apple has a problem that needs addressed.