3 Replies Latest reply: Jun 10, 2011 4:37 AM by b noir
paul96 Level 1 Level 1 (0 points)

If I select to "Import using aac" and then select "custom" I am not given any further options to customise. This used to be an option where an other small page would open and give me all the various custom settings available but now nothing. If I try "import using mp3" and then select "custom" then I am given all the custom options. I have uninstalled itune and reinstalled but no change. This is really anoying as until I can sort this problem out I can not rip my cd collection as I wish to.  Any help appreciated. Thanks


iPhone 4, Windows Vista
  • b noir Level 9 Level 9 (72,015 points)

    That one can be caused by damaged iTunes preferences files. If that is what is afoot, rebuilding one set of your preferences files can get past the issue.

     

    Prior to doing the preference file rebuilds: Best to make a note of any custom preferences you have set up for your iTunes. (Rebuilding pref files returns preferences to their defaults ... so you'll likely have to set some of those custom preferences up again from scratch.) Also make a note of any third-party plugins/add-ons you have installed. You may have to reinstall those after the rebuilds.

     

    First, quit iTunes if you have it open.

     

    Next, you'll need to make sure you are set up to view hidden files and folders in Vista (or 7).

     

    1. From the Start menu, click Open.

    2. In the Organize menu, click Folder and Search Options.

    3. Click the View tab.

    4. In the "Advanced settings" pane under "Hidden files and folders" make sure that the "Show hidden files and folders" option is selected.

    5. Click OK.

     

    Next, you'll remove the iTunes preference folder (and contained file).

     

    6. In Computer, open Local Disk C:\ or whichever drive your documents are stored on.

    7. Open the Users folder.

    8. Open the folder with the name of the Vista (or 7) user account in which iTunes isn't showing the Custom AAC options.

    9. Open the AppData folder.

    10. Open the Roaming folder.

    11. Open the Apple Computer folder.

    12. Drag the iTunes folder out onto the Desktop.

     

    Now you'll rebuild the preference folder and file.

     

    13. Launch iTunes. This will cause iTunes to rebuild that preference folder and file. The iTunes Setup Assistant will run. Do not add files to your library when prompted to do so. Otherwise you'll end up with a library full of duplicates.

     

    Once iTunes has launched, check your importing preferences again. Do you get the AAC options again?

  • paul96 Level 1 Level 1 (0 points)

    Hi

    Thank you for taking the time to reply. YES, it worked and all sorted now. Just need to decide what settings to apply but thats for me to decide. 

    I think quite a few people have had this problem also. Thanks again I really appreciate your help. All the best.  Paul

  • b noir Level 9 Level 9 (72,015 points)

    You're welcome, Paul! Many thanks for reporting back about your resolution, too. (This was my first trial run with that particular modified set of instructions for this.)

     

    Kudos here to chosborne for the heads-up that we only need to rebuild the \Roaming\ set of preferences:

     

    Re: iTunes 10.2.2 Custom AAC Import not working