0 Replies Latest reply: Jun 9, 2011 1:02 PM by KoobcamUser
KoobcamUser Level 1 Level 1 (0 points)

I have had a Canon Digital Rebel XSi for a few years now and it has always worked well with my macbook and iphoto. I recently upgraded to the Macbook Pro (early 2011) and was pretty excited about being able to leave the USB cable behind.


Here's where it gets interesting:

  • When I pop the SD card out of my camera and put it into my macbook pro the SD card shows up on the desktop and in iphoto 2011, however it doesn't have anything on it except for the default folders that the camera creates. No photos.
  • I could also see that there was occupied space on the SD card, no files but used space
  • When I put my SD card back in the camera and got an error of "Cannot create folder" so I couldn't use it or see the photos anymore
  • I used a restore program to get all the photos I'd taken over the weekend trip off the card
  • Next I decided to reformat the SD card in the Canon XSi, I popped off a few pics and put the card back in the Macbook and I was able to import them
  • Cool it was fixed... well, actually I put it back in the camera after importing and "Cannot create folder" again! Again the card is useless
  • I updated the firmware on the XSi to the latest 1.1.0 version and tried it all again, but still the same results


There is a fix and it's simple enough. If I just continue to use the USB cable everything works normally. I will of course do this, but I'd love to use the new SD card slot and not corrupt my card. I'm curious if anyone else is having similar issues. I'm also concerned that when I grab photos from a friend's SD card that I'll break it, and that just aint cool.


Thanks to anyone who reads through this exciting post and offers any suggestions.

MacBook Pro, Mac OS X (10.6.7), 13" i5