Previous 1 2 Next 27 Replies Latest reply: Feb 6, 2013 1:18 AM by seventy one
Specialty-Machining Level 1 Level 1

When I attempt to empty my trash, it will not complete, but gives me an error code -8003.



Mac Mini, Mac OS X (10.6.4)
Solved by Linc Davis on Jun 13, 2011 2:02 PM Solved

That won't work. The files are in the Trash folder on his TM volume, not the one in his home folder. I don't know what the point of repairing permissions would be. A restart is unnecessary. Error -8003 is not a file-busy error; it's an ACL error. Restarting doesn't change the ACL's and neither does a permission repair.

Reply by Linc Davis on Jun 11, 2011 10:23 AM Helpful

Did you move files from a Time Machine backup to the Trash?

Reply by Linc Davis on Jun 12, 2011 9:15 AM Helpful

You destroyed your Time Machine repository. Erase the TM volume and start over. As for emptying the Trash, you need root privileges to do that. You can do it in the shell (Terminal), or with an application called "TrashIt." Please read the TM documentation which clearly states that you should never touch the repository with the Finder.

 

Trash It! updated to v4.1 – NoName ScriptWare

finder trash 8003 "time machine" - Google Search

All replies

Previous 1 2 Next