2 Replies Latest reply: Feb 5, 2013 7:59 PM by matw8
kweg150 Level 1 Level 1

Hi all,


Since a week when this particular iMac starts up, clients logging in, after building up the desktop for this client, it receives a window stating "Type an administrator's name and password to allow MCXDiskSetup' to make changes".




If the client cancel this window, he/she is able to work. It is just annoying and I like to know which settings should be changed in order to stop this window for appearing after login. Where should I look? Do I have to look in WGM, or should I open terminal? Any advice welcome.


Best regards,




NB. Running SL server (latest version), AFP, DHCP, DNS, OD, Web services, and iCal.

mac mini Intel Core 2 Duo, Mac OS X (10.6.7), Server
  • jefffromcleburne Level 1 Level 1

    Not sure if you have fixed this problem or not but I was having the same problems and here is how I fixed it.  Go to /System/Library/CoreServices/ManagedClient.app/Contents/Resources and look for MCXDiskSetup.  You can either add a .old to the end of it or delete the file.  I prefer to add the .old to the end because I dislike deleting system files.  You will have to do this on all machines you are having problems with.  I hope this helps.



  • matw8 Level 1 Level 1

    This was driving me mad for a few hours, then I found a Managed Client setting that fixed it.


    Under MEDIA ACCESS in the OTHER MEDIA tab, the box for REQUIRE AUTHENTICATION was ticked against the INTERNAL DISKS


    Once I removed this (in fact stopped managing it altogether) the annoying messages stopped.


    Hope this helps someone else in future.  Googling the message only gave me 4 results!!  Getting support for Apple related enterprise level problems is extremely frustrating.