Previous 1 2 3 4 5 Next 103 Replies Latest reply: Aug 21, 2015 5:04 AM by turingtest2 Go to original post
  • oz10k Level 1 Level 1



    I had problems with my 160GB drive. Briefly, if you restored it, it worked up to a point.  You could get a couple of gig of songs on it and all would be fine.  But if you kept going you'd hear some whirring and chirping and everything would lock-up.


    My computer is running XP SP3. 


    I could still put the iPod into disk mode.  If I opened a command prompt window and ran chkdsk it would show multiple file errors.  If I ran chkdsk /R the errors would be fixed.


    But then if you restored it and started putting music on it, it would lock-up again.


    So I decided it would be best to reform the drive.  To do that I had to discover the utility Fat32Formatter.  But when I tried it, it stated that the partition had collapsed and that the drive needed to be initialized. I tried to use the initialize feature of Fat32Formatter, but still got the message that the partition had collapsed.


    I then discovered EASEUS Partition Master, which I can strongly recommend.


    I'm happy to say that I repartitioned the drive this weekend.  So far (knock on wood) it's working fine.


    I pretty much used the Partition Master default values.  It allowed me to select 100 GB of the drive (the surface test starting failing just a bit beyond that point), specify the partition as primary and FAT32 reformat it. 


    I used the default cluster size, I believe it was 64K.  I left the partiton label blank (it was optional).  I picked the Drive letter as N.  When I was done, the iPod name was N:\, but it was easy to change.


    If you believe you need to reformat and nothing else is working for you, give Partition Master a try.



  • turingtest2 Level 9 Level 9

    Good news. At least you get a bit more useful life out of the device.



  • Corey5390 Level 1 Level 1

    Ok so I ended up on this page and ran the SMART test and these were my numbers...


    Retracts: 201

    Reallocs: 1023

    Pending sectors: 74

    Start/stops: 19029


    I ran this because my iPod is 30Gb but is only allowing me to put 2.4Gb of music on before giving me Error(-69). Any tips..? or is this the end of my 30Gb iPod being a 30Gb iPod...and instead it being a 2.4Gb iPod...

  • turingtest2 Level 9 Level 9

    Try the formatting fix from earlier in this thread. This should release the pending sectors. If the drive is stable then a full format should map out all of the bad sectors, and once done a restore should be successful. If the computer bogs down completely, or you still can't get any media on to it afterwards then I guess it's time to call it a paperweight.



  • Corey5390 Level 1 Level 1

    Ok, well if you're talking about doing the steps on the link I've already done them, countless times. The thing that annoys me about it is that it was holding 1600 songs, and then I decided to reformat and restore the darn thing so that I'd have a "new ipod", and now it cant take more than 480. On a separate note, I do not have the option to run a "HDD Scan" in the iPod diagnostics, its a 30Gb video iPod, and I'm kinda confused as to why. I may have tried to run one awhile ago but quit and am wondering if thats some of my problem. Does any of this seem plausable?

  • turingtest2 Level 9 Level 9

    Don't worry. Different models have different options. Quitting a scan wouldn't cause a problem anyway. As the drive degrades it becomes less able to read and write sectors reliably. Reallocated sectors happen when a problem sector has been detected and is then taken out of use, but if the problem is too severe then there is not much to be done. The only other possibility would be to erase the contents again and then throw in a few large dummy files, e.g. 3Gb worth, in case the problem is all around that 2.4Gb region. Adding data to the iPod involves adding a file, and updating the database, over and over again. If the database becomes located in a sticky part of the drive then everything grinds to a halt.



  • Ms.K.Hill Level 1 Level 1



    Need help. IPod Classic 120GB, makes a crackling sound. Ran the test here are my numbers:


    Retracts: 255


    Pending Sectors:269

    Poweron hours: 199

    Start/Stops: 6746

    Temp: Current 33c

    Temp: min 4c

    Temp: max 49c.


    Not sure what all this means. Powered off and got the message to restore. "Use Itunes to Restore". Well, I have no clue how to do either. Please help.



  • turingtest2 Level 9 Level 9

    Same advice as I gave Corey5390 really:


    Try the formatting fix from earlier in this thread. This should release the pending sectors. If the drive is stable then a full format should map out all of the bad sectors, and once done a restore should be successful.


    If the iPod won't restore properly, or take your media, then there really isn't much else I can suggest. Main options are replacing the drive, or purchasing a new device.



  • mattpaul Level 1 Level 1

    I had similar problem with iPod classic,it was working fine for 2 and hlaf years,and oneday when I connected it to itunes,it hung up,even my computer was not responding.On removing all content is gone,I had half the capacity full of songs,noe it says almost all of memory is used up by "other" content.I also could feel the disc spinning.Tried connecting different computer,both mac and windows,no use,my ipod is not recognised.Finally ,I was about to say RIP,just did some more googling,and found out a method for entering DISK MODE.Once in disk mode ,itunes recognised ipod and insisted for restore.I did restore,and the ipod is working fine(sure ,I lost data)

  • Nicholas_Lewis Level 1 Level 1

    Retracts: 8

    Reallocs: 3024

    Pending Sectors: 192

    PowerOn Hours: 87

    Start/Stops: 28017

    Temp: Current 31c

    Temp: Min 6c

    Temp: Max 57c


    So I have problems with my 1,5 year old Classic 160Gb...
    iPod wouldn't play some songs. It would get a few seconds into a song, then skip to a different one. After the hardreset it synced only 297 songs and I have an error message (-53, -50, -60)

  • turingtest2 Level 9 Level 9

    Try formatting the drive.



  • jtb12 Level 1 Level 1

    If it can help someone I couldn't manage to sync my ipod completely (it stopped in the middle because of bad sectors I think) and I couldn't reformat my ipod classic 80GB to FAT32 in Windows. Finally I used a live cd of GParted (Parted Magic) and I formatted the disk there. I had to try the formatting but in the end it worked.


    After that I shut my computer down, unplugged my ipod, then rebooted to Windows.

    Then I plugged my ipod in again, launched itunes, sync...and tada! The sync worked until the end.


    Good luck to all that read this, hope that helps!

  • Sheron90 Level 1 Level 1

    My 5-6 yr old ipod 5G2A 80Gb Classic just started blinking the apple logo with clicking sounds.


    tried formatting -wotks when empty returns to the above state.


    the smart data results are:


    retracts: 2357


    Pending sectors:0

    Power on hours:521



    tried disk check in windows(win 7 x64) and it shows no errors, also can sucessfully use disk mode


    any help would be appreciated

  •  EumarZephyr Level 1 Level 1

    Im having the same problem with my 160gb ipod classic, it crashes at random song while sync and it gives mi several diferent unknown errors. I´ve tried to fix it using the procedures here and nothing.




    Retracts: 246

    Reallocs: 343

    Pending: 3

    PowerOn: 988

    Start/Stops: 385


    Any advice?

  • Green_M4n Level 1 Level 1

    So, I ran the test and got the following results.


    Retracts: 315

    Reallocs: 0

    Pending Sectors: 10

    PowerOn Hours: 1104

    Start/stops: 15937


    These don't seem bad to me, but I'm still experiencing problems of freezing and not reading content. I would attempt to restore it, however it cannot connnect to my Mac even when it's in Disk Mode and following the steps you've outlined in the previous post. Any way to check to see if it has a problem with the connection? When I plug it in, it says "Do not disconnect" but the computor doesn't recognize it, disk mode or not. What should I do?

Previous 1 2 3 4 5 Next