7 Replies Latest reply: Jun 23, 2011 7:42 PM by Kr@zy
zimbos_05 Level 1 Level 1 (0 points)

So im trying to connect to my home WIFI, but am having no luck what so ever. Its been working fine for the past year since i have had my phone. Last night, i came home from a night out (where the WIFI worked fine) and i tried to log on to my WIFI, but its not connecting. I have tried everything from turning the phone off and on again. Ive reset Network settings. Ive tried restarting my modem. My Mac laptop seems to be connected fine and the internet is working without any hassles. My phone just wont connect to the WIFI. It can find the WIFI network, but every time i put in the password, it keeps saying, Unable to connect to network.

 

Its really annoying me as i have tried everything i can see on the website and everywhere else.


iPhone 3GS, iOS 4.3.2
  • Carolyn Samit Level 10 Level 10 (96,910 points)
    but every time i put in the password, it keeps saying, Unable to connect to network.

    You are positive you are typing in the router or base station wi fi password, not your admin password?

  • zimbos_05 Level 1 Level 1 (0 points)

    Ive tried using both the base station password and the admin password and neither is working.

  • digitard Level 1 Level 1 (0 points)

    Have you tried resetting the password to what you think it is in the router in case someone changed it, or it has a Cap/Lowercase, etc, that you weren't aware of?

     

    What type of encryption are you using?  If you're using WEP have you tried WPA2 (if supported by your router)?  I've found that in my personal experience using a WPA2 encryption type solves most password issues since it can use a standard passcode over a HEX key.

  • Kr@zy Level 1 Level 1 (0 points)

    I had no problems for over a year, and then after upgrading to 4.3.2 boom I was having the same problems of being unable to connect to wifi on the iphone at home (other devices worked fine).  I upgraded to 4.3.3 but it continued & then I thought I would try online for help!

     

    My iphone was showing it was connected in the settings page, but not in the top left of the home screen, and if I tried to update apps etc it could tell me to connect to wifi.

     

    I tried all of the solutions suggested by others here, except updating firmware because I had no idea how to do that!

     

    I have at last (fingers crossed it continues) managed to solve the problem using a combination of the suggestions here.  I will list what I did in the order I did it, just incase it helps anyone else.  (Apologies in advance Im no computer expert!!)

     

    1. Settings > WiFi > clicked on my network > Forget this network

    2. Settings > WiFi > Ask to join networks > OFF

    3. Settings > WiFi> OFF

    4. Unplugged my router for over 30 minutes I had tried spells of ten minutes etc before with no luck

    5. Switched router back on waited 5 minutes

    6. Settings > WiFi > ON

    7. Settings > WiFi > clicked on my network > enter router password

     

    As I say  I tried other things that worked for others and it didn't help me, but this worked for me & it may help someone else.

  • zimbos_05 Level 1 Level 1 (0 points)

    i guess ill try anything now.


    My WIFI started working again all of a sudden, so i thought nothing of it. I get home today after picking up my cousins from school, and bang, the WIFI is gone again.


    I can see the network,  i just cant access it. Put in the password and all.


    I dont understand why they just cant make things work.

  • tc baby Level 1 Level 1 (0 points)

    my problem seems similar, i can connect to my airport with my lap top, my itouch, but not my iphone.   i cannot join the network on my iphone because it does not even detect it.   are you still having problems?  did your fix last? 

  • Kr@zy Level 1 Level 1 (0 points)

    TC baby - mine is still working fine, so its worth giving the suggestions here a try!