3 Replies Latest reply: Apr 9, 2014 11:52 PM by LexSchellings
bottleboot Level 1 (0 points)



I have been having kernel panics since yesterday. I followed the doctor x, "Resolving Kernel Panics", ruled out some problems, repaired my disk and premissions with the disk utility and reinstalled Mac Os X.


Everything seemed fine and wroked more smoothly but now, a day later, it's back and it seems to be worse.


This is the log of my latest panic. It happened when Komodo started to hang, which I can't use now anymore without force quitting it. I also tried a reinstall.

You might think this is a Komodo problem and so not for this forum. But these panics also happen when i use other programs.



Interval Since Last Panic Report:  14313 sec

Panics Since Last Report:          1

Anonymous UUID:                    FF979E40-9803-4310-9A7D-81E774B6BC84


Tue Jun 14 12:26:31 2011

panic(cpu 0 caller 0x00143764): "zalloc: \"ipc kmsgs\" (959056 elements) retry fail 3"@/SourceCache/xnu/xnu-1228.15.4/osfmk/kern/zalloc.c:966

Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

0x3486fc78 : 0x12b4c6 (0x45f91c 0x3486fcac 0x13355c 0x0)

0x3486fcc8 : 0x143764 (0x4614d8 0x45eea4 0xea250 0x3)

0x3486fd68 : 0x143d52 (0x1f936b8 0x1 0x3486fdb8 0x19df51)

0x3486fd88 : 0x11dd44 (0x1f936b8 0x4f91c4 0x3486fdf8 0x19c1ca)

0x3486fdb8 : 0x12d44e (0x60 0x0 0x0 0x0)

0x3486fdf8 : 0x1264fa (0x6c5e400 0x0 0x28 0x3486fee4)

0x3486ff08 : 0x198fa3 (0x3486ff44 0x0 0x0 0x0)

0x3486ffc8 : 0x1a1cfa (0x5a49ac0 0x0 0x10 0x5a49ac0)

No mapping exists for frame pointer

Backtrace terminated-invalid frame pointer 0xbfffb648


BSD process name corresponding to current thread: komodo-bin


Mac OS version:



Kernel version:

Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386

System model name: MacBookPro4,1 (Mac-F42C89C8)


System uptime in nanoseconds: 779003950342

vm objects:2086840

kernel map entries:2875356






vm pages:22527208

ipc ports:134861020

ipc kmsgs:245518336



HFS node:2796192


Kernel Stacks:1540096



unloaded kexts:

com.Huawei.driver.HuaweiDataCardDriver     4.0.3 - last unloaded 131253655541

loaded kexts:

com.Huawei.driver.HuaweiDataCardDriver     4.0.3 - last loaded 65494408564

com.ZTE.driver.ZTEUSBCDCACMData     1.0.6

com.ZTE.driver.ZTEUSBCDCACMControl     1.0.6

com.option.driver.OptionQC     1.1.16

com.option.driver.OptionMSD     1.0.0

com.apple.driver.AppleHWSensor     1.9d0

com.apple.driver.InternalModemSupport     2.4.0

com.apple.iokit.IOBluetoothSerialManager     2.1.9f10

com.apple.filesystems.autofs     2.0.2

com.apple.driver.AppleHDAPlatformDriver     1.7.1a2

com.apple.driver.AppleUpstreamUserClient     2.7.5

com.apple.driver.AppleHDAHardwareConfigDriver     1.7.1a2

com.apple.driver.AppleHDA     1.7.1a2

com.apple.GeForce     5.4.8

com.apple.Dont_Steal_Mac_OS_X     6.0.3

com.apple.driver.AppleGraphicsControl     2.8.15

com.apple.nvidia.nv50hal     5.4.8

com.apple.driver.AppleHDAController     1.7.1a2

com.apple.driver.SMCMotionSensor     2.1.1d2

com.apple.driver.AudioIPCDriver     1.0.6

com.apple.driver.AppleIRController     113

com.apple.kext.AppleSMCLMU     1.4.5d1

com.apple.driver.ACPI_SMC_PlatformPlugin     3.4.0a17

com.apple.driver.AppleLPC     1.3.1

com.apple.driver.AppleBacklight     1.6.0

com.apple.driver.AppleTyMCEDriver     1.0.0d28

com.apple.iokit.IOFireWireIP     1.7.7

com.apple.driver.AppleUSBTCButtons     1.7.4f1

com.apple.driver.AppleUSBMultitouch     189.35

com.apple.driver.AppleUSBTCKeyEventDriver     1.7.4f1

com.apple.driver.BroadcomUSBBluetoothHCIController     2.1.9f10

com.apple.driver.AppleUSBTCKeyboard     1.7.4f1

com.apple.driver.AppleUSBMergeNub     3.5.2

com.apple.iokit.IOSCSIMultimediaCommandsDevice     2.1.1

com.apple.iokit.SCSITaskUserClient     2.1.1

com.apple.driver.XsanFilter     2.7.91

com.apple.iokit.IOATAPIProtocolTransport     1.5.3

com.apple.iokit.IOAHCIBlockStorage     1.2.2

com.apple.driver.AppleFileSystemDriver     1.1.0

com.apple.iokit.AppleYukon2     3.1.13b2

com.apple.driver.AirPortBrcm43xx     366.91.21

com.apple.driver.AppleAHCIPort     1.7.0

com.apple.driver.AppleIntelPIIXATA     2.0.1

com.apple.driver.AppleUSBHub     3.4.9

com.apple.iokit.IOUSBUserClient     3.5.2

com.apple.driver.AppleFWOHCI     3.9.7

com.apple.driver.AppleUSBEHCI     3.4.6

com.apple.driver.AppleUSBUHCI     3.5.2

com.apple.driver.AppleEFINVRAM     1.2.0

com.apple.driver.AppleSmartBatteryManager     158.10.5

com.apple.driver.AppleRTC     1.2.3

com.apple.driver.AppleHPET     1.4

com.apple.driver.AppleACPIPCI     1.2.5

com.apple.driver.AppleACPIButtons     1.2.5

com.apple.driver.AppleSMBIOS     1.4

com.apple.driver.AppleACPIEC     1.2.5

com.apple.driver.AppleAPIC     1.4

com.apple.security.seatbelt     107.12

com.apple.nke.applicationfirewall     1.8.77

com.apple.security.TMSafetyNet     3

com.apple.driver.AppleIntelCPUPowerManagement     76.2.0

com.apple.driver.DiskImages     199

com.apple.BootCache     30.4

com.apple.iokit.IOSerialFamily     9.4

com.apple.driver.DspFuncLib     1.7.1a2

com.apple.NVDAResman     5.4.8

com.apple.iokit.IOHDAFamily     1.7.1a2

com.apple.iokit.IOAudioFamily     1.6.9fc5

com.apple.kext.OSvKernDSPLib     1.1

com.apple.driver.IOPlatformPluginFamily     3.4.0a17

com.apple.driver.AppleSMC     2.3.1d1

com.apple.iokit.IONDRVSupport     1.7.3

com.apple.iokit.IOGraphicsFamily     1.7.3

com.apple.driver.AppleUSBBluetoothHCIController     2.1.9f10

com.apple.iokit.IOBluetoothFamily     2.1.9f10

com.apple.iokit.IOUSBHIDDriver     3.4.6

com.apple.driver.AppleUSBComposite     3.2.0

com.apple.iokit.IOSCSIBlockCommandsDevice     2.1.1

com.apple.iokit.IOBDStorageFamily     1.5

com.apple.iokit.IODVDStorageFamily     1.5

com.apple.iokit.IOCDStorageFamily     1.5

com.apple.iokit.IOSCSIArchitectureModelFamily     2.1.1

com.apple.iokit.IO80211Family     216.1

com.apple.iokit.IONetworkingFamily     1.6.1

com.apple.iokit.IOAHCIFamily     1.5.0

com.apple.iokit.IOATAFamily     2.0.1

com.apple.iokit.IOFireWireFamily     3.4.9

com.apple.iokit.IOUSBFamily     3.5.2

com.apple.driver.AppleEFIRuntime     1.2.0

com.apple.iokit.IOSMBusFamily     1.1

com.apple.iokit.IOHIDFamily     1.5.5

com.apple.iokit.IOStorageFamily     1.5.6

com.apple.driver.AppleACPIPlatform     1.2.5

com.apple.iokit.IOACPIFamily     1.2.0

com.apple.iokit.IOPCIFamily     2.6


Can it have to do something with these kexts ? I don't know why I have them or why they are running.


unloaded kexts:

com.Huawei.driver.HuaweiDataCardDriver     4.0.3 - last unloaded 131253655541

loaded kexts:

com.Huawei.driver.HuaweiDataCardDriver     4.0.3 - last loaded 65494408564

com.ZTE.driver.ZTEUSBCDCACMData     1.0.6

com.ZTE.driver.ZTEUSBCDCACMControl     1.0.6

com.option.driver.OptionQC     1.1.16

com.option.driver.OptionMSD     1.0.0

MacBook Pro, Mac OS X (10.5.8)
  • Klaus1 Level 8 (47,755 points)

    You need to make sure you have rid yourself of all constituent parts of Komodo.


    The kexts you mention may be relevant. Kernel panics are usually, but not exclusively, hardware relatred, often caused by faulty RAM.


    What is a Kernel Panic?








    More details here:




    Useful article on how to avoid and eliminate kernel panics here:



  • bottleboot Level 1 (0 points)

    Hi! Thanks for your reply!


    One of the hardwaretest i ran was a RAM test which came out fine as is my HD.

    I have had other kernel panics without Komodo running, that's the diffecult thing.

    I have gone through so many technotes, tutorials and tests without any significant result, I don't know where to look again. I wish the error logging would be more detailed.


    So far it has been a tad better, whithout another kernel panic yet but the day isn't over. Programs hang more often now though.

  • LexSchellings Level 6 (8,752 points)

    You have uninstall Komodo, not only make it not running. But the real culprits are:

    You have to uninstall all the ZTE and Huawei software, look in Applications folder, Utilities folder, SystemPreferences and then look for leftovers in the following folders:

    yourname /Library/LaunchAgents









    Edit: and of course restart after this, and empty the trash.

    If it is not possible to remove an item 'because it is in use', start ActivityMonitor and quit that process.