Previous 1 2 3 4 5 6 Next 85 Replies Latest reply: Apr 9, 2016 12:19 PM by OrganicBooks Go to original post
  • benttop Level 1 Level 1

    Interesting. That would mean if my theory held any water at all, it would be just USB/Firewire issues. Well, going on the third day here without any false eject notices. BTW Thunderbolt rocks. Way faster!

  • benttop Level 1 Level 1

    Well after six days using a Thunderbolt drive instead of USB or Firewire, I have had exactly zero instances of the eject message. I'm not sure exactly what conclusions can be drawn since I changed several variables at the same time. By doing this switch, these are all of the variables at play:


    • HDD Interface (USB/Firewire to Thunderbolt)
    • HDD manufacturer (Seagate to G-Tech)
    • HDD USB Driver (removed)


    Any one of those could have been the culprit. Based on all of the reports I've read here and other threads, it really is a tossup, but I'm betting on the drivers being the main culprit based on the number of folks who have de-installed theirs and had success.


    Seems mine's fixed. Good luck to those of you who are still seeing this issue.

  • sc25893 Level 1 Level 1

    I think it's nonsense to think that everyones hard drives are failing!


    This keeps happening to me on my mac mini, transfers for about 10 minutes or so then the big error message. The drive is securely connected via a usb hub with my mouse receiever in another on of the 4 slots.


    This has also happened to me when plugged directly into the mac mini.


    No surprises that I have exactly zero problems when using this same drive with the pc, can transfer to my hearts content and never disconnects. It even offers to fix the drive after the mac has screwed it up. I've had to run chdsk J: \f a number of times already thanks to osx.


    This is a mac issue and all these little things are starting to stack up against apple in my mind (after the HD4000 incident). I mean, this is basic, an external drive should connect and stay connected.



  • benttop Level 1 Level 1

    Well more than two weeks ago since I switched everything to Thunderbolt, and I have not seen the eject message even once. I'm convinced I've corrected the problem here. Get rid of your USB and Firewire drives folks, they seem to be the source of this anomaly.

  • sc25893 Level 1 Level 1

    Get rid of your USB and Firewire drives folks, they seem to be the source of this anomaly.


    I'm glad you got it fixed, but this is no solution! Lol. I would have thought that in 2013 when computers have advanced so much that it could handle a USB drive. Not exactly cutting edge stuff!



  • benttop Level 1 Level 1

    If it ever gets resolved correctly, I'm thinking there is a bug in the USB specification that Apple publishes for third party developers, such that they inadvertently create drivers that behave in this way. Since that is pure speculation, chances are great that I'm wrong, but it has to be something bizarre like that to have had so many people having this same issue with such a wide variety of external drives. Add to that the instances of actual hardware failures (cables, drives, etc.) and it is very difficult to diagnose or troubleshoot.

  • stevenarichards Level 1 Level 1

    A few months ago, Apple store tech told be that Apple had reduced the voltage sent to USB drives (after 10.5 I think).

    I had 2 drives crash as a result of this problem.  It happens on my Macbook Pro and my Mac Pro.


    Yes, I agree with sc25893, Mac is forcing us to toss our USB drives

  • benttop Level 1 Level 1

    It would be good to know if this Apple store tech's story has any basis or if it is just his theory. Anyone know how to find out if this is really true or not?

  • stevenarichards Level 1 Level 1

    Agreed.   I was told that communications came from national technical support and was a result of meetings with Western Digital and Adobe.


    I had several experiences with Apple's Genuis Bar and store management over my usb drive ejecting.  Apple finally replaced my first MacPro over the issue, but the replacement newer-version MacPro experiences the same issue.  It can't just be the drives, because it happens in all USB drives.  I agree with someone's comment that it happens more over usb splitters.  But nothing convinces me that it's not inherent in ALL usb drives.  Over the past 4 years, my archives consist of 11 full-sized WD drives of varying sizes plus 7 passport-size drives.  All Western Dig...  My experience is that it happens to them all.  It got worse after OS-X Leopard.


    My newest MacPro just started having the same problem with two 2TB drives.

  • benttop Level 1 Level 1

    I have half a dozen WD USB drives here that are all dead. Never again. They are junk. Trust my data to those? Not bloody likely.

  • benttop Level 1 Level 1

    Here it is July 7. Since switching to a pair of Thunderbolt external drives in January, I have had exactly ZERO disconnect messages. I guess six months without any fails is enough time to pronounce the cure. Try it. You might like it.


    The side benefits are quite nice too - these drives are way faster. I'll never go back to USB.

  • BigGuzz Level 1 Level 1

    I have same issues on my early 2011 MacBook Pro on OSX 10.8.4, if i connected my WD MyBook Essentials, the partitions shown for under 1 minute and suddenly didnt detected on finder after the pop up message "the disk was not eject properly..." but i never ejected the MyBook! replugged in but the warning message still appears.

    i have 2 partitions on NTFS formatted and 1 partition for Time Machine. no ones detected on finder

    already updating the MyBook firmware. reinstall the paragon NTFS, updating the OSX, unchecked the harddisk sleep on Energy Preferences, but no ones works.


    i think this is Mountain Lion issues, because i tried on my friend latest 2011 MBP 10.8.4, nothing worked like on my MBP. But when i connecting to windows laptop and my Samsung TV (can read hdd for movies,etc) they works normally without problems. so not hardware problem on my MyBook and my MBP.


    please Apple fix this bugs!

  • AxEffects Level 1 Level 1

    Hi there folks,


    While surfing the mac forums lately I've seen a lot of people having difficulties with external storage devices not being detected, and many, being dismounted or self-ejecting causing loss or damage of data. I've also read of problems pertaining to old data not being accessible on the new drive. This being said, I've had these same issues recently with my Mac. Take a deep breath, all is well. It really isn't your Mac. After reading so many forum posts I've decided to share some of my experiences that have answered questions and resolved these problems for me.


    Here are some solutions for most of the folks I'm sure, who are having problems with self-dismount/eject:


    I'm running a 2013 Macbook Pro Retina with OSX 10.8.4 Mountain Lion.


    For those that just can't get their drives recognized or to show in 'Finder':


    I'll start with proper formatting. Be sure your new drive has been formatted as 'Mac OS Extended (journaled)' and that the partition map scheme is 'GUID Partition Table.' Even though your drive should have come formatted for your Mac 'out of the box', sometimes they just don't get it right.


    An important factor worth mentioning is to be sure you're running your external storage device with the most recent firmware. Just because that shiny new drive came fresh out of the factory sealed box, doesn't mean you have the latest firmware. Keeping your firmware up to date is a most definite necessity as each and every day brings us new features and function in our operating systems, that sometimes changes how hardware will behave and does indeed require Firmware Updates from the manufacturers.


    Ensure your USB/Firewire/Thunderbolt connections are functioning properly; this is especially important if you are using an expandable multi-port hub with your system. Via 'System Report' pull up 'Hardware' and 'USB', 'Firewire', 'Thunderbolt' (whichever applies). Look at the data and be certain everything is being found, and found correctly. If you see something that is not being found, or is being found incorrectly (USB 3.0 connection being found as a USB 2.0 as an example) be certain of a couple of things:


    Check that your power for all of your devices are connected (external drive power, power for your hub, etc). You may have been using your hub passively running other low consumption devices on it with line level voltage from your computer with no problems. However, your hub must have power to run a device of this type. Another possibility is that your cable may be damaged, or you're plugged into a USB hub or USB port on your computer that only supports USB 2.0.


    For everyone who suffers with "improper eject":


    The first thing I discovered when I had problems with other external drives dismounting is that power management in newer Macs use a VERY LOW POWER sleep mode, almost to hibernation levels. Most external drives can only detect a connection to a computer when the computer is sending a line level signal via connection cable. When newer macs enter sleep mode the power is beneath the threshold level the external devices are capable of sensing. Therefore, when the computer sleeps, the drive thinks the computer is off and puts itself to sleep causing improper dismount or self-eject, and of course generating the message that the device has been improperly ejected. Yes, this can damage files. What is required when using these devices, is to either eject the drive manually through the Finder Window, and then let your computer sleep at will, or adjust your power management setting in the "Energy Saver" tab to "NEVER" for the 'Computer Sleep' setting. Also in the same Energy Saver window, be certain to UNCHECK 'Put hard disks to sleep whenever possible," and UNCHECK 'Enable Power Nap.'


    Many external drives have there own power management features as well, that can be set from its own settings window and these operate independently of OSX. If these devices are set for a sleep mode before OSX  sleeps, it will cause itself to eject improperly from the OS and you will get error messages and possibly corrupt data, and, or your back up. Where these devices offer power management settings, it is advisable to disable any sleep settings. Until all of the manufacturers catch up with ultra low power connection discovery, it is highly recommended that you manually eject your drive through OSX Finder prior to any time you plan to let your computer sleep, or before you turn it off. This should be rule of thumb for any external storage device connected to a Mac. I personally leave my computer on full time during the day with external drives ready at the helm. I have had ZERO issues since discovering these things.


    This said, some users will have their external drives plugged into a power strip separate from their computer; and I know people who do this; they will turn off the power strip when shutting down the computer; the computer may not be ready and when the power to the drive is shut down...voila, improper eject.


    Another item that contributes to these issues is energy preference settings being stored by other programs for your old storage device, perhaps now accessing your new drive imposing obsolete, and conflicting settings. When I first experienced some of this behavior at discussion, I had replaced my 2 TB WD MyBook Studio for Mac with a 4TB Seagate Backup Plus for Mac drive. The WD has power management options and when set were also being stored by Time Machine. The answer is to delete the offending file. I deleted the preference file for Time Machine (not to worry, the Mac makes a new one ;-)), by doing the following:


    1) Turn off Time Machine via Time Machine Preferences window.


    2) Open the 'Finder' window.


    3) Eject External Hard Drive via 'Finder' window.


    4)  Click on Macintosh HD.


    5)  Click on Library.


    6) Click on Preferences.


    7) Locate the file named '' and DELETE it (Move to Trash).


    8) Restart your computer


    Now for another one: Once your drive is installed successfully and is functioning properly, if you've had a problem with Time Machine not being able to access your backup data, when you know the data is there and you can see your backup folders plain as day, an item that may warrant your attention here is a permission reset if you've moved data from the old storage device to the new one:


    1) Reboot and hold Command + R


    2) Terminal and type 'resetpassword' (no spaces)


    3) Select main drive at top of dialogue box that appears, then select 'reset permissions/ACL at the bottom of the box.


    4) Reboot computer.


    5) Open 'Disk Utility' in Apps and reset main hard drive permissions.


    6) Reboot computer.


    This process resets the user permissions folder. One way to avoid going through all of this is to use your 'Migration Tool' found in your Apps folder INSTEAD of  the old copy and past from the old to the new.


    This one probably goes without saying; however, I've read many, many forum complaints that the backup software that came with their drive either won't install or doesn't function properly on their mac. USE TIME MACHINE. Most storage device Manufacturers even specify to use Time Machine instead of their own software. The major players in the field don't even make BackUp software for Mac. They'll format the drive for Mac (in most cases :-/ ) but that's it. There is a reason for this; no other backup software comes close to keeping your files as safe and secure as they will be with  APPLE Time Machine.


    Hope this helps some people.


    Happy computing!

  • Apollo Reyes1 Level 1 Level 1

    any updates on this prob? I have the same issues and wondering if you have a fix . . . thanks

  • PlotinusVeritas Level 6 Level 6


    • HDD Interface (USB/Firewire to Thunderbolt)
    • HDD manufacturer (Seagate to G-Tech)
    • HDD USB Driver (removed)

    Any one of those could have been the culprit.




    NONE of those is the culprit.


    95% of the errors seen by those in this thread is due to ONE THING, a junky 50 cent SATA bridge/card in an external HD


    External HD are insanely easy to diagnose (Ive got a 100 of them). Bad USB cable (on commercial sold USB drives) almost doesn’t exist anymore.


    External USB HD have 4 'parts' (not counting the HD itself and its internals)

    1. USB cable ....(never an issue anymore, approaching 100%)

    2. HD enclosure.....a plastic or metal box which cannot ever be an issue.

    3. the HD itself, in these issues, it accounts for less than 5% (however I recommend NOBODY buy a WD drive).

    4. ....and last but not least is the epicenter of 'weak links' ,.....a SATA card/bridge that is connected to the HD inside the HD box, the size of a stick of gum, with SATA female on one side, and female USB on the other side, containing circuitry for data transfer between the SATA on the HD and to USB on the other.


    While these bridge cards are better than they used to be, theyre still insanely unreliable.


    There are literally probably MORE than 100,000 perfectly working external hard drives out there thrown away every year because people assume the "hard drive is bad"... when really they could crack open the HD enclosure, remove the HD and put the good HD into a new enclosure.



    See this video of the SATA CARD, its at 8:55min.



    All HD external are nearly 100% like the video above.


    See pic below,..a (much larger) SATA card as found inside a typical HD enclosure ($20 ebay)


    This is the nasty critter pictured below causing all the "crazy" activity seen on external HD, very odd behaviour, some have called it "haunted hard drive syndrome".  Random ejects, random strange vanishing of the HD , especially in mid transfer of data.