Previous 1 2 3 Next 83 Replies Latest reply: Nov 12, 2015 10:13 AM by tugruler
simpswim Level 1 (0 points)

For some reason my 1TB WD My Passport Essential SE keeps randomly ejecting itself from my mac computer. And I keep getting this error message pictured here:

 

image.png

In text: "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off. To eject a disk, select it in the Finder and choose File > Eject. The next time you connect the disk, Mac OS X will attempt to repair any damage to the information on the disk"

 

I am transferring large (5-10GB) HD video files, so I'm wondering if this is overloading the drive. However I don't think this is the case since I easily transferred these types of files on the older 500GB WD My Passport Mac USB hard drive (Model No: WD5000MEA) that I also own. Seeing that my newer 1TB WD My Passport Essential SE (Model No: WX71A31E5201) is built to perform better, faster and more reliably than my older model, I don't think this is the case.

 

I've tried resetting the PRAM on my Mac computer, and I used Mac's Disk Utility application to repair the disk (note: Disk Utility said that my drive was fine). What should I do to stop my external hard drive from randomly ejecting itself? (Hopefully the solution doesn't require me to delete/move the many, many GBs of files I have on my drive.)

 

The things that I have:

 

Computer:

Mac OSX Snow Leopard Version 10.6.7

Processor: 2.6 GHz Intel Core 2 Duo

Memory: 4 GB 667 MHz DDR2 SDRAM

 

External Hard Drive:

1TB WD My Passport Essential SE (WDBACX0010BBK-NECS)

Format: Mac OS Extended (Journaled)


MacBook Pro, Mac OS X (10.6.7)
  • Eric Ross Level 6 (11,665 points)

    Try this, open energy saver preferences and uncheck the box for putting drives to sleep when idle, if the box is currently checked.

  • simpswim Level 1 (0 points)

    Also:

     

    I get this error message when I try to transfer files as well:

     

    The Finder can’t complete the operation because some data in “Example_File.mov” can’t be read or written.

    (Error code -36)

  • simpswim Level 1 (0 points)

    Thanks for your help.

     

    I tried that but the drive will still eject itself randomly at times.

     

    I contacted Western Digital about this and they say it might be a problem with my USB cord. So they're going to send me a new one.

     

    Has anyone else had this problem and found that it was due to a faulty USB 3.0 (compatible with USB 2.0) cord?

  • Allan Eckert Level 9 (50,726 points)

    Sounds like disk is on the way out. I would move or backup all data on it.

     

    Allan

  • simpswim Level 1 (0 points)

    I just purchased it, though. Do you really think this is the case, and I purchased a defective disk?

  • Allan Eckert Level 9 (50,726 points)

    In my years of IT support you would not believe how many disks were dead in the first month after installation. My suggestion is contact the vendor and have it replaced immediately.

     

    Allan

    tiger

  • simpswim Level 1 (0 points)

    That's pretty unfortunate. I'll try to do that.

     

    Any reccomendations on how I can get it replaced with minimal amounts of hoops I might have to jump through for Western Digital?

  • Allan Eckert Level 9 (50,726 points)

    Call or email WD and ask for a an RMA with a shipping document.

     

    Allan

  • GrendelODA133 Level 1 (0 points)

    I just purchased one of these tonight and started having the same continuous ejection issue as soon as I started trying to put files on it.  I started copying a large folder of digital video when the error first occurred.  Every couple of minutes I can see the drive icon go semi-transparent like it has been ejected.  Then the following error message pops up requiring an "OK".

     

    WD My Passport 0740 Media is in use and cannot be powered off.

    Try quitting applications and try again. (OK button)

     

    I have several portable drives and have never experienced an issue such as this.  This is my first (and likely last) "WD Passport".  I have seen the error reported here in the Apple discussions as well as WD support and other tech forums.  So far I have not seen a reasonable explanation.

     

    Computer:

    Mac OSX Snow Leopard Version 10.6.8

    Processor: 2.8 GHz Intel Core 2 Duo

    Memory: 4 GB 1067 MHz DDR3

     

    External Hard Drive:

    1TB WD My Passport Essential SE (WDBACX0010BBK-01)

    Format: Mac OS Extended (Journaled)

  • aarduini Level 1 (0 points)

    I am also having the same problem with a 1TB WD My Passport Essential SE I purchased this week.

    Please let us know us know when you receive if the new cable they sent you fixes the issue, or if we will all have to contact WD for a hard drive replacement,

  • GrendelODA133 Level 1 (0 points)

    With me, the problem was the WD software that I installed.  I uninstalled it and reformatted the drive.  Since then I have not experienced any more problems.

  • Hypnoguy Level 1 (10 points)

    When I have had this problem, I assumed it was the USB failing. Could this be it?

  • John Hammer1 Level 4 (2,805 points)

    Hypnoguy might be on the right track. If your drive is a USB drive, plug it directly into your computer, not a USB hub. I have found that solves a lot of problems with USB devices, especially if the hub being used is an unpowered hub.

  • GrendelODA133 Level 1 (0 points)

    Again, the software was the problem with me.  It was not the hardware.  As previously stated, I have other drives

    that were not experiencing any problems.  There is nothing wrong with my USB port and I am not using a hub.  As soon as I stopped using the WD proprietary software, the problems ended.

Previous 1 2 3 Next