1 Reply Latest reply: Jun 15, 2011 4:32 PM by kaimandreamin
kaimandreamin Level 1 Level 1 (0 points)

Yesterday, I was wanting to play Flight Simulator in Windows so I restarted the Mac. It made the "Mac noise" and I held the "option" key but the screen was black (it was lit up) and the Apple logo screen never came up. It was stuck on the black screen for a while so I held the power button down and restarted it. Then I left it alone and the Apple logo didn't come up again. After a minute, the screen turned blue and it went to the OS X login screen. I logged it and Mac OS X worked fine. It might be a little laggy but it works. So I kept trying to get it to let me select Windows with no luck. Then I went into System Preferences and told it to start up into Windows. Restarted the Mac again, no Apple screen and the Windows boot screen came up. It loaded and then the screen turned black (again it was lit) and stayed for a few minutes. Then I restarted and it did the same thing. I tried holding "option" again to go back to Mac OS X and it didn't work. I tried holding "X" to get it to go to Mac OS X and it also didn't work. So I was stuck in Windows mode and it wouldn't boot. When I would let it do it's own thing at startup, it would be on a black screen with white text saying that Windows didn't shutdown properly or something and it gave me 3 choices to boot it. But the arrow keys wouldn't work so I hit "Enter" and it still wouldn't boot Windows. Finally, I inserted the Mac OS X disc and held down "C" at startup to us the disc and I reinstalled OS X and now I'm back in Mac mode but the Apple logo screen still doesn't show up and I won't try to go into Windows again. I also tried to do a hardware diagnostic which is on the Mac application disc but it wouldn't do that either. Any thoughts or ideas?


MacBook Pro, Mac OS X (10.6.7), 15" 2.0 GHz quad core i7