Previous 1 2 3 Next 33 Replies Latest reply: Oct 21, 2012 10:07 PM by rogierlommers
nodomain Level 1 (0 points)

Hi folks,


I recently purchased two iPad2, upated to the latest firmware and had to find out that FaceTime somehow seems to "forget" the registration. It only works after reboot or after disabling and enabling it through the iPad's settings.



My iPad is a 3G with 32 GB, the other one is a wifi only with 16 GB. Both are connected to wifi in separate locations. I also forwarded all ports as described in the knowledgebase article but we still only can get it to work by rebooting the iPads or disabling and enabling FaceTime.


Most of the time it just works in one direction (e.g. the wifi iPad calling the 3G one) - the call goes through and I am able to answer the call. But most of the time when I try to call the wifi iPad, my iPad tries to connect, plays the "ringing" sound but nothing happens - the call does not reach the other iPad at all.


There is also no error message...


Do you have any ideas? It somehow ***** that we have to initiate the FaceTime call using plain old telephones ;-)... I was hoping that it "just works".


Perhaps this is a bug that is hopefully fixed in iOS5?



iPad 2, iOS 4.3.2
  • Dah•veed Level 7 (33,390 points)

    Some folks have discovered that changing their DNS service fixes FaceTime connection issues.


    The ideal way is to configure your modem/router with DNS service, but often settings in Settings/Wi-Fi on your iPad will override the router settings.


    Try either of these;



    Google Public DNS,


    I would also reset both iPads. Press & hold the Power and Home buttons together for 10+ seconds, ignoring the red power-off slider, until you see the Apple logo.

  • nodomain Level 1 (0 points)

    Thanks for your reply. I won't go for the DNS solution since the drawback of that solution is that then my iTunes downloads are too slow because of Akamai's geolocation algorithms (see here

    Resetting the iPad is the same as shutting it down and then switching it on again, right? As I already wrote, this helps for getting it to work, but it is no "durable" solution. I just want to be able to call the other iPad without using the phone and telling the other side to reset the iPad.

    For me, it looks like a bug in the registration or something else. How can we inform Apple about this so that they fix it soon?



  • Dah•veed Level 7 (33,390 points)

    Resetting the iPad is the same as shutting it down and then switching it on again, right?

    That is not what I described. So no, it is not the same.


    For me, it looks like a bug in the registration or something else.

    FT works fine for millions of us. It is likely a DNS resolution issue with your ISP.


    If you have a Mac you can set different network configurations for different needs with the Location feature. You could use what works for FT when you want FT and what works for iTunes when you want iTunes. It takes seconds to switch between the settings.

  • nodomain Level 1 (0 points)


    I still think it is the same:


    I don't have a Mac (yet)... This thread deals with FT problems between two iPads. Furthermore it is important that it just works without playing around with the settings each time.


    So let me conclude:

    I need to try the reset (once more)... But I don't think this is a solution because when I try to call the next day it surely won't work again.

    I don't want to change the DNS settings since then we are going to have issues with iTunes downloads.

    I still think it's a bug...


    Any other ideas? How can I file a bug with Apple as a non-neveloper?



  • nodomain Level 1 (0 points)

    I filed a bug right now. Lets see how this is being fixed :-)

  • Dah•veed Level 7 (33,390 points)
    Furthermore it is important that it just works without playing around with the settings each time.

    If your ISP does not provide DNS service that allows decent FT connection then that is not an Apple issue, that is your ISP's issue. If resetting the DNS settings when you wish to use FT is what works, then that is what one would have to do to work around the issue with your ISP.


    You have been offered a solution that has resolved the FT connection issue for many people. So that is anecdotal evidence that it is not likely a bug, especally since FT works perfectly from the start for millions of us.

  • nodomain Level 1 (0 points)

    Again, I am still convinced that this is not a DNS issue at all. I assume this has something to do with NAT timeouts or something like this.

    Why? Because I do not get an error message as other people who can not register with FT. The call just never reaches the other iPad. Furthermore, if I changed the DNS settings I would have the huge drawback that the iTunes downloads are slow (see some post above).


    Unregistering and registering FT again (or rebooting the device) helps to temporarily fix the issue. That's another fact that points me to NAT issues. I assume that FT works with something similar or equal to SIP. If it works like SIP then there could be some issues with my routers (AVM Fritz!Box on both ends) that kills the NAT connections to the iPads. But perhaps it is someting more complex since port forwarding didn't help either.


    As you can see, I am still unsure about the real reasons for this "bug". But I still think it's a bug. Since all my settings are correct in my opinion, it only can be a bug.


    An Apple product just needs to work. Without making difficult settings. And my two iPads with FaceTime do not just work! I hope this is getting fixed soon - if it's a bug or not.


    Just because FT works for millions of people does not mean that there is no bug in my special situation!

  • Dah•veed Level 7 (33,390 points)

    Have you taken the 30 seconds it would take on both ends to see if the DNS solution resolves your issue?

  • Fred*M. Level 4 (2,385 points)



    I suggest you try rebooting the iPads.  Hold down both the Sleep and Home buttons for several seconds until the Apple logo appears.  After restarting, see if there is improvement.


    Another thing to try is to remove the SIM card from the 3G iPad.  FaceTime only works over WiFi, and that iPad might be jumping to 3G mode without your knowledge.



  • nodomain Level 1 (0 points)

    Some weeks ago the DNS settings in my Fritzbox were indeed set to, and it did not work either.

    I can give it a try.

  • nodomain Level 1 (0 points)

    If you read my original post then you can see that a reboot or disabling and enabling Facetime really helps. But just for the day... if we try to call again on the next day or some hours later, FT doesn't work again.


    And come on, do you really want me to remove the SIM card? This must be a joke!


    What is about "it just works"?


    I'll try the DNS stuff but I don't see this as a solution because of the slow Akamai downloads that I experience then.

  • Roosevelt Jones Level 2 (380 points)

    If you are able to get FaceTime to work reliably with the different DNS settings then you will know it is a DNS issue and you can work with your ISP to see if they can get the DNS server updated with the values needed to make FaceTime work correctly. They can possibly get with Apple to see what name/ip pairs they need. If not then more troubleshooting will need to be done to get your FaceTime running properly.


    Are you able to run a parallel test using Skype? Do you have a static IP from you ISP? If not, do you have control over IP lease time? Is there anything you can ting of thatbwould expire on a daily basis? Where are you located and do you know if others in your region are having similar issues?


    We are just end users here and not Apple employees with in-depth knowledge of how FaceTime actually works. We only have access to our experiences and what we have seen work for others as we try to assist other users. Contacting Apple support directly is a possible option as Apple does work to fix reported bugs in their systems.

  • o365 Level 1 (0 points)

    I discovered a strange reproducible "FaceTime Sleep Bug" for Wi-Fi iPad 2 and iPod Touch.


    You can experiment for yourself whether this is an issue for you and use the (not so convenient) workaround. Hopefully when more of us complain, Apple will get it resolved permanently.

  • o365 Level 1 (0 points)

    You said you have no problem with calling the 3G version of iPad 2, so I suspect this is more similar to my iPhone 4 which always works to receive FaceTime.


    For your Wi-Fi only iPad 2, could you try to use your 3G iPad to call Wi-Fi iPad while Wi-Fi iPad is actively on (not in locked screen). If this works, then try the "FaceTime Sleep Bug" experiment yourself to see if this is the case.


    You said "I also forwarded all ports as described...", which seemed technically impossible, because port forwarding should work for one device only, so in theory you cannot possibly forward to both your wi-fi and 3G iPads... so I would suggest that you turn off all manual port forwarding and just leave them as UPnP. Just my 2 cents.

Previous 1 2 3 Next