Previous 1 2 3 Next 60 Replies Latest reply: Jun 16, 2011 9:38 AM by Philly_Phan
Philly_Phan Level 6 Level 6 (12,410 points)

I need help blocking HTML5.  Whenever I log on to my Mac, Safari automatically opens (it's NOT configured to do so) and I the following message pops up:

 

The website “http://download.cnet.com” is requesting 1 MB of disk space to store “html5 test db” as a database on your disk.

 

I click NO and then an application that I do not want automatically downloads.

 

How do I stop the garbage HTML5 from taking control of my machine?

 

 

 

Flash never caused me problems like this.


iPod classic, Mac OS X (10.6.7), iPad-1 IOS 4.3.3
  • a brody Level 9 Level 9 (64,595 points)

    Flash actually causes worse problems.  It eats processor cycles for breakfast, lunch, and dinner, and is why PowerPC Macs are having extreme difficulty with Youtube without HTML5.  Amazingly the old Quicktime Sorenson compression allowed for similar streaming video on a Powerbook G3/233 Mhz as Youtube, yet it wasn't ever adopted by Youtube.  There are browsers that don't use HTML5, but HTML5 you should be thankful does not use processor cycles as badly.  You can Google which ones do not.  In the meantime, you should probably contact C!Net and let them know they need to improve their HTML5 support, or simply not ask for it.  Seems like they aren't programming properly for it.

  • Linc Davis Level 10 Level 10 (164,105 points)

    Whenever I log on to my Mac, Safari automatically opens (it's NOT configured to do so)...

     

    You may not know that it's configured, but it obviously is. Check your login items in the Accounts preference pane. If you're absolutely sure that nothing in that list is launching Safari, then check the following files:

     

    • /Library/Preferences/com.apple.loginwindow.plist
    • /Library/Preferences/loginwindow.plist
    • Library/Preferences/com.apple.loginwindow.plist
    • Library/Preferences/loginwindow.plist

     

    The first two (if they exist) are in the Library folder at the top level of your startup volume. The other two are in the Library folder inside your home folder.

     

    Also check Safari > Preferences > General > New windows open with...

     

    I agree that you should be able to set a preference to deny websites the right to store data locally without being prompted. There doesn't seem to be any way to do that.

  • RaiMan Level 1 Level 1 (35 points)

    strange discussion - wrong discussion.

     

    If you are sure that you did not configure Safari to start up at login, so why blame Safari and HTML5?

     

    You have somehow allowed (or even without knowing) cnet.com to put something on your machine, that now forces Safari to open the mentioned cnet url at login.

     

    So try to find out what it is and how to stop it.

     

    I agree with a brody: blame cnet about bad habbit and programming.

  • Philly_Phan Level 6 Level 6 (12,410 points)

    Defend HTML5 all you want but I never had problems with Flash.

     

    I really want to contact CNET but I can't figure out how.

  • Philly_Phan Level 6 Level 6 (12,410 points)

    I have positively confirmed that there is absolutely nothing in the preferences panes for any of the login accounts to explain this.  Safari should not even open up but this is happening with ALL of the logins!

     

    Should I be able to read the plist files?

  • a brody Level 9 Level 9 (64,595 points)
  • Philly_Phan Level 6 Level 6 (12,410 points)

    Linc Davis wrote:

     

    Whenever I log on to my Mac, Safari automatically opens (it's NOT configured to do so)...

     

    You may not know that it's configured, but it obviously is. Check your login items in the Accounts preference pane. If you're absolutely sure that nothing in that list is launching Safari, then check the following files:

     

    • /Library/Preferences/com.apple.loginwindow.plist
    • /Library/Preferences/loginwindow.plist
    • Library/Preferences/com.apple.loginwindow.plist
    • Library/Preferences/loginwindow.plist

     

    The first two (if they exist) are in the Library folder at the top level of your startup volume. The other two are in the Library folder inside your home folder.

     

    Also check Safari > Preferences > General > New windows open with...

     

    I agree that you should be able to set a preference to deny websites the right to store data locally without being prompted. There doesn't seem to be any way to do that.

    I found the first and third plists.  I double-clicked on each one and neither one has any reference to Safari.  The second and fourth plists do not exist.  What next?

     

    Should I trash those plists?

  • Philly_Phan Level 6 Level 6 (12,410 points)

    a brody wrote:

     

    CBS Interactive Privacy Policy Comment link

    I'll do it but why "CBS Interactive?"

  • a brody Level 9 Level 9 (64,595 points)

    If you scroll down to the bottom of CNet's website, a popup menu on the right says "Other CBS Interactive sites" and there is a toolbar down there that includes the Privacy Policy link, which directs you to that contact page.  Yes, their page navigation leaves a lot to be desired.

  • Linc Davis Level 10 Level 10 (164,105 points)

    What about /Library/Preferences/com.apple.loginitems.plist and /Library/LaunchAgents ? You're looking for references not necessarily to Safari, but to a URL.

  • Philly_Phan Level 6 Level 6 (12,410 points)

    Thanks.

     

    They allege a response within 24 hours.

  • Philly_Phan Level 6 Level 6 (12,410 points)

    Linc Davis wrote:

     

    What about /Library/Preferences/com.apple.loginitems.plist and /Library/LaunchAgents ? You're looking for references not necessarily to Safari, but to a URL.

    Here's the loginterms.plist.  Nothing related that I can see:

     

    bplist00—  ^privilegedlist“    _  CustomListItemsZController° ‘  

       TIcon_  CustomItemPropertiesTNameUAliasO  zImgR zFBIL n  ^ »¯˘üH+2Ùæ2Ù¡«FáÜ           ˇ˛icnCˇˇˇˇ $2Ùæ2Ùπ2Ù∏2Ù∂2Ò22Ò12Ò$ >  3 " Application.icns   Macintosh HD ™Applications/Nikon Software/Nikon Message Center 2/Nikon Message Center 2.app/Contents/SharedSupport/Launch Nikon Message Center 2.app/Contents/Resources/Application.icns  /ˇˇ—

    _  com.apple.loginitem.legacyprefs“    TPathTHide_ á/Applications/Nikon Software/Nikon Message Center 2/Nikon Message Center 2.app/Contents/SharedSupport/Launch Nikon Message Center 2.app _  Launch Nikon Message Center 2O  P P  »¯˘üH+2Ù∂2Ù∏«FáÜ           ˇ˛ˇˇˇˇ  2Ù∂2Ò22Ò12Ò$ >  3 D!Launch Nikon Message Center 2.app   Macintosh HD ÜApplications/Nikon Software/Nikon Message Center 2/Nikon Message Center 2.app/Contents/SharedSupport/Launch Nikon Message Center 2.app  /ˇˇ    1<>GLchn Ï Ô         ™ ´ À    

     

    LaunchAgents has two files:

    com.adobe.AAM.Updater-1.0.plist

    com.adobe.CS5ServiceManager.plist

  • thomas_r. Level 7 Level 7 (30,345 points)

    This has nothing whatsoever to do with HTML5.  No flavor of HTML can cause Safari to start up and try to load a page.  What you're asking is like saying that your radio turns on and plays bad music when you turn on your car, and blaming the radio station for the problem.  (Okay, the bad music is their fault, but everything else is not.  The radio station cannot turn on your radio and tune it to their frequency.)

     

    You need to find out why Safari is starting automatically on login, and why it is automatically loading some CNET page.  Does the problem continue if you start up in Safe Mode?  What about if you try another user account?

  • Badunit Level 6 Level 6 (11,400 points)

    You have jumped to the conclusion that because Safari is opening on its own and cnet wants to download something with the word "html5" in it that HTML5 has somehow done something to your system.

     

    html5 test db is nothing special.  Look it up on Google.  You can get rid of the warning message by setting Safari security preference to allow the storage. You have your Safari preferences set to ask you always.

     

    As for the automatic startup issue, one other place to look is to right click on the Safari icon in the dock and see if it is set for "open on login".  I think this is directly tied to the login items system preference but it can't hurt to look.

     

    There are a number of posts on these forums and other places about Safari automatically starting when it is not on the list of login items.  One is here:

    https://discussions.apple.com/message/6775001?messageID=6775001

Previous 1 2 3 Next