Previous 1 4 5 6 7 8 Next 155 Replies Latest reply: Jan 12, 2016 10:48 PM by Mr. SBLee Go to original post
  • Virgil Questions Level 1 Level 1

    Had same problems and tried all the suggestions.  My Airport provides me with two Networks, I had one Mac on the first, and the Macbook Pro and they other.  I put them both on the same Network, problems sovled


    (Not sure how and when I put them on different Networks, but that's life lol )

  • ChampionHannah Level 1 Level 1

    As long as you don't press done after putting in your information it should work. It worked for me Good luck

  • Rathbone Hall Level 1 Level 1

    Scan the Support Community sites. Apple TV losing connection is prevalent. The many postings point out the problem occurs with Apple TV1,2and 3; with different brands of router including Airport Extreme; from current and past versions of iTunes; after varying periods of working well.....minutes, hours, days; losing connection with Home Sharing and loosing Airplay; whether the router and Apple TV are in same room or separated by distance; after trying innumerable posted 'fixes'; after exchanging for a new Apple TV.

    Readers, please don't post a fix until you check it works for atleast a week.

  • MacTavish Level 2 Level 2

    This thread is NOT about the AppleTV, of which I still own the first generation of. And while "home sharing" is connected, this thread is simply about: (I will just copy the very first post below so as to be clear why this thread was started in the first place, in in my opinion has been SOLVED already, as it's the "behavior" as of now)




    "When i go to advanced folder and turn home sharing on, type in my account and password then hit create home sharing. Then the next window pops up and i hit done the sharing folder in the left column just disappears. Tried creating new apple account and still didnt work. Help please!"


    Read the last page or two, and it will be clear enough.

  • Scaningen Level 1 Level 1

    I have the same problem, the shared device don’t show in iTunes.


    First I used the stream function of iTunes library in iPad 3. It didn’t work.  Tried everything, tampered with the router and with Windows Firewall, sharing and soon.


    But I had to open iTunes as administrator, did set the iTunes shortcut to always open as administrator and get the message if I want the program to be able to make changes to my computer.


    Then it was possible to see and play the library on the iPad.


    But still no sign of the iPad device in iTunes, if I open Preferences -> Sharing it says: “Status: On, no users connected”


    Then I downloaded the iTunes Remote and it worked fine on the iPad but the device doesn’t show up, but a Playlist called “Remote” show what is chosen to play at the iPad.


    Still the “Status: On, no users connected” is shown.


    And with the remote if you want to connect another device to the Home Sharing you need to click on the device that Is said to show in iTunes and fill in a pin code shown in the Remote.


    Neither is it possible to sync the iPad via Wi-Fi, nothing shows anywhere. But when I did set it to sync via Wi-Fi  iTunes wasn’t opened with Administrator privilege. Going to try that another day.


    I sync with FileApp Home net app and it works fine, also some documents program was able to access WM media Streaming files.



    Windows 7 64 bit, iTunes 10.6, iPad 3.


    The PC is on cable and the rest on Wi-Fi. All devices, PC, iPad3, a couple of Android Phones show up in the router administration as part of the network with their ip addresses.

  • mrniceguy12 Level 1 Level 1

    YOU ALL NEED TO DOWNLOAD APPLE'S BONJOUR. I accidently uninstalled it and you need it for home sharing.

  • MacTavish Level 2 Level 2

    I have always had Bonjour installed and this issue was solved for me in my post 2 back. No problems anymore as now I understand how it works. Perhaps it's advice for someone like you who deleted it somehow but that was never a issue for me!

  • Lillybellasmom Level 1 Level 1

    I did this and mine started working, however if I shutdown my computer I have to turn home share off and on again. I hope they fix this, it is a bit annoying and had me quite upset until I tried this. Thank you!

  • EZCullen Level 1 Level 1

    I was having the same problem and I fixed it... My brother could see my library on his computer but I couldn't see his library on mine. I turned on home sharing under the "advanced" tab. I then went to itunes preferences and turned on "share my library on my local network"


    ... still nothing happened until FINALLY I went to Itunes/Preferences/General and then in the first area of boxes clicked on the box "shared libraries"


    Almost instantly my brothers library showed up on the sidebar at the left btw STORE and GENIUS.


    Hope this helps some of you!

  • seaj11 Level 1 Level 1

    Absolutely nothing in this thread has worked for me. I just got a new MacBook Pro, OS 10.8.1 with the iTunes 10.6.3 update, and the first day I got the MacBook (before the update) I was able to access my iTunes library of my desktop computer, an iMac running 10.4 and iTunes 9. Now, a few weeks later, I tried it again and it won't work. The Apple IDs match, there is no firewall running, I reset the router, I tried turning Home Sharing off and then on (WITHOUT hitting "done"), all relevant preferences are enabled. The iMac's library appeared finally under "Shared" in the MacBook's iTunes, and when I clicked on it it began to load then abruptly disappeared. And no, no one had turned off the iMac. Oddly, the iMac's iTunes can load and play the MacBook's library just fine.


    I have been researching and fussing with this for an hour and finally decided to post. I know these 2 computers can connect, and I haven't changed anything related to the network configuration since I got the MacBook. So, I imagine it is the iTunes update. If nothing else I will import my backup CDs into the MacBook but I don't see why I can't access the iMac's library. If an older iTunes can read a newer iTunes why isn't the opposite true? Is this an issue with the update? Am I just out of luck until another software update?

  • heroes_villians Level 1 Level 1

    Surprisingly, this actually solved the issue for me. I know this may not be the case for everyone, but seeing as I also have two networks, it seems both my computers need to be connected to the same network. Thank you so much for pointing this out.

  • cherub2187 Level 1 Level 1

    I had the hardest time trying to figure it all out (Windows 7 iTunes latest).  Everything was working yesterday when I bought my Apple TV 3 then today it just dropped off of my homeshare.  I tried everything but a few posts up had it right (also another site had this solution for Windows users).  Go to Control Panel --> Programs --> Programs and Features --> then Right-click on Bonjour then repair.  Make sure iTunes is not open when you do this.  Once it repairs, open up iTunes.  This worked for me.  I had a feeling it wasn't iTunes, firewall, nor Apple TV that was at fault.  Bonjour is the link to them all for media streaming/syncs.  Hopefully this helps.


    Edit: The reason why it dropped off was because there was a huge Windows update overnight.

  • Tex Arcana Level 1 Level 1

    Can anyone give any more color on the Windows update?  I have the exact same problem with iTunes on Win7x64 and my iPhone/iPad, but repairing Bonjour didn't help. So I'm stuck.

  • crosleyno Level 1 Level 1

    I had same problem as you all.


    But i found a way. My problem was my router. And it did not let my apple tv connect to my homeshare.

    Also it stopped Mirror on my Ipad.


    But here is my way:


    1. Enable UPnP in my router

    2. Port Forwarding on my LAN settings, i made a rule for my apple tv.


    Port for apple TV that need to make a rule for on my router:


    TCP-port 123 og 3689

    And UDP-port 123 og 5353.


    I checked my ip number on apple tv and it was


    so i made an rule on Port Forwarding


    123   -   - 3689


    That was enough for my router then homeshare worked.


    See my way on my blogg



    hope i could help :-)

  • John C - from UK Level 1 Level 1

    I have spend hours and hours looking at this problem and finally managed to figure out what was going on.


    My symptoms: I couldn't see the itunes shared library from my ipads (1 and 2) and my 2 apple TVs


    It used to be working fine and I couldn't figure out what had changed


    I had tried:


    • Turning off and on sharing (about a million times)
    • Rebooting (more than a million)
    • Disabling Norton
    • Removing Norton
    • Disabling Windows firewall



    None of which would fix the problem.


    It turns out the problem was one of my iphones was trying to sync wirelessly to the itunes.  For some reason this seems to consistantly bugged up the sharing functionality.


    I had to physically connect the iPhone vua USB turn off the wireless sync and now it works!!


    I hope that helps someone else.

Previous 1 4 5 6 7 8 Next