Previous 1 5 6 7 8 9 Next 155 Replies Latest reply: Jan 12, 2016 10:48 PM by Mr. SBLee Go to original post
  • xJoe999 Level 1 (10 points)

    Hi crosleyno,

    thank you for this post, it is very useful! I am on 50% now, works fine for while ...

    I tried what you proposed, because the router seems to be my problem. Unfortunately I have Huawei HG622u from O2. I could not put in everything as you described, only allowed the 3689 port for my AppleTV. The router does not accepted the prot 123. Any idea?

    Thanks in advance.

  • JohnnyG76 Level 1 (45 points)

    running iTunes using the "Run as Administrator" command fixed my issue. Now everything is being detected properly. My guess is there are some functions that require to be excuted by the actual Administrator account at least once.

  • xJoe999 Level 1 (10 points)


    but it is in Windows, right? How about iMac?

  • JohnnyG76 Level 1 (45 points)

    @Joe99 yes in my case I'm using Windows 7 Pro 64bit. Sorry I can't help you on your Mac

  • xJoe999 Level 1 (10 points)

    OK, no problem.

  • archiller Level 1 (0 points)

    I've been having this issue. Using a Macbook Pro 15" retina with apple tv 3rd gen. Home sharing wouldn't appear anymore on my itunes. After trying everything on here I turned my wifi on and off and it worked. Bottom line is if you have a repeater or multiple networks at your place you have to reset the wifi network. Good luck

  • Daniel Frye Level 1 (5 points)

    Thank you! Thank you! Thank you! Turning off my wifi and turning it back on combined with not hitting the done button in the home sharing fixed my problem. I am very grateful as I have been working on this issue for two weeks. Thanks again

  • Daniel Frye Level 1 (5 points)

    Try not clicking the "Done" button and turn your wifi off and then back on again. This worked for me.

  • xJoe999 Level 1 (10 points)

    Hi, where do you turn your wifi on and off? On your Macbook or Apple TV?

    I have been facing this issue for 6 months now. Unbelievable, but nobody can help. After Done Home Sharing disappears and ATV loses connection with my iMac after several minutes. HELP!

  • deadams Level 1 (0 points)

    I'm trying to run homesharing between an iMac and Mac Book Pro.


    I've updated my router firmware, iTunes, reset my wireless connection on both computers, I've refreshed my router, shut down both computers and rebooted, I've disconnected from home sharing and reconnected.


    With the exception for a brief minute after I rebooted my router, I have been unable to see the other computer from home sharing.  All I ever see is the icon for homesharing but it doesn't show the other computer's contents.


    Why did it work for a minute then go away?


    I'm running 10.6 OSX on both units and the latest iTunes, 10.7 I think.


    Help, please.

  • Daniel Frye Level 1 (5 points)

    Turn the wifi off and then back on--on your Mac. Also check your preferences for Sharing unders systems preferences. May sure, when you turn on home sharing in itunes that you DO NOT click the "Done" button. Just scroll over and select a playlist or your Music libray on the left to leave that screen.


    Also make sure all your computers are using the same iTunes login. This was very confusing for me as my login goes back many years ago when all that was required was a user name...not an email. Initially, I logged in with my and that set up a whole new iTunes ID. When I realized this I relogged in with just my username (no "@") and password and then I found all my original music and movies and tv shows.  Once I got the home sharing working it found everything.


    Good luck.

  • Daniel Frye Level 1 (5 points)

    Do not click the DONE button. Just select a playlist or the "Music" icon on the left. Turn the wifi off and on, on your computer. The icon is located in the top right of the gray bar that runs the length of your screen. The icon looks like a grouping of arched lines getting shorter in descending order.

  • JohnnyG76 Level 1 (45 points)

    I guess I spoke too soon...

    after a few days of running iTunes as an Admin (windows 7 64-bit).. I'm back to where NO devices on my home network can see my itunes library..

    I've rebooted my computer and router, did a repair to the program itself under "Programs and Features" in the Windows control panel. I've restarted the Bonjour service several times.. and I even DISABLED my Windows Firewall completely.. still no go..


    I can't believe its THIS complicated to get something like this working!! VERY frustrating!



    JohnnyG76 wrote:


    running iTunes using the "Run as Administrator" command fixed my issue. Now everything is being detected properly. My guess is there are some functions that require to be excuted by the actual Administrator account at least once.

  • SevenTimes7 Level 1 (10 points)

    This solve my issue... not pressing the Done button... silly. Thank you!!

  • kgt1996 Level 1 (0 points)

    I had a similar issue to yours, whenever i set up homesharing, it showed up on the side but it didn't show my email/username thing... do you know what i mean? i have been using my mom's computer for my itunes forever but then when i try and transfer it to my new laptop it says it will erase and sync everything on my ipod grrrrrrrr why does itunes have to be so mean!!!!

Previous 1 5 6 7 8 9 Next