Previous 1 2 Next 25 Replies Latest reply: Jun 22, 2011 2:18 PM by R_Brackin
corcoraniii Level 1 Level 1 (0 points)

I have a Mac Pro 3,1 Quad-Core Intel Xeon, 2.8 GHz with an ATI Radeon HD 2600 XT graphics card..  I have 12 GB of memory.


When I went to download FCP X from the App store, I got the message that it would not work with my graphics card.  Same for Motion 5 and Compressor.


What is the least expensive card I can purchase that will let FCP X run on my machine?  Also, I assume it is something I can replace myself, as I have done with memory.


Thanks for any help.

Mac Pro, Mac OS X (10.6)
Previous 1 2 Next