Previous 1 9 10 11 12 13 14 Next 198 Replies Latest reply: Aug 23, 2014 2:05 PM by blairthornton Go to original post
  • Luis Sequeira1 Level 6 Level 6 (8,380 points)

    grandtheadmiral wrote:


    I've had beach all issues with projects carried forward from 10.0.2 and 10.0.3, and some weird new crashes. But with a brand new project, started clean in 10.0.4 FCP has been awesome. Faster, snappier, never crashes, works great.


    Like apple recommended, don't upgrade FCPX if you're in the middle of a project. Try to finish them up first.


    Good recommendation.

    And if such an "upgraded project" is causing these troubles, an obvious thing to try is to create a brand new project and copy and paste the contents of the problematic project into it. At least, it won't hurt to try.

  • Baron Sekiya Level 1 Level 1 (20 points)

    I found a workaround for the beachball problems (hopefully).


    I had to purchase Event Manager X


    EVX allows just the events/projects I'm working on to show-up in FCPX and it seems that doing that makes things run more smoothly. I mostly work on short less than 5 minute projects and the crashes were killing me. So far after editing three short videos things seem to be running smoothly. In fact I took my FCPX icon out of the dock and just leave EVX there when I want to start Final Cut.


    I haven't fully tested EVX over the long term, only found out about it from a video forum online but it seems to work.

  • Sofus Comer Level 1 Level 1 (15 points)

    Hi Baron, thanks for the tip on event manager x.

  • Sofus Comer Level 1 Level 1 (15 points)

    I still think it has to do with the codec your working with.

    I was in pain with beachball until i only had the h264 nikon d800 files in fcpx.


    So for all the folks having beachball spins. Please include the codecs used at the time of beachball and also the names of all the codecs found in your events folders.


    I am reimporting all my xdcam ex files to see if fcpx still works smooth after that. Will post back to tell more.

  • tomhen77 Level 1 Level 1 (0 points)

    If you have made an upgrade from 10.0.3 to 10.0.4 and still have that error (spinning ball on timeline) you should check your EVENT, click ctrl + a for all files and Use a transcode option again.


    In my case it helped. It turns out that not all files correctly transcode.

  • rgomez Level 1 Level 1 (0 points)

    In my case, I'm not even using any "codec", at least not in the video sense of the word. This project (the only I have right now to test) is a stop motion, so all are jpgs files. Still, not even the files are displayed in the "canvas" area of the screen, and the spinning ball never goes away.


    I have another one where I do have some video, now that I remember, but if jpg files doesn't work, I don't see why any other thing should work. I don't know what, but they certainly did something from 10.0.2 -> afterwards that messed up with my MBP.

  • Tom Wolsky Level 10 Level 10 (113,785 points)

    How much RAM do you have> How large are the images? What format are you working in?

  • montywent Level 1 Level 1 (0 points)

    I've been following this thread for some time and there have been a number of fixes only to have the spinning beach ball return or some glitch surface to mess things up. So is "event manager" the fix all or is it a specific fix for some while not doing much for others.


    I'm sorry to say this because it's stating the obvious, but with all the brain power at apple why do we continue to have these issues? Other than comments from very frustrated fcpx users no one has really offered a good reason why we have been so forgotten.


    The biggest concern I have is an opinion mentioned a while ago that apple has much better income from other products and it's just a business move not to spend the needed time and money to bring fcpx up to specs...


    I have too much money invested in hardware/software and a computer to start over again [new editing program], but as I get more work it is becoming clear that I need a stable system/program, yet no other system seems perfect when you read other editing forums...what to do in the long run???

  • rgomez Level 1 Level 1 (0 points)

    Well, just installed the latest trial, 10.0.5, and I still have the same problem. I can't even see the jpg files in the "preview" pane (can't remember the name right now). Beachball.


    I haven't even tried opening any project. This is just trying to see the files in one of the events. And I don't have so many events, just 4 or 5.


    I can't believe this. I just can't believe this.


    I haven't tried creating a new user, or using Even Manager X (I'm burning this 5 usd just to try this), but I seriously doubt anything will change. Hopefully I'm wrong, but I have lost my faith. And after the Mac Pro "updates" today, I think it is clear where Apple is sending the Pro users...

  • rgomez Level 1 Level 1 (0 points)

    Well, a little bit more info. I tried with Event Manager X and it didn't change anything. I still get the beachball.


    I create a whole new user and now it does seem to work. So there must be something messed up in my user that is creating all this mess. Any idea of how to clean this up as if it was a whole new installation, without making it a whole new installation (or using a different user in my machine)


    Of course I would like to be able to open and edit the projects I already finished there, but at least I would like to be able to do a new one I have to start *soon*, and maybe later see how to make the others work.


    Any idea would be greatly appreaciated.

  • rgomez Level 1 Level 1 (0 points)

    No luck yet. I've AppZapped it, moved the events and projects library, and so on, trying to get a "fresh install" but there must be something missing.


    I guess my only option is to use the second user to edit now, while somehow magically it gets fixed in my normal user account.

  • Timothy Palmer-Benson Level 1 Level 1 (10 points)

    Is there any truth to the fact that FCP X runs almost flawlessly on a fully pimped out top of the line Imac with16mB 3.4 Quad 7core i7? From my experience it does. It will play back at least 4 multiclips without hiccup if you have a thunderbolt drive attached. On the other hand, a 2010  Mac Pro 3.33GHz six core, ATI 5870 video, 24GB RAM with 0 Raid can't do it although the Macpro may render faster. Beach balls have occured for me when there is something wrong with the audio. When I have seen this I have always converted to AIFF and the problem has gone away.

  • pocketdev Level 1 Level 1 (0 points)

    I bought FCPX a couple weeks ago after having previously used the trial version with good results.  I did a bunch of editing with no problems-- it was really speedy, to the point where I don't even use proxy media, because it can do it all in realtime.


    Then one day I was shooting and my camera overheated. It stopped recording in the middle of a long take and then resumed when it had cooled down (I didn't notice it at the time.)  I had trouble importing these files.  Since this date FCPX has been very sluggish.  I deleted the problematic files but no luck.


    As I write this I've got a beach ball.  There is no real access to the drive iwth the media, and there is no real use of the CPUs going on right now.  It isn't spending any time doing either, and it *should* be rendering a transition.  In fact it is doing a rendering job that would have been a second or two only a week ago, but now is taking 15 minutes -- so far.  And it is doing it super, super slow.  Not using the CPU not hitting the drive, so it isn't held up from lack of resources.


    Maybe it is because I added my iMovie events (using the "import Imovie Events" menu option.)  OR maybe it is because I added a bunch of effects. Well, I deleted everythign from the Motion Templates folder but that didn't change anything.


    I'm at a loss now. 


    It is almost like FCP X uses a system process to decode video and that process is wedged or hung, or consdtantly crashing as FCP X waits to get its frames back.


    Certainly it isn't because it is taking too long to get data off the disk (it is not even trying) or because I lack CPU (all 4 cores are idle.)


    So, this isn't the lack of proxy media.  It is a bug.


    The footage is all H.264, with no proxy media or optimized media.

  • Timothy Palmer-Benson Level 1 Level 1 (10 points)

    Try with  importing a new event and have FCP import them and optimise them. Best results are with optimised files, better quality.

  • pocketdev Level 1 Level 1 (0 points)

    I found the problem!


    Solution:  Delete the bogus folders in your Movies/Final Cut Events/  folder.   (left: Color Presets, Effect Browser Thumbnails, Export Presets and Render Files)


    Somehow in my root drive, in the Final Cut Events folder there were some bogus folders.  For example "Camera Render Files" and "Peaks Data" were in there, as if "Final Cut Events" was the *event*.  So it was seeing "Camera Render Files" as an "event" and trying to deal with the massive amount of subfolders there.


    At least that's what I think happened.  Anywy, getting rid of this junk  fixed it.