2 Replies Latest reply: Jun 23, 2011 5:55 AM by Terraaustralia Branched from an earlier discussion.
YUKON_HO Level 1 Level 1 (0 points)

I am having this problem with my MAcBook Leopard (not snow leopard) .

 

My Mac would not recognize the network it is assigned to and after repeating multiple times -> Join other network -> click on the network;  it seems to work .

 

While logged in the network it doesn't seem to drop connection though( as some have reported).

 

This is frustrating.

 

A recent Airport patch from apple didn't seem to fix the problem.

My Ipod (linked to the same network ) seems to work just fine (not sure if that helps).

 

Any suggestions ?

  • 1. Re: Network Issues
    greg sahli Level 7 Level 7 (23,760 points)

    I suggest you get iStumbler to help in troubleshooting:

    http://www.istumbler.net/

     

    Then, give us all the details you observe there.

    Signal strength and strength of neighbors on the same channel are first priority info.

  • 2. Re: Network Issues
    Terraaustralia Level 1 Level 1 (35 points)

    I have a small network and have found WiFi a very difficult subject to deal with because you cannot measure the power of the signal other than through the radiating lines in the finder. Poor performance of WiFi is often due to weak signals. In my case a modem signal deteriorated and I had no way of knowing at the time. When I bought a Dratek Vigor 2710vn with 80211n the signal was on steroids and I could connect to the Soyuz spacestation. Keep an eye on the radiating lines, assuming you have your WiFi symbol in the Finder that is. (Tick box - Show Airport status in Menu bar) in Network window and see if they fluctuate.

     

    Second suggestion is to go to System Preferences>Network>Airport>Advanced. Her, delete existing network name then re-create the network as a Preferred Network. Click OK. That should take you back to the previous window. Click on Advanced again, click on the network name and enter WEP password and click on box Remember this network. Click on Add. Then Click OK. Now you have a preferred network which Mac will seek and link automatically. This will cancell out the computer to computer networks you may have created via Join Other Network.

     

    Three. Be careful creating networks via the WiFi Finder icon as these may become computer to computer networks. That means your mac acts as a router and not simply a receiver of the signal. Check the windows carefully as you proceed watching for the text, computer to computer, as this happened automatically in Tiger, With Leopard I am not so sure as it has been better behaved for WiFi.

     

    You do not indicate how your network is structured. Are you using an Airport station or a modem with WiFi?

    If the latter, I have moved to setting fixed IP addresses in my modem so I can connect with IP number to other computers via Go. If you stick with automatic rotating addresses means that connecting to other computers relies on afp or the computer name, which is OK, but I like the precision of using the IP address.

     

    Since I have adopted this practise WiFi has been more reliable.

     

    In Network>Apple Talk ensure box Make Apple Talk Active is ticked, Go to Configure and choose manual. Go to Node ID enter 1. Go to Network ID enter 2. This ensures the O/S does not get confused switching between Apple talk systems.

     

    Finally, if the above does not work you will need to trash a number of networking prefs and re-build your connections. Try the above suggestions and if that fails to improve look for these files (names may vary slightly).

     

    /Library/Preferences/com.apple.sharing.firewall.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.internetconnect.plist

     

    /Library/Preferences/SystemConfiguration/preferences.plist

     

    /Users/YourUserName/Library/Preferences/com.apple.systempreferences.plist

     

    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

     

    Look for files like this also...

     

    /Users/YourUserName/Library/ByHost/com.apple.PrefPane.Network.<12digitHexNumber> .plist

     

    Or...

    /Users/YourUserName/Library/Preferences/ByHost/com.apple.networkConnect.<12digit HexNumber>.plist

     

    /Users/YourUserName/Library/Preferences/ByHost/com.apple.networkConnect.<etherne t MAC address>.plist

     

    Reboot needed after trashing them.

     

    That should fix everything.