1 2 Previous Next 15 Replies Latest reply: Jul 12, 2011 4:35 PM by SingaporeDave
SteveBenner Level 1 Level 1 (5 points)

I have created Quick-Clusters in Compressor, but whenever I try to encode using one, it fails.Screen shot 2011-06-23 at 11.50.13 AM.png

Not sure what to do here.

  • 1. Re: Mutli-Core and Multi-Thread Clusters?
    sowattmusic Level 1 Level 1 (5 points)

    Same here

    Different error message

     

    HOST Quicktime Error: 0

     

    When using quickcluster exporting from within fcpX.. it works, but it is slow and I do not see any advantage.

    But using quick clusters with video files crated in fcp6 or any other file, i get error messages-

    I can use "My Computer" but the processing speed is absolutely not good then.

     

    to be fixed in the next release

  • 2. Re: Mutli-Core and Multi-Thread Clusters?
    My voice is my password Level 2 Level 2 (270 points)

    is it still trying to use quickcluster from version 3.5.whatever at the same time?  seems like a conflict try disabling the older one leaving only the new one for compressor 4

     

    -mvimp

  • 3. Re: Mutli-Core and Multi-Thread Clusters?
    sowattmusic Level 1 Level 1 (5 points)

    Well

    It is a totally fresh install with only fcpx, compressor4 and motion *new#

    So there is no trace of 3.5 in this install.

    I did unmount the system disk which contains fcs 2

  • 4. Re: Mutli-Core and Multi-Thread Clusters?
    SteveBenner Level 1 Level 1 (5 points)

    Has anyone gotten Compressor 4 to work with all cores and threads successfully?  If so, what is the exact process?

     

    I've used Clusters in Compressor 3 no problem...so I am not sure what is going on.

  • 5. Re: Mutli-Core and Multi-Thread Clusters?
    sowattmusic Level 1 Level 1 (5 points)

    There are clearly unsolved issues with compressor 4 and cluster processing.

    At this point I think all we can do is wait for appel to release a fixed version

  • 6. Re: Mutli-Core and Multi-Thread Clusters?
    SteveBenner Level 1 Level 1 (5 points)

    Okay...I wasn't sure if it was me or if this was a major program problem.  I don't understand why Compressor just doesn't use all available cores and threads to begin with.

  • 7. Re: Mutli-Core and Multi-Thread Clusters?
    ctzsnooze Level 1 Level 1 (40 points)

    It works fine for me, though it took me quite a long time to figure out how.  Other threads describe what to do.  Don't use quick clusters because they don't work.  Make the other type of cluster.  Select services only used in cluster checkbox.  Then you can drag the services up to the box on the right in the cluster admin thing.  Set to use however many cores you want in the service settings before creating the cluster.  Put a copy of FCPX on each machine you install Compressor 4 on and intend to use for clustering when selecting FCPX > Share > Export using compressor settings.

     

    Sorry to be so brief here but there are detailed instructions in other threads.  Do everything above and it works fine.  Not fast for small files, but fast (and without tying up your own machine) with large files.

     

    Cheers - c.

  • 8. Re: Mutli-Core and Multi-Thread Clusters?
    Waymen Level 5 Level 5 (5,635 points)

    It's working for me with Compressor 4 on my quad-core Mac Pro. After setting up a QuickCluster with services and with a given name and then I select that same-named cluster in the submit dialog. When I do this with video files that are over a certain length (more than one minute?) it will use all of the cores on my Mac Pro with multiple, active instances of the compressord process. In fact, all of these active processing threads are shown as separate entries in the Share Monitor application (each with a progress bar, the segment of the video that is being compressed, and an ETA).

     

    I think you MAY also need to make certain that you have disabled the cluster controller that is part of Final Cut Studio/Compressor v3 (check your settings in the Apple QMaster panel of the System Preferences, I've set mine to "Services only" and deselected both "Rendering" and "Compressor"). I'm not sure about this (that's why I say "MAY"), but it's worth a try if you are having problems.

  • 9. Re: Mutli-Core and Multi-Thread Clusters?
    sowattmusic Level 1 Level 1 (5 points)

    Thanks for the answer. You mean that even tough I booted from a brand new partition, I should disable the old Qmaster processing in the inactive partition.

    If I understand right I must boot in my FCS 2 or 3 partition, then disable all qmaster, then shut down and reboot with the new FCPx partition and it should work.

    I will try then.

  • 10. Re: Mutli-Core and Multi-Thread Clusters?
    Waymen Level 5 Level 5 (5,635 points)

    What exactly do you mean when you say "brand new partition?" Do you mean that you are booting from a completely new and different installation of Mac OS X? If, however, by a new partition you mean that you've just moved the applications to a different disk then that may not work (in fact, I think that the FCPX applications must be stored in your home or boot Application directory).

     

    In any case, be aware that in order to use more than two cores with Apple's H.264 codec you must enable job segmentation (it's a checkbox in the codec/preset inspector panel titled "Allow Job Segmentation"). It appears, however, that some presets do not allow the preference for job segmentation to be changed.

     

    I'm assuming that you've also set up QMaster correctly and make certain that you've specified more than one instance under the "Apple Qmaster > Share This Computer > Setup > Services:Compressor > Options" panel in the Compressor v4 application.

  • 11. Re: Mutli-Core and Multi-Thread Clusters?
    sowattmusic Level 1 Level 1 (5 points)

    No it is a brand new formatted drive witha new os etc.  I followed the guideline that says that fcpX must be installed on a newly formatted system drive.

    I will check the job segmentatation preferences

    As far as qmaster setting, ye  I turned onthe 24 cores to process the data.

    How many cores do you have working on your system?

  • 12. Re: Mutli-Core and Multi-Thread Clusters?
    Waymen Level 5 Level 5 (5,635 points)

    I'm running on a quad-core system. As for the number of Qmaster instances, the Compressor User Manual says that you should allow 2GB of DRAM for each instance (a recommendation, not a hard requirement). I'm not sure what you mean by your "24 cores to process the data" (instances?), but that would suggest that your system should have 48GB of DRAM. The Compressor User Manual even warns about setting too many instances since that can actually result in a decrease in total throughput. However, I think the 2GB requirement is overstated, so you can probably exceed that limit if you have less memory but plenty of extra processor cores.

     

    My quad-core system has 6GB of DRAM and I've enabled up to 3 instances and when I run Compressor v4 with that setup I often show 0% CPU idle from within the Activity Monitor (that is, all four cores are running at 100% utilization). However, if I turn off sharing (Qmaster) then I show about 50% idle. The encoding times pretty much follow with the CPU utilization, although there is some notable overhead at the beginning and ending of the job (which appears to run on one thread, so effectively on a single core).

  • 13. Re: Mutli-Core and Multi-Thread Clusters?
    SingaporeDave Level 1 Level 1 (0 points)

    There are a few simple things that I would start with.  I was able to get Compressor 4 working on all my cores and even able to "oversubscribe" if you will.  I was even able to do it with Compressor 3.5 installed still.  Not meaning to intentially, but when going to the app store and purchasing Compressor, you dont have much of an option to move it to another drive or partition with ease. 

     

    Start by installing and restarting your computer. Not sure if this is neccasary, but it seemed to clear out a few processes that were running. 

     

    Second, go to preferences and go into apple qmaster.  Stop sharing all services.  You wont be using this anymore.

     

    Launch Compressor 4.  Go to apple Qmaster within Compressor 4.  Click on Share this computer.  Click on quickcluster.  You can then click the next two options for renduring and compressor and then you can control the number of instances started by clicking on the options tab.

     

    Once you import the video and add setting click submit. Select the name of your quickcluster and share monitor will pop up.  The rest is history, just like old days with 3.5. 

     

    Hope that helps.  Its a simple process it just took a few minutes to figure out.  The documentation for setting up a quickcluster really sucked. 

     

    Oh, once downloading and starting up Compressor 4 for the first time, you should go get updates, looks like there was a patch for some of the video formats.

     

    Cant promise it will fix everything but I couldnt even find a simple setup doc or thread.

  • 14. Re: Mutli-Core and Multi-Thread Clusters?
    SteveBenner Level 1 Level 1 (5 points)

    I tried this and it worked once.  Now when I start sharing when opening compressor, the cluster does not appear.  Very odd behavior.

1 2 Previous Next